flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Martin <windo...@gmail.com>
Subject adc byte decode errors in Flash Builder 4.7
Date Wed, 14 May 2014 18:24:11 GMT
Hey everyone,

I've finally left design view and moved onto Flash Builder 4.7.  And with
that I also upgraded my proxy class set from the Flex Builder 3 generator
to the one in Flash Builder 4.7, which means we now get HTTP 500 responses
:D  But a little oddity has crept into my dev environment.

It appears that the "incremental build" functionality in Flash Builder 4.7
is having issues when using the proxy swc files (fiber.swc and
playerfds.swc).  I keep getting abc byte decode errors every so often.  A
clean and rebuild fixes the problem, but with this large project it can be
a bit of a pain.  In my research it seems people are saying that this can
happen when included swc files are compiled with a different framework
version than the main project.  I believe this matches what i'm seeing.
I'm on Flex 4.12.0 and I suspect the two above mentioned swc files were
compiled with Flex 4.5 because of their location path (C:\Program
Files\Adobe\Adobe Flash Builder 4.7 (64
Bit)\eclipse\plugins\com.adobe.flexbuilder.project_4.7.0.349722\fiberSwcs\4.5\libs\playerfds.swc).
In the fiberSwcs folder we only have two subfolders 3.6 and 4.5.

So in the end I'm wondering if we don't have the ability to recompile these
in the latest framework.  Were they included with the donation, or Adobe
kept these as they are really part of Flash Builder 4.7?

Regards,

Chris

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message