flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: [DISCUSS] Discuss Apache Flex Falcon 0.0.1 RC3
Date Fri, 18 Apr 2014 15:04:02 GMT
Justin,

It looks like you are trying to run the FalconJX Cross-Compiler on the
Flex SDK.  That is definitely not supported.  I will add this to the
RELEASE_NOTES

I was able to run Falcon on the Flex SDK and get a swc and swf.

-Alex

On 4/18/14 12:15 AM, "Justin Mclean" <justin@classsoftware.com> wrote:

>Hi,
>
>> Please Justin, the only goal for this package is to be upstream of
>>FlexJS.
>> To me, it does not matter how it works against the Flex SDK.
>
>So perhaps we should rename the project from "Apache Flex" to something
>else? :-)
>
>In good conscious I can't vote +1 on a release if it doesn't actually
>work.
>
>The compc issue is nothing to do with the Flex SDK as far as I can see.
>
>Can you compile this class?
>
>package
>{
>	public class Dummy
>	{
>		public function Dummy()
>		{
>		}
>	}
>}
>
>Here's I get:
>
>./compc -include-sources dummy.as -o dummy.swc
>
>Using Falcon codebase: ./../../compiler
>Using Flex SDK: /Users/justinmclean/Documents/ApacheFlex4.12released/
>Exception in thread "main" java.lang.UnsupportedOperationException
>	at 
>org.apache.flex.compiler.internal.driver.as.ASBackend.getSourceFileHandler
>Instance(ASBackend.java:70)
>	at org.apache.flex.compiler.clients.MXMLJSC.<init>(MXMLJSC.java:211)
>	at org.apache.flex.compiler.clients.COMPJSC.<init>(COMPJSC.java:128)
>	at org.apache.flex.compiler.clients.COMPJSC.main(COMPJSC.java:116)
>
>Can you tell me why this isn't working at least?
>
>Thanks,
>Justin


Mime
View raw message