flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik de Bruin <e...@ixsoftware.nl>
Subject Re: [DISCUSSION] Release Apache Flex FlexUnit 4.2.0 RC4
Date Thu, 10 Apr 2014 09:39:04 GMT
Running 'ant package' a second time, with nothing changed etc. etc.
SUCCEEDS, weirdly enough... Your choice: I'll gladly change my vote to +1
as the code seems to work as advertised, eventually ;-)

EdB




On Thu, Apr 10, 2014 at 11:31 AM, Erik de Bruin <erik@ixsoftware.nl> wrote:

> All of those ant command should be run from the top level directory (and
>> none in FlexUnit4 sub directory)  but you can get away with just an "ant
>> clean" and "ant package".
>>
>
> When I run the 'ant thirdparty-downloads' task from the top level
> directory (as the README seems to indicate) it gives me this error:
>
> <error>
> Buildfile: /Users/erik/Documents/ApacheFlex/git/flex-flexunit/build.xml
>
>   [taskdef] Could not load definitions from resource
> net/sf/antcontrib/antcontrib.properties. It could not be found.
>
>
> BUILD FAILED
>
> Target "thirdparty-download" does not exist in the project "FlexUnit4".
> </error>
>
> When I run it in the directory 'FlexUnit4", it succeeds. Another amendment
> to the README needed, or is something wrong with the build?
>
> Also, when I run 'ant clean' in the top level dir, I get a whole bunch of
> this error:
>
> "[taskdef] Could not load definitions from resource
> net/sf/antcontrib/antcontrib.properties. It could not be found."
>
> Just running 'ant' succeeds. If I run 'ant package' after that, this time
> it ran a whole bunch of tests, successfully, but then it fails with this
> message:
>
> <error>
> ...
>
> aircilistener:
>   [taskdef] Could not load definitions from resource
> net/sf/antcontrib/antcontrib.properties. It could not be found.
>
> init:
>      [copy] Copying 2 files to
> /Users/erik/Documents/ApacheFlex/git/flex-flexunit/FlexUnit4AirCIListener/libs
>
> compile:
>     [compc] Loading configuration file /Applications/Adobe Flash Builder
> 4.7/sdks/4.11.0/frameworks/flex-config.xml
>     [compc] Error: PermGen space
>     [compc]
>
> BUILD FAILED
> /Users/erik/Documents/ApacheFlex/git/flex-flexunit/build.xml:187: The
> following error occurred while executing this line:
> /Users/erik/Documents/ApacheFlex/git/flex-flexunit/FlexUnit4AirCIListener/build.xml:74:
> compc task failed
> </error>
>
> EdB
>
>
>
> --
> Ix Multimedia Software
>
> Jan Luykenstraat 27
> 3521 VB Utrecht
>
> T. 06-51952295
> I. www.ixsoftware.nl
>



-- 
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message