flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: [VOTE] Release Apache Flex SDK Installer 3.0 - RC7
Date Sat, 15 Mar 2014 07:36:57 GMT


On 3/14/14 11:04 PM, "Justin Mclean" <justin@classsoftware.com> wrote:

>Hi,
>
>> I'm not sure what "Latest SDK" means.  Is that the nightly?  Did you
>> install it into Documents/ApacheFlexDevelopGit?
>Latest develop branch.
Sorry, I'm still confused.  If it is the latest develop branch, how is the
installer involved?

>
>> What were you running when you got this error?  Ant on some build.xml?
>> Which one?
>ant in the air_for_ant directory.
I was about to guess that.  The README for the installer says you have to
specify AIR_HOME when building ant_on_air, was it set to some older
version of AIR SDK? It won't pick the AIR SDK out of the SDK specified by
FLEX_HOME.  So if you specify AIR_HOME as an AIR 4.0 SDK and then the
build works then this is not an installer issue.

However, I did notice the README is not quite correct.  The ant_on_air
build does not use FLEX_HOME_WIN and FLEX_HOME_MAC, the installer build
does.  I will fix the README.  It looks like the README is not in the
source package.  Did we fix a README issue for the SDK or Installer once
without doing another RC or is another RC required?

>
>> Crap.  I guess I did not understand how this part of the install was
>> supposed to work.  This is a bug in the install script for 4.12, not the
>> installer.
>This only happens when you use the new installer - so that basically
>means we can release the new installer until we fix the config file and
>release 4.12.1.
>
>There should be a way to make them independent of each other and avoid
>this - any ideas?
They are independent.  Other than downloading the binary package,
verifying the MD5, and uncompressing, the rest of the install
responsibilities are in the package, not the installer.  I suspect if you
actually use Ant to run the installer.xml you'll have the same problem.  I
know the temptation is to change the installer, but if we ever get the
installer out there, we'll be glad in the future that (hopefully) any
other SDK or FlexJS install issue can be fixed in the SDK and FlexJS
installer.xmls so we only vote on one package and not try to coordinate
two votes and two packages in the future.

>
>>> -Issue with 4.11 RSL in flex-config.xml
>> More details please?
>As discussed before that are incorrect and have 0 as the build number.
Rats, looks like I missed that before.  I'll have a look in my morning.

Thanks,
-Alex


Mime
View raw message