flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: [VOTE] Release Apache Flex SDK Installer 3.0 - RC7
Date Sat, 15 Mar 2014 05:50:49 GMT


On 3/14/14 10:05 PM, "Justin Mclean" <justin@classsoftware.com> wrote:

>Hi,
>
>Sorry but is -1 (binding) and the issues look serious to me.
>
>Try to compile with several SDKs - all produced errors.
>
>Latest SDK:
I'm not sure what "Latest SDK" means.  Is that the nightly?  Did you
install it into Documents/ApacheFlexDevelopGit?

>Error: Inconsistant linkage in
>/Users/justinmclean/Documents/ApacheFlexDevelopGit/frameworks/libs/air/air
>global.swc(flash.utils:ByteArray, flash.utils:CompressionAlgorithm,
>flash.utils:IDataInput2, flash.utils:IDataOutput2) -
>'flash.utils:ByteArray' is marked as extern, but
>'flash.utils:IDataInput2' is not
>
>When using 4.12 SDK setup to AIR 4.0 get this error - which seems odd to
>me.
> [exec] invalid application descriptor: Unknown namespace:
>http://ns.adobe.com/air/application/4.0
What were you running when you got this error?  Ant on some build.xml?
Which one?

>
>Running the convenience binary the flex description and flex-config.xml
>contain the locale that the installer was run in not the locale the SDK
>was compiled with (en_US).
>
>This means if you are on a locale other than en_US and try to compile the
>installer with an SDK downloaded by it you get this
>
>[compc] command line: Error: unable to open
>'/Users/justinmclean/Downloads/apache-flex-sdk-installer-3.0.0-src/ant_on_
>air/locale/en_AU'
>
>And would presumably cause issues with other projects that only have
>en_US resources in an non en_US locale.
Crap.  I guess I did not understand how this part of the install was
supposed to work.  This is a bug in the install script for 4.12, not the
installer.  Good thing we're thinking of doing a 4.12.1.

>
>Rest all good:
>Signatures fine
>README, NOTICE etc all good
>Ran on OSX and caching, non caching is good
>Can use SDK made from installer (but see locale issue above)
>
>Some other minor issues:
>-Issue with 4.11 RSL in flex-config.xml
More details please?

>-Outstanding issue re caching out of date player globals
I still think it doesn't matter, but that is also something we can address
in the next SDK release.  This is not an installer issue.

-Alex


Mime
View raw message