flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: [DISCUSS] Discuss Release Apache Flex SDK Installer 3.0 - RC4
Date Fri, 07 Mar 2014 19:59:48 GMT

On 3/7/14 11:36 AM, "OmPrakash Muppirala" <bigosmallm@gmail.com> wrote:

>On Fri, Mar 7, 2014 at 11:33 AM, Alex Harui <aharui@adobe.com> wrote:
>> On 3/7/14 11:06 AM, "OmPrakash Muppirala" <bigosmallm@gmail.com> wrote:
>> >>And of course, the perfect option is to get Falcon up to snuff so we
>> >>don't
>> >> need the SDK download at all.
>> >>
>> >>
>> >Of course, this is the best option.  But, I think for now, we can
>> >switch the 4.11 download to point to the mirror url.
>> That doesn't make sense to me.  We just pushed 4.12.  When we announce
>> we have to pull 4.11 of the mirrors.
>Isnt it just a swap of the url in the config file to switch to 4.12 when
>releases?  Or is the plan to stick to 4.11 (via archive url) for a while?
>What is the point in sticking to 4.11?
It works, and I don't have to add apache mirror handling code to the ant
script.  I can do it, it just isn't a high priority right now.  Maybe if
we start seeing serious download numbers of FlexJS we'll have to revisit,
but maybe by then we'll have some other solution other than pulling down
the latest SDK (like a separate package or hopefully, Falcon is ready).

Keep in mind that the Falcon build is locked to specific versions of
Apache commons.  We don't pull the latest there so we are also hitting
archive.a.o for those jars as well.  I would think archive.a.o already
gets hit a lot by other download scripts from other projects.  There is
risk to having your product automatically use the latest, although I
noticed we are for Google Closure.


View raw message