flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: [DISCUSS] Discuss Release Apache Flex SDK Installer 3.0 - RC3
Date Tue, 04 Mar 2014 02:04:46 GMT
This for this feedback.  I have some questions/comments inline.

On 3/3/14 4:45 PM, "Justin Mclean" <justin@classsoftware.com> wrote:

>Signatures check out fine.
>The build instructions still need improvements:
>- Required version of AIR in not mentioned. It's 3.4 for ant_on_air.
How did you determine this and where do you expect the required version to
be stated?

>This means the build is likely to fail first time you try to compile it
>if using an earlier version of AIR.
>- While ant_on_air requires AIR 3.4 the installer requires AIR 3.8. Means
>build will likely fail if you set AIR_HOME to say 3.4 because the first
>build failed.
I've been wondering why we set the AIR version so high.  Om, do you know?
>What does "ant test" in ant_on_air exactly do? Why is it picking up RC3
>and not RC4? Will it still work if the RCs are deleted?
Ant test performs a simple test with most of the ant tasks.  It downloads
an apache-rat binary as a test, but I don't it picks up any of our Rcs.
What output are you seeing that indicates that it is?

>After finally compiling the installer (via ant) and running it the fonts
>in drop downs and license check boxes were incorrect. Can send screen
>shot if needed.
Yes, please send a screen shot.

>Installed 4.12 RC3 on AIR 13 (beta) and seem to go well. Looks like all
>files were cached and OSMF cache was used.
>Looking at the produced SDK the swf version was incorrect in
>flex-config.xml (23 rather than 24).
Probably needs fixing in sdk-installer-config-4.0.xml.

>Tried again with AIR 4. However I think it may of used the lab version
>and not the release version. Possibly it getting confused between both
>versions of AIR 4?
What are the clues it used the wrong version?  You mean a labs version of
AIR 4 or AIR 13?  The cache items are identified by the paths to the items.
>Running again with default setting (4.11/FP 11.9) all previous cached
>versions were used.
>Looking again at flex-config.xml I can see that the RSL version numbers
>are incorrect.
That's bad.  I don't think it is the installer's job to fix up the RSL
versions.  Will have to check the SDK.  Is this for a 4.12RC3 or older

>Noticed the height of the install messages jumps up and down a lot which
>is a little unpleasant.

View raw message