flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From OmPrakash Muppirala <bigosma...@gmail.com>
Subject Re: Air iOS app - Blank white screen
Date Thu, 27 Mar 2014 15:57:16 GMT
On Mar 27, 2014 6:34 AM, "Alex Harui" <aharui@adobe.com> wrote:
>
> Pretty sure loading SWFs, even embedded SWFs at runtime is not allowed on
> IOS because of the restriction on interpreted code.

There is no technical limitation for this.  Swfs should load fine.  It may
not pass through the App store approval process, though.

Flexicious, try using a spark Image instead of the mx one.  The mx swcs are
excluded from the app during the mobile compilation process.  No compile
errors, but it will end up failing in runtime.

You need to either remove all references to mx components or add the mx.swc
manually in to your build path.

Thanks,
Om

>
> -Alex
>
> On 3/27/14 6:08 AM, "Flexicious.com" <flexicious@gmail.com> wrote:
>
> >Thanks Alex - we did try that - for some reason it choked right before it
> >could alert the message. We seem to have narrowed down the problem to
> >images that use swf files as source. Once we remove these images, the app
> >loads. So that begs the question, how do you get the Image component to
> >load swf graphics? Or is that just not possible with Air on iOS
> >
> >[Embed(source = '/assets/images/someIcon.swf')]
> >public static var someIcon:Class;
> >
> >And then <mx:Image source="{Resources.someIcon}"
> >
> >
> >
> >On Wed, Mar 26, 2014 at 9:32 AM, Alex Harui <aharui@adobe.com> wrote:
> >
> >> Try putting in an uncaughtException handler and see if it catches
> >>anything.
> >>
> >> On 3/26/14 5:26 AM, "Flexicious.com" <flexicious@gmail.com> wrote:
> >>
> >> >tried with 3.9, 4.0 as well as air 13.
> >> >
> >> >
> >> >
> >> >On Wed, Mar 26, 2014 at 1:47 AM, Raj Raju <raj.virtuali@gmail.com>
> >>wrote:
> >> >
> >> >> Can you try to make the build with latest air sdk 4.0 ( 4.0.0.1619
> >>). I
> >> >> guess the problem will be resolved with this new sdk .
> >> >> You can find the link below
> >> >>
> >>http://labsdownload.adobe.com/pub/labs/flashruntimes/air/air4-0_sdk_wi
> >> >> n.zip<
> >> >>
> >> >>
> >>
> >>
http://labsdownload.adobe.com/pub/labs/flashruntimes/air/air4-0_sdk_win.z
> >> >>ip
> >> >> >
> >> >>
> >> >> Cheers,
> >> >> Raju.M.
> >> >>
> >> >>
> >> >>
> >> >> On Wed, Mar 26, 2014 at 9:38 AM, Flexicious.com <
flexicious@gmail.com
> >> >> >wrote:
> >> >>
> >> >> > We have a fairly large air app, and for some reason, when we
> >>package
> >> >>it
> >> >> for
> >> >> > iOS, it does not launch correctly. Just a plain white screen.
When
> >>we
> >> >> > launch it in debug mode (or even using Fast packaging), it works
> >>fine.
> >> >> Only
> >> >> > with the export release build it simply launches a plain white
> >>screen
> >> >>and
> >> >> > does nothing.
> >> >> >
> >> >> > Anybody seen anything similar? Any idea if there is an error of
> >>some
> >> >> sort,
> >> >> > any way to find out what the error is?
> >> >> >
> >> >>
> >>
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message