flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Ent <p...@adobe.com>
Subject Re: [FlexJS] BarChart component added - render issue
Date Fri, 07 Feb 2014 16:23:07 GMT
Assuming that I've built and installed things into the right places, I did
not get this warning building the example using ant in the BarChartExample
directory. So just using FB. I'm not yet familiar enough the configuration
differences to see why this would be the case.

--peter

On 2/7/14 10:59 AM, "Alex Harui" <aharui@adobe.com> wrote:

>Are you guys only getting this warning when using FB or does the warning
>also show up when building from ant?
>
>On 2/7/14 7:01 AM, "Peter Ent" <pent@adobe.com> wrote:
>
>>I got all the code and rebuilt. The issue Om was trying to fix is
>>definitely fixed - the charts look great in both AS and JS.
>>
>>I am however, getting this warning when cross-compiling the
>>BarChartExample from within Flash Builder:
>>
>>/Users/pent/Documents/Apache
>>Flex/BarChartExample/bin/js-debug/org/apache/flex/charts/beads/XAxisBead.
>>j
>>s
>>:82: WARNING - Bad type annotation. Unknown type
>>org.apache.flex.charts.beads.layouts.BarChartLayout
>>  var /** @type {org.apache.flex.charts.beads.layouts.BarChartLayout} */
>>barChartLayout = 
>>org.apache.flex.utils.Language.as(this._strand.getBeadByType(org.apache.f
>>l
>>e
>>x.core.IBeadLayout),
>>org.apache.flex.charts.beads.layouts.BarChartLayout);
>>                 ^
>>
>>In my XAxisBead.js (from the bin/js-debug directory) there is no
>>goog.require for BarChartLayout.
>>
>>I don't see anything in the AS file that might cause the cross-compile to
>>leave it out.
>>
>>--peter
>>
>>On 2/7/14 3:02 AM, "OmPrakash Muppirala" <bigosmallm@gmail.com> wrote:
>>
>>>On Thu, Feb 6, 2014 at 11:09 PM, Alex Harui <aharui@adobe.com> wrote:
>>>
>>>>
>>>>
>>>> On 2/6/14 10:49 PM, "OmPrakash Muppirala" <bigosmallm@gmail.com>
>>>>wrote:
>>>>
>>>> >On Feb 6, 2014 10:42 PM, "Alex Harui" <aharui@adobe.com> wrote:
>>>> >>
>>>> >> Ack.  Read the error incorrectly.  It may not be BarChartLayout
>>>>that
>>>>is
>>>> >> incorrect.  Do you know which .js file is actually complaining?
>>>> >>
>>>> >
>>>> >Yes, it is from XAxisBead.js
>>>> Hmm.  Are you all synced up?  I got an error cross-compiling FlexJSJX.
>>>>I
>>>> just checked in a fix for that.  Maybe that is the root of the
>>>>problem?
>>>>
>>>>
>>>I did see those other errors.  Dint think it was related.  In any case,
>>>I
>>>got your latest fixes, but still have the same issue.
>>>
>>>
>>>> My copy of XAxisBead.js does have a goog.require for BarChartLayout.
>>>>Does
>>>> yours?
>>>>
>>>
>>>Interesting.  After I run ant in the flex-asjs folder, I see that
>>>flex-asjs\frameworks\js\FlexJS\libs\org\apache\flex\charts\beads\layouts
>>>\
>>>X
>>>AxisBead.js
>>>does have the require for BarChartlayout (among a lot of other requires)
>>>
>>>goog.provide('org.apache.flex.charts.beads.XAxisBead');
>>>
>>>goog.require('org.apache.flex.charts.beads.ChartItemRendererFactory');
>>>goog.require('org.apache.flex.core.FilledRectangle');
>>>goog.require('org.apache.flex.html.staticControls.Label');
>>>goog.require('org.apache.flex.events.Event');
>>>*goog.require('org.apache.flex.charts.beads.layouts.BarChartLayout');*
>>>goog.require('org.apache.flex.html.staticControls.beads.models.ArraySele
>>>c
>>>t
>>>ionModel');
>>>goog.require('org.apache.flex.core.UIBase');
>>>goog.require('org.apache.flex.events.IEventDispatcher');
>>>goog.require('org.apache.flex.core.IBeadLayout');
>>>goog.require('org.apache.flex.core.IStrand');
>>>goog.require('org.apache.flex.core.IBead');
>>>goog.require('org.apache.flex.core.IDataProviderItemRendererMapper');
>>>goog.require('org.apache.flex.charts.core.IChart');
>>>goog.require('org.apache.flex.core.ISelectionModel');
>>>goog.require('org.apache.flex.charts.core.IChartAxis');
>>>
>>>Then, I copy the modified files into the SDK that I installed using the
>>>new
>>>Installer.
>>>
>>>But, when I compile the example app, the file:
>>>flex-asjs\examples\BarChartExample\bin\js-debug\org\apache\flex\charts\b
>>>e
>>>a
>>>ds
>>>
>>>seems to have been modified with a whole bunch requires removed.  There
>>>are
>>>only these three:
>>>
>>>goog.provide('org.apache.flex.charts.beads.XAxisBead');
>>>
>>>goog.require('org.apache.flex.html.staticControls.Label');
>>>goog.require('org.apache.flex.charts.core.IChartAxis');
>>>
>>>Looks like something funky is happening in the FlexJS-FalconJX build.
>>>
>>>Thanks,
>>>Om
>>>
>>>
>>>>
>>>> -Alex
>>>> >
>>>>
>>>>
>>
>


Mime
View raw message