flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jake Churchill <reyna...@gmail.com>
Subject Re: Pepperflash and PopUpMananger
Date Thu, 13 Feb 2014 00:19:40 GMT
In working on this, I found that it was all around the modal layer.  So, I
just created a global Swiz event to handle adding/removing popup children
and I manage the overlay manually by adding a basic component over top my
content.  The popups are all non-modal, but I'm re-creating the overlay
manually creating them as modal to the user.

I'll test out the SystemManager direction as well.  Curious, when creating
a modal popup through PopupManager, does it actually add 2 items to the
SystemManager (overlay and popup component)?  Or is the overlay something
built into flash in another way?

Thanks!

-Jake


On Wed, Feb 12, 2014 at 5:58 PM, Alex Harui <aharui@adobe.com> wrote:

> As an experiment, don't use PopUpManager and directly add the popup to
> SystemManager.popUpChildren.
>
> On 2/12/14 2:12 PM, "Jake Churchill" <reynacho@gmail.com> wrote:
>
> >Hello again,
> >
> >I'm working on an issue where none of my popups display correctly in
> >chrome.  This is via PopUpManager.addPopup().  I know there is a bug
> >logged
> >with chromium about this:
> >
> >https://code.google.com/p/chromium/issues/detail?id=333024
> >https://code.google.com/p/chromium/issues/detail?id=323680
> >
> >However, I'm wondering if anyone has come across a workaround (no matter
> >how out of the way it may be).  I work on an app where there are lots of
> >"wizard" popups and info boxes and in chrome, the majority of the time
> >they
> >just don't display.  The modal overlay is there, just not the popup.  I've
> >tried all kinds of combinations of popup parents and childList settings
> >and
> >have modified the popup components that I'm using.  I've tried modal and
> >not, and I've tried forcing invalidatedisplayList() on the parent and
> >popup
> >with no luck.
> >
> >I've tried setting wmode="opaque" and wmode="transparent" after reading
> >that this might force hardware acceleration off (but it doesn't seem to in
> >my case).
> >
> >The only fixes I've found are to turn hardware acceleration off in chrome
> >settings or disable the built-in flash player in favor of the plugin.
> > Unfortunately, that's not really a viable option to have thousands of
> >users do.
> >
> >Interestingly enough, when I turn modal off on the popup, it seems to
> >sometimes work.  I'd really prefer not to "un-modalize" all my popups for
> >a
> >temporary bug in chrome.
> >
> >If anyone has any ideas, please let me know.
> >
> >Thanks!
> >
> >-Jake
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message