flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Moore" <Jason.Mo...@harksolutions.co.uk>
Subject RE: How does Flex compiler take advantage of the AIR 4 Improved Packaging Engine?
Date Mon, 20 Jan 2014 10:43:45 GMT
Additional: You need to place the option just before the "-provisioning-profile" otherwise
it doesn't seem to work.

-----Original Message-----
From: Jason Moore [mailto:Jason.Moore@harksolutions.co.uk] 
Sent: 20 January 2014 10:41
To: dev@flex.apache.org
Subject: RE: How does Flex compiler take advantage of the AIR 4 Improved Packaging Engine?

Export the release package in Flash Builder, the setting you need is at the point you compile
the IPA. Look for the "Customise Launch" button bottom right when you are entering the packaging
settings. You can then add a parameter "-useLegacyAOT" with a value set to "no".

Be warned though, I believe this compiler is still beta.. my application compiles in 3 Mins
instead of 10, but the result fails to run on the iPad !

J :)

-----Original Message-----
From: Alexander Doroshko [mailto:alexander.doroshko@jetbrains.com]
Sent: 20 January 2014 10:10
To: dev@flex.apache.org
Subject: Re: How does Flex compiler take advantage of the AIR 4 Improved Packaging Engine?

I know only how to do it in IntelliJ IDEA :) Project Structure dialog | Modules | [your Flash
module] | [your Flash build configuration subnode] | iOS tab | Additional ADT options.

On 20.01.2014 13:54, DarkStone wrote:
> Hi Alexander,
>
> Thx for your answer, now the question I have is:
>
> How to modify Flash Builder to enable "-useLegacyAOT no" by default?
>
>
> Any help will be highly appreciated : )
>
> DarkStone
> 2014-01-20
>
>
> 在 2014-01-20 17:03:58,"Alexander Doroshko" 
> <alexander.doroshko@jetbrains.com> 写道:
>> Hi,
>> new “-useLegacyAOT no” is the option of ADT packaging tool. ADT is 
>> included in the Adobe AIR SDK. So it is related neither to Flex SDK, 
>> nor to Flex compiler, nor to ASC 2.0. Nothing prevents you from using 
>> the option when working with Flex SDK any version + AIR SDK 4.
>>
>> Alexander
>>
>> On 19.01.2014 20:16, 周 戈 wrote:
>>> Hi all,
>>>
>>> I’ve just installed Flex 4.11 SDK with FP 12 & AIR 4 SDK using Flex SDK
Installer v2.7.0, I’m aware of that you can’t use “-useLegacyAOT no” as the argument
for the Flex compiler.
>>>
>>> Well I think it’s because “-useLegacyAOT no” is introduced in the ASC 2
of AIR 4 SDK, and the current Flex compiler does not use ASC 2 yet.
>>>
>>> The problem is, packaging a Flex Mobile Project to the IPA format 
>>> takes too long! Even the simplest Flex Mobile Project will take 4-5 
>>> minutes to compile for packaging an IPA file, that’s really painful
>>> : (
>>>
>>> Is there a way to let Flex compiler take advantage of the AIR 4 Improved Packaging
Engine (which improves iOS packaging time up to 10 times over the previous packager)?
>>> http://helpx.adobe.com/en/flash-player/release-note/fp_12_air_4_rele
>>> ase_notes.html#new_features
>>>
>>> If this issue can be addressed, it will be a HUGE improvement for 
>>> the Flex Mobile platform, so exciting to hear from you guys : )
>>>
>>>
>>> DarkStone
>>> 2014-01-20


Mime
View raw message