flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jake Churchill <reyna...@gmail.com>
Subject OSX 10.9 Debugging
Date Wed, 22 Jan 2014 21:42:49 GMT
I recently upgraded my mac to 10.9 by way of purchasing a new mac, not
upgrading an existing.  I installed all the usual XCode, FlashBuilder 4.7,
etc.  I noticed that I cannot debug anything on the desktop through ADL.
 It just sticks at 57%.  I am also unable to debug web apps.  The only type
of debugging I have gotten to work is a mobile app directly on the device
or via iOS simulator, nothing else seems to work.

I've read up for days on the issue and applied the privacy setting to
include Flash Builder, updated ownership/permissions on the project, my
entire documents directory (where my project lives) and the applications
directory to be my user and chmod -R 777 every where I just mentioned.

I've tried all the different flex/air combinations I have which are:

   - flex 4.6, AIR 3.1
   - flex 4.6, AIR 3.4
   - flex 4.6, AIR 3.8
   - flex 4.6, AIR 3.9
   - flex 4.6, AIR 4.0
   - apache flex 4.11, AIR 4.0


I'm now at a complete loss.  When I close out the app while the debugger
progress is still stick at 57%, I get this error:

Process terminated without establishing connection to debugger.

2014-01-22 15:36:59.313 adl[3199:507] CoreText performance note: Client
called CTFontCreateWithName() using name "Times Roman" and got font with
PostScript name "Times-Roman". For best performance, only use PostScript
names when calling this API.
2014-01-22 15:36:59.313 adl[3199:507] CoreText performance note: Set a
breakpoint on CTFontLogSuboptimalRequest to debug.


Launch command details:
 /Users/jake/Documents/apache_flex_sdks/flex4.11AIR4.0/bin/adl -runtime
/Users/jake/Documents/apache_flex_sdks/flex4.11AIR4.0/runtimes/air/mac
-profile mobileDevice -screensize 768x1004:768x1024 -XscreenDPI 132
-XversionPlatform IOS "/Users/jake/Documents/Adobe Flash Builder
4.7/NEIMobile/bin-debug/NEIMobile-app.xml" "/Users/jake/Documents/Adobe
Flash Builder 4.7/NEIMobile/bin-debug"


Any help is very much appreciated.  I'm going crazy here.

Thanks!

-Jake

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message