flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject [FlexJS] Build Scripts, FlexJSOverlay replaced by ApacheFlexJS.zip
Date Mon, 25 Nov 2013 07:10:21 GMT
Hi,

I just checked in some changes to flex-falcon and flex-asjs to allow for a
build script in flex-asjs.  The main target will build the SWCs.  The
examples target will build all of the examples.  The release target will
build apache-compliant release packages.  The package-sdk target will
package a new version of FlexJSOverlay.zip called ApacheFlexJS.zip and
ApacheFlexJS.tar.gz.  FlexJSOverlay.zip is now obsolete as we have enough
pieces in flex-asjs to no longer need to overlay files on top of an
existing Flex SDK.  Now you unzip or untar the ApacheFlexJS artifact and
run a deploy script that copies a few missing pieces from an existing Flex
SDK.  Eventually, the deploy script will be replaced by a installer.

The main target does run jshint and gjslint.  I've set failonerror=false
on jshint for now as it is still spitting warnings.  You'll also see
warnings when running the examples target.  Volunteers are welcome to
clean all of that up.

I've posted the latest ApacheFlexJS.zip and ApacheFlexJS.tar.gz at [1].
I'll remove FlexJSOverlay.zip once I get confirmation that these artifacts
worked for others.

Next step for me is to try to get the next Adobe donation to legal for
review.  Then work on the installer.

As always, feedback and contributions welcome.

Thanks,
-Alex

[1] http://people.apache.org/~aharui/FlexJS/


Mime
View raw message