flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maurice Amsellem <maurice.amsel...@systar.com>
Subject RE: [jira] [Commented] (FLEX-33876) Font Styles not taking effect on mx:PieCharts, mx:ColumnCharts, mx:Legends, s:Form and s:Alert
Date Thu, 14 Nov 2013 10:03:23 GMT
Try using the experimental namespace:

@namespace exp "http://flex.apache.org/experimental/ns";
exp|Alert
{
	fontWeight : normal;
	fontFamily: defaultFont;
}

-----Message d'origine-----
De : Dylan Randall (JIRA) [mailto:jira@apache.org] 
Envoyé : jeudi 14 novembre 2013 10:55
À : issues@flex.apache.org
Objet : [jira] [Commented] (FLEX-33876) Font Styles not taking effect on mx:PieCharts, mx:ColumnCharts,
mx:Legends, s:Form and s:Alert


    [ https://issues.apache.org/jira/browse/FLEX-33876?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13822289#comment-13822289
] 

Dylan Randall commented on FLEX-33876:
--------------------------------------

That's awesome! Most of the changes you suggested have worked! The s|Alert however hasn't.
This is what I have in the css 

@namespace sparkComponents "spark.components.*"; 
sparkComponents|Alert
{
	fontWeight : normal;
	fontFamily: defaultFont;
}

I tried to cater for the bold heading but to no avail.

I understand now why some items don't apply the font when its default weight is bold thanks
for the insight.

> Font Styles not taking effect on mx:PieCharts, mx:ColumnCharts, mx:Legends, s:Form and
s:Alert
> ----------------------------------------------------------------------------------------------
>
>                 Key: FLEX-33876
>                 URL: https://issues.apache.org/jira/browse/FLEX-33876
>             Project: Apache Flex
>          Issue Type: Bug
>    Affects Versions: Apache Flex 4.9.0, Apache Flex 4.10.0, Apache Flex 4.11.0
>         Environment: Windows 7 Professional SP1 64Bit running on MacBook Pro (mid 2010)
OSX 10.9 Bootcamp.
> Apache Flex SDK 4.11 running on FlashBuilder 4.7 Standard.
>            Reporter: Dylan Randall
>            Priority: Critical
>         Attachments: ApplicationStyles.css, FontStyleTest.fxp, Mostardesign - Sofia Pro
Bold.otf, SofiaProLight.otf
>
>
> When I try to apply a css style that lives in the main application onto a sub application
loaded into the main application via a SWFLoader some styles are not set. Instances like s:Label
have the style applied however mx:PieChart, mx:ColumnChart and mx:Legend the style is not
applied. I am only trying to apply a font to the text of these components. Things like the
callouts and the text on the legends do not get the style applied to them. The same goes for
s:Form the font style isn't applied to the component. The same font style is also not being
applied to the title string of the s:Alert component but the body or message string the font
is being applied correctly.



--
This message was sent by Atlassian JIRA
(v6.1#6144)
Mime
View raw message