flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Ent <p...@adobe.com>
Subject Re: [FlexJS] StatesTest example app broken?
Date Thu, 19 Sep 2013 16:02:35 GMT
I'm not making any headway on this. There is a global style declaration
which should associate a state implementation with any class:

global
{
    iStatesImpl: ClassReference("org.apache.flex.core.SimpleStatesImpl");
}


I don't know why this isn't being picked up. I'm going to try
DataBindingTest and see how that goes.
--peter

On 9/19/13 11:12 AM, "Peter Ent" <pent@adobe.com> wrote:

>I am looking into this.
>--peter
>
>On 9/19/13 1:03 AM, "Alex Harui" <aharui@adobe.com> wrote:
>
>>I haven't tried StatesTest in a while.  Can you work with DataBindingTest
>>instead?  It should have everything StatesTest has and more.
>>
>>-Alex
>>
>>On 9/18/13 9:58 PM, "OmPrakash Muppirala" <bigosmallm@gmail.com> wrote:
>>
>>>I picked this project up [1] after a while and when I run the app, I am
>>>getting this RTE:
>>>
>>>TypeError: Error #1009: Cannot access a property or method of a null
>>>object
>>>reference.
>>>    at org.apache.flex.core::ViewBase/set
>>>states()[C:\p\flex_os\workspace\flexroot\git\flex-asjs\frameworks\as\src
>>>\
>>>o
>>>rg\apache\flex\core\ViewBase.as:83]
>>>    at
>>>MyInitialView()[C:\p\flex_os\workspace\flexroot\git\flex-asjs\examples\S
>>>t
>>>a
>>>tesTest\src\MyInitialView.mxml:23]
>>>    at StatesTest/_StatesTest_MyInitialView1_c()
>>>    at
>>>StatesTest()[C:\p\flex_os\workspace\flexroot\git\flex-asjs\examples\Stat
>>>e
>>>s
>>>Test\src\StatesTest.mxml:26]
>>>
>>>I resynced recently and I am guessing some recent changes break this
>>>app.
>>>When I step through the debugger, it looks like ValuesManager.valuesImpl
>>>is
>>>returning null.
>>>
>>>Alex/Peter, can one of you please take a look?
>>>
>>>Thanks,
>>>Om
>>>
>>>[1] https://fisheye6.atlassian.com/browse/flex-asjs/examples/StatesTest
>>
>


Mime
View raw message