flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joel Tan <joel.ta...@gmail.com>
Subject FXG ScaleGrid on BitmapImage not working
Date Thu, 22 Aug 2013 04:41:02 GMT
Hi,

Does anyone encounter this? <BitmapImage /> ScaleGrid seem to be not working on FXG.
Below are my code:

============================================================================================

<?xml version="1.0" encoding="utf-8" ?>
<Graphic version="2.0" xmlns="http://ns.adobe.com/fxg/2008" scaleGridTop="6" scaleGridLeft="6"
scaleGridRight="94" scaleGridBottom="54" >
    

     	<Rect width="100" height="60" radiusX="4" radiusY="4" >
		<fill>
			<LinearGradient rotation="90" >
				<GradientEntry color="#00649f" />
				<GradientEntry color="#005080" />
			</LinearGradient>
		</fill>
		<stroke>
			<LinearGradientStroke rotation="90" >
				<GradientEntry color="#0079c1" />
				<GradientEntry color="#004b77" />
			</LinearGradientStroke>
		</stroke>				
	</Rect>

	<!-- Use BitmapImage for InnerGlow, since ScaleGrid will not work on filter -->
	<BitmapImage x="0" y="0" source="@Embed('skins/mobi/assets240/InnerGlow240.png')" scaleX="1"
scaleY="1" fillMode="scale" width="100" height="60" />

    	
</Graphic>

============================================================================================

The <Rect /> has no problem while scaling, but the bitmap image doesn't seem to be applied
to the scaleGrid, is there anything that I have done it wrongly?

Thanks!


Joel
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message