flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "tom chiverton (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLEX-33558) CameraUI slow return to flex application on certain devices
Date Thu, 23 May 2013 14:11:20 GMT

    [ https://issues.apache.org/jira/browse/FLEX-33558?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13665200#comment-13665200
] 

tom chiverton commented on FLEX-33558:
--------------------------------------

I'm sure it does break with the extra non-SDK code added. But it's obviously not an SDK bug
because the camera feature works fine here with your view without your extra non-SDK code.

We should close this issue.
                
> CameraUI slow return to flex application on certain devices
> -----------------------------------------------------------
>
>                 Key: FLEX-33558
>                 URL: https://issues.apache.org/jira/browse/FLEX-33558
>             Project: Apache Flex
>          Issue Type: Bug
>    Affects Versions: Apache Flex 4.9.0
>         Environment: See below
>            Reporter: Jesse Hellyer
>              Labels: camera, cameraui
>         Attachments: JPEGEncoder.as, KPMMobileApplication-app.xml, MobileData2.as, SDK_4.9.1-testing.fxp,
_Super_MobileData2.as, ViewExistingRegistrationRequests.mxml, ViewProductRegistrationIOS.mxml
>
>
> I have been having very slow results with the CameraUI in flex.   Initially, I was using
version 3.1 which was VERY buggy, and I was running into erroring out returning from the CameraUI,
and very slow speeds.
> I have since downloaded and installed the newest Apache Flex framework, 4.9.1.   The
CameraUI returns VERY fast on our Samsung Tab 7.1 that we bought a few months ago.  On an
older Droid Charge phone, that is up to date with updates, it takes 30-40 seconds to return
from the CameraUI into my code.  Same with an iPhone 4 running iOS 6.1.   
> The line in question is marked in yellow below:  mpLoader.loadFilePromise(mediaPromise);
> Essentially, I call the cameraUI when the user hits a button.   The native camera interface
opens up right away.  A picture is taken.  On iOS and Android both, you have to “save”
or “use” the picture.   Once you click that button in the native UI, the camera holds
on a black screen for a long time (up to 30 seconds or so).   That’s where the error seems
to be, mpLoader.loadFilePromise(mediaPromise);
> You can see in the code I have put output statements to a label showing where the code
is hanging.  It hangs right after it writes out -16
> Here is the code:
> https://gist.github.com/MrJesse34/5577978
> And here is the XML config file:
> https://gist.github.com/MrJesse34/5627336

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message