flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Kessler <kesslerconsult...@gmail.com>
Subject Re: git commit: [flex-sdk] [refs/heads/develop] - FLEX-33524: Added convenience feature to enable/disable buttons in a ButtonBar/TabBar.
Date Sat, 04 May 2013 00:01:31 GMT
   Give me an opinion which of these you prefer.  I have a few sets of
changes I could use.  I will apply the same logic for the array based ones

1.  Keep the existing named methods (disableButton/enabledButton) and move
70% of code to a button index lookup method which they both call.

2.  Combine the 2 methods (disableButton/enabledButton) into one method
with an extra property requirement "setButtonEnabled(buttonLabel,
enabledValue, optionalFieldName)".

3.  Both options


On Thu, May 2, 2013 at 11:44 PM, Alex Harui <aharui@adobe.com> wrote:

> Hey Mark,
> Do you think it is worth trying to have all of these APIs call a common
> function?  I think I'm seeing the same code more than once.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message