flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frédéric THOMAS <webdoubl...@hotmail.com>
Subject Re: Apache Flex SDK Installer - 2.5 release?
Date Mon, 11 Mar 2013 07:56:07 GMT
Justin,

Actually, I already had to deal with those scripts but thank you to remind 
me, especialy for linux, I always forgot :)

The burden is I will have to manipulate the flex-config.xml manualy.
Note: I would have prefered to run a script against but I should manage to 
run a specific shell depending of the OS, I started to do that in the 
developer Tool Suite but we haven't got the same structure in the Installer 
so I'll have to rewrite everything, what I dont want.

> That's a little tricky perhaps add a way to start off at a step or a skip 
> downloads flag in the code? You can put local file path URLs in the config 
> file so that it just copies the files rather than downloading them.
If I put all the nescessary files in the app user directory (where all the 
files are normaly downloaded), I guess I can skip the steps via debug config 
:) btw, do you remember where is the user directory, the same place in 
release than in debug in AIR ?

> Hope that helps!
Yes, that helps :)

Thanks,
-Fred

-----Message d'origine----- 
From: Justin Mclean
Sent: Monday, March 11, 2013 8:35 AM
To: dev@flex.apache.org
Subject: Re: Apache Flex SDK Installer - 2.5 release?

Hi,

> 3- I'm already thinking a way for the user to select the FP and AIR 
> version from the GUI, the only thing that bother me is the way I should 
> update the flex-config.xml and much more.

If you are good with shell scripts take at a look at in the ide directory 
there's scripts there that set the Flash and AIR version.

Basically for Flash Player you need to set the version and swf version in 
flex-config.xml and for AIR you need to set it in air-config.xml and 
airmobile-config.xml.

Flash Player  10.2  set swf version 11
Flash Player  10.3 set swf version 12
Flash Player  11.0 set swf version 13
Flash Player  11.1 set swf version 14
Flash Player  11.2 set swf version 15
Flash Player  11.3 set swf version 16
Flash Player  11.4 set swf version 17
Flash Player  11.5 set swf version 18
Flash Player  11.6 set swf version 19

Player global needs to be downloaded and renamed and placed in the correct 
place

For Flash Player 11.0+ the path is:
http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal<FP 
version>.swc

Where version is 11_0, 11_1, 11_2 etc etc

For Flash Player 10.2 and 10.3 the path is
http://download.macromedia.com/get/flashplayer/installers/archive/playerglobal/playerglobal<FP

version>.swc

Where version is 10_2 or 10_3.

AIR 2.6 needs flash player 10.2
AIR 2.7 needs flash player 10.3
AIR 3.0 needs flash player 11.0
AIR 3.1 needs flash player 11.1
AIR 3.2 needs flash player 11.2
AIR 3.3 needs flash player 11.3
AIR 3.4 needs flash player 11.4
AIR 3.5 needs flash player 11.5
AIR 3.6 needs flash player 11.6

So may be best to select AIR first?

AIR download for OSX is:
http://airdownload.adobe.com/air/mac/download/<AIR version>/AdobeAIRSDK.tbz2

For Windows is:
http://airdownload.adobe.com/air/win/download/<AIR version>/AdobeAIRSDK.zip

And Linux (2.6 only):
http://airdownload.adobe.com/air/lin/download/<AIR version>/AdobeAIRSDK.tbz2

>  find a way I wouldn't have to run the all steps to be able to debug it. 
> Any good tricks will be welcome.
That's a little tricky perhaps add a way to start off at a step or a skip 
downloads flag in the code? You can put local file path URLs in the config 
file so that it just copies the files rather than downloading them.

Hope that helps!

Justin


Mime
View raw message