flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik de Bruin <e...@ixsoftware.nl>
Subject [FalconJS] error in fresh working copy
Date Mon, 11 Mar 2013 17:59:08 GMT
Alex,

When I check out a fresh working copy of FalconJS and try to build it
using the ant script or in Eclipse, I get the following error:

compile:
    [javac] Compiling 31 source files to
/Users/erik/Documents/ApacheFlex/repo_again/falcon/trunk/compiler.js/build/classes
    [javac] /Users/erik/Documents/ApacheFlex/repo_again/falcon/trunk/compiler.js/src/org/apache/flex/compiler/internal/as/codegen/JSGeneratingReducer.java:5574:
incompatible types
    [javac] found   : org.apache.flex.compiler.tree.as.IVariableNode
    [javac] required: org.apache.flex.compiler.internal.tree.as.BaseVariableNode
    [javac]         BaseVariableNode var_node =
var_expr_node.getTargetVariable();
    [javac]                                                                    ^
    [javac] Note:
/Users/erik/Documents/ApacheFlex/repo_again/falcon/trunk/compiler.js/build/generatedSrc/as3.codegen/org/apache/flex/compiler/internal/as/codegen/CmcJSEmitter.java
uses unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] 1 error

My copy of Falcon is also a fresh new working copy that builds correctly.

Can you reproduce this?

EdB



--
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl

Mime
View raw message