flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Doroshko <alexander.doros...@jetbrains.com>
Subject Re: Air 3.7 in Apache Flex
Date Sun, 24 Mar 2013 20:09:05 GMT

>> My understanding is that the only problem is that:
>> - flex-config.xml, air-config.xml and airmobile-config.xml files do not
>> include Flex related stuff;
>> - mxmlc.bat (mxmlc on Mac) and compc.bat (compc on Mac) scripts point to ASC
>> 2.0 jars instead of legacy jars.
> It seems like this might be handles by some clever text manipulation
> in the SDK build script(s), IF the legacy jars are still present in
> the distribution... Can anyone confirm that?

Legacy jars are included in the Apache Flex SDK installation and they 
are not overwritten when AIR SDK (any kind of bundle) is overlaid on top 
of Flex SDK. So, yes, if installer performs AIR SDK overlay skipping 
several files - the problem would be solved.

View raw message