flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tigran Najaryan" <tig...@gmail.com>
Subject Configuring Ant for SDK build (WAS: Error compiling SDK)
Date Sat, 30 Mar 2013 08:22:17 GMT
Solved the problem. It turned out I had flexTasks.jar from an earlier Flex
SDK in my Ant "lib" directory. 

Copied the new flexTasks.jar from Apache SDK 4.9.1 to the Ant and the build
went without any problems. Apparently the mxmlc task from the old
flexTasks.jar had problem accepting the target-player parameter.

Perhaps it is worth adding a note about Ant configuration in the SDK README
file. Currently it only says you need Ant 1.7.1 or greater but provides no
configuration instructions.

Thanks,
Tigran.


-----Original Message-----
From: Alex Harui [mailto:aharui@adobe.com] 
Sent: Wednesday, March 27, 2013 7:49 PM
To: dev@flex.apache.org
Subject: Re: Error compiling SDK

Any chance you have a FLEX_HOME environment variable pointing to an Adobe
Flex SDK?


On 3/27/13 6:14 AM, "Tigran Najaryan" <tignaj@gmail.com> wrote:

> Hi guys,
> 
>  
> 
> I am trying to compile the SDK and get an error during the build.
> 
>  
> 
> I started here http://flex.apache.org/download-source.html and 
> followed the instructions in "Bleeding-Edge Release". After getting 
> the source code using git I installed the prerequisites as per the 
> README file. Then tried "ant main", accepted all default answers when 
> prompted and got the following error after a while:
> 
>  
> 
> assets-compile:
> 
>     [mxmlc] Loading configuration file D:\WORK\My 
> Experiments\ApacheFlex\sdk\frameworks\flex-config.xml
> 
>     [mxmlc] command line: Error: configuration variable 'target-player'
> value contains unknown token 'playerglobal.version'
> 
>  
> 
>  
> 
> I am not sure what am I doing wrong. For some reason it does not 
> recognize the 'playerglobal.version'. I did not edit the 
> build.properties, it contains the default "playerglobal.version = 
> 11.1" line. I also tried passing
> -Dplayerglobal.version=11.1 to ant but get the same error.
> 
>  
> 
> Any advise?
> 
>  
> 
> Thanks,
> 
> Tigran.
> 

--
Alex Harui
Flex SDK Team
Adobe Systems, Inc.
http://blogs.adobe.com/aharui


Mime
View raw message