flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tigran Najaryan" <tig...@gmail.com>
Subject RE: Error compiling SDK
Date Thu, 28 Mar 2013 05:45:20 GMT
My FLEX_HOME points to C:\Program Files (x86)\Adobe\Adobe Flash Builder
4.6\sdks\4.9.0 which is a release copy of Apache Flex SDK 4.9.0 installed in
my Flash Builder. 

Tried setting FLEX_HOME to D:\WORK\My Experiments\ApacheFlex\sdk which is
the Apache Flex SDK directory I am trying to compile but that changed
nothing, I get exactly the same error.

Anything else I can try?


-----Original Message-----
From: Alex Harui [mailto:aharui@adobe.com] 
Sent: Wednesday, March 27, 2013 7:49 PM
To: dev@flex.apache.org
Subject: Re: Error compiling SDK

Any chance you have a FLEX_HOME environment variable pointing to an Adobe
Flex SDK?

On 3/27/13 6:14 AM, "Tigran Najaryan" <tignaj@gmail.com> wrote:

> Hi guys,
> I am trying to compile the SDK and get an error during the build.
> I started here http://flex.apache.org/download-source.html and 
> followed the instructions in "Bleeding-Edge Release". After getting 
> the source code using git I installed the prerequisites as per the 
> README file. Then tried "ant main", accepted all default answers when 
> prompted and got the following error after a while:
> assets-compile:
>     [mxmlc] Loading configuration file D:\WORK\My 
> Experiments\ApacheFlex\sdk\frameworks\flex-config.xml
>     [mxmlc] command line: Error: configuration variable 'target-player'
> value contains unknown token 'playerglobal.version'
> I am not sure what am I doing wrong. For some reason it does not 
> recognize the 'playerglobal.version'. I did not edit the 
> build.properties, it contains the default "playerglobal.version = 
> 11.1" line. I also tried passing
> -Dplayerglobal.version=11.1 to ant but get the same error.

View raw message