flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harbs <gavha...@gmail.com>
Subject Re: Getting source working in Flash Builder
Date Thu, 21 Feb 2013 08:03:13 GMT
Okay. There's too much about the process that's kind of black magic to me. I guess after I
finish getting this working I'll understand how everything ties together better. That's a
good thing I guess… ;-)

I was under the impression that you could link to the source files instead of the swcs. Why
is the SDK libs different than regular libs?

On Feb 21, 2013, at 2:27 AM, Justin Mclean wrote:

> Hi,
> 
>> I did use the installer.
> Which would of given you last release 4.9.
> 
>> The issue is that I'm trying to use the source rather than the distribution for two
reasons:
>> 1) I wanted to look into the TLF bugs that were reported.
>> 2) I need the Alert and ColorPicker components that's not in the 4.9 release.
> 
> Make a release build from the source with ant release, copy and unzip/untar the release
and use the script in the IDE directory to make an SDK usable for Flash Builder or any other
IDE.
> 
>> Does the source need to be compiled before it can work?
> Um yes. The source gets compiled in swcs (in the frameworks/lib directory) that your
Flex application uses.
> 
>> I wonder if now would be a good time to try InteliJ IDEA...
> You would still have the package the SDK up, your issue is not unique to just Flash Builder.
> 
> Hope that helps.
> 
> Justin


Mime
View raw message