flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Harui (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (FLEX-33367) flash.display.Loader intermitently causing children of loaded swf to loose type
Date Thu, 24 Jan 2013 17:47:13 GMT

     [ https://issues.apache.org/jira/browse/FLEX-33367?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alex Harui resolved FLEX-33367.
-------------------------------

    Resolution: Invalid

The test case does not use Flex.  flash.display.Loader is part of the Adobe FlashPlayer, not
the Apache Flex project.
                
> flash.display.Loader intermitently causing children of loaded swf to loose type
> -------------------------------------------------------------------------------
>
>                 Key: FLEX-33367
>                 URL: https://issues.apache.org/jira/browse/FLEX-33367
>             Project: Apache Flex
>          Issue Type: Bug
>          Components: .Unspecified - Framework
>    Affects Versions: Adobe Flex SDK 4.6 (Release)
>         Environment: Seen on windows, mac and linux, various OS.
>            Reporter: Tim Leslie
>              Labels: loader
>
> Have a look at this stack overflow for a complete explaination and instruction on how
to reproduce: http://stackoverflow.com/questions/14464898/flash-display-loader-intermitently-causing-children-of-loaded-swf-to-loose-type
> When two movieclips are loaded into an application using a flash.display.Loader and Event.COMPLETE
is dispatched from both loaders on different frames, some instances in the first movieclip
to be loaded loose their type when the second movieclip becomes available. For example, a
recursive search for all decendents of type MC_Circle fails when normally it works. I have
been recomended to report this issue by users of Stack Overflow who were able to reproduce
it. I'm not sure of the full list of affected SDKs or Flash Player versions but I have been
using 4.6. I have only tried hosting the swfs to be loaded on linux machine though the problem
is reproducing with the loader swf on various OS. It's possible the problem only occurs when
loading over a network.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message