flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carol Frampton <cfram...@adobe.com>
Subject Re: Release target and Batik
Date Thu, 31 Jan 2013 00:59:46 GMT
It builds on both windows and Mac so I think it is something machine specific. Do a modules
thirdparty-clean and then rebuild. 

Sent from my iPhone

On Jan 30, 2013, at 7:57 PM, "Alex Harui" <aharui@adobe.com> wrote:

> It looks like batik/lib is in SVN.  Maybe the fix is to remove it from SVN,
> and add a mkdir for it in the init section of batik's build.xml.  Fred, can
> you try that out?
> 
> 
> On 1/30/13 4:50 PM, "Carol Frampton" <cframpto@adobe.com> wrote:
> 
>> I don't quite remember. I think the lib dir used to be in svn and now it is
>> not. It is created and deleted as part of the build process.
>> 
>> You could do a svn status on this directory. If it has a ? delete it.
>> 
>> Carol
>> 
>> 
>> 
>> Sent from my iPhone
>> 
>> On Jan 30, 2013, at 7:46 PM, "Frédéric THOMAS" <webdoublefx@hotmail.com>
>> wrote:
>> 
>>> Hi Carel,
>>> 
>>> Then, Could the problem come from the re-sync ?
>>> 
>>> -Fred
>>> 
>>> -----Message d'origine-----
>>> From: Carol Frampton
>>> Sent: Thursday, January 31, 2013 1:44 AM
>>> To: dev@flex.apache.org
>>> Cc: dev@flex.apache.org
>>> Subject: Re: Release target and Batik
>>> 
>>> There were some changes in this directory for 4.9.  I saw this error during
>>> the transition.  I'd delete the batik dir and resync  it and then try to
>>> build again.
>>> 
>>> Carol
>>> 
>>> Sent from my iPhone
>>> 
>>> On Jan 30, 2013, at 7:17 PM, "Alex Harui" <aharui@adobe.com> wrote:
>>> 
>>>> Might just be a bug that needs fixing so it ignores a missing folder.
>>>> I've
>>>> found that Windows ANT is more sensitive to missing folders.  Most of us
>>>> use
>>>> Macs which seems to ignore missing folders.
>>>> 
>>>> 
>>>> On 1/30/13 4:07 PM, "Frédéric THOMAS" <webdoublefx@hotmail.com> wrote:
>>>> 
>>>>> Hi,
>>>>> 
>>>>> I was trying to play with the release target but I encountered a problem
>>>>> [1],
>>>>> before the release target start, I¹ve got lib folder under batik but
it
>>>>> looks
>>>>> like it removed it during the release, which cause that error.
>>>>> 
>>>>> Can someone help ?
>>>>> 
>>>>> -Fred
>>>>> 
>>>>> [1]
>>>>> $ ant release
>>>>> Buildfile: U:\sources\asf\flex\sdk\developRC1\build.xml
>>>>> 
>>>>> check-playerglobal-home:
>>>>>   [echo] PLAYERGLOBAL_HOME is
>>>>> U:\sources\asf\flex\sdk\develop\frameworks\libs\player
>>>>>   [echo] playerglobal.version is 11.1
>>>>>   [echo] playerglobal.swc is
> U:\sources\asf\flex\sdk\develop\frameworks\libs\player/11.1/playerglobal.sw>>>>
> c
>>>>> 
>>>>> check-air-home:
>>>>>   [echo] AIR_HOME is U:\sources\adobe\air\3.4
>>>>> 
>>>>> check-pixelbender-home:
>>>>>   [echo] PIXELBENDER_HOME is C:\Program Files (x86)\Adobe\Adobe
>>>>> Utilities -
>>>>> CS5\Pixel Bender Toolkit 2
>>>>> 
>>>>> check-compile-env:
>>>>>   [echo] OS: Windows 7 / 6.1 / x86
>>>>>   [echo] VM: Java HotSpot(TM) Client VM / 20.8-b03
>>>>>   [echo] Java: 1.6.0_33
>>>>>   [echo] Ant: Apache Ant(TM) version 1.8.2 compiled on December 20 2010
>>>>> Ant
>>>>> Java Version: 1.6
>>>>> 
>>>>> check-runtime-env:
>>>>> 
>>>>> check-adobe-extension-manager-env:
>>>>>   [echo] ADOBE_EXTENSION_MANAGER is C:\Program Files (x86)\Adobe\Adobe
>>>>> Extension Manager CS5\Adobe Extension Manager
>>>>> CS5.exe
>>>>> 
>>>>> thirdparty-clean:
>>>>> 
>>>>> thirdparty-clean:
>>>>> 
>>>>> batik-jars-clean:
>>>>> 
>>>>> velocity-jars-clean:
>>>>> 
>>>>> clean:
>>>>> 
>>>>> thirdparty-clean:
>>>>> 
>>>>> swfobject-clean:
>>>>> 
>>>>> swfobject-fabridge-clean:
>>>>> 
>>>>> clean-adobe-flex-sdk:
>>>>> 
>>>>> clean:
>>>>> [delete] Deleting directory
>>>>> U:\sources\asf\flex\sdk\developRC1\lib\external\optional
>>>>> 
>>>>> modules-clean:
>>>>> 
>>>>> batik-clean:
>>>>> 
>>>>> init:
>>>>> 
>>>>> BUILD FAILED
>>>>> U:\sources\asf\flex\sdk\developRC1\build.xml:298: The following error
>>>>> occurred
>>>>> while executing this line:
>>>>> U:\sources\asf\flex\sdk\developRC1\modules\build.xml:170: The following
>>>>> error
>>>>> occurred while executing this line:
>>>>> U:\sources\asf\flex\sdk\developRC1\modules\thirdparty\batik\build.xml:161:
>>>>> U:\sources\asf\flex\sdk\developRC1\modules\th
>>>>> irdparty\batik\lib does not exist.
>>>>> 
>>>>> Total time: 1 second
>>>> 
>>>> -- 
>>>> Alex Harui
>>>> Flex SDK Team
>>>> Adobe Systems, Inc.
>>>> http://blogs.adobe.com/aharui
> 
> -- 
> Alex Harui
> Flex SDK Team
> Adobe Systems, Inc.
> http://blogs.adobe.com/aharui
> 
Mime
View raw message