flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: svn commit: r1433766 - /flex/sdk/branches/develop/ide/checkAllPlayerGlobals.sh
Date Wed, 16 Jan 2013 04:51:12 GMT



On 1/15/13 8:29 PM, "Justin Mclean" <justin@classsoftware.com> wrote:

> HI,
> 
>> The other script doesn't appear to download anything.
> /ide/frameworks/makeApacheFlexforFlashBuilder.sh uses curl to download several
> things including the 11.1 playergolobal.swc.
That seems like a problem.  If Om's installer had to require acceptance,
this script should as well.

> 
>>  and all of Adobe's websites try to make very clear the terms of use
> Totally unclear to me especially in that case as none of the licences refer to
> playerglobal specifically.
Yup, very confusing.  You should show the FP EULA.  In theory, newer
playerglobals aren't covered by the Adobe Flex SDK license, only the version
Adobe bundled (11.1)
> 
>> .We (Apache) should not circumven that,
> I'm certainly not trying to do that.
> 
> My intention is to make the SDK:
> a) Easier to reliably use and test. Currently we have no way of knowing which
> playerglobal.swc you are actually using. Copying files about of the same same
> give a large potential for confusion. Note the md5 checks in the script.
> b) Make it easier for users to use the version of the flash player they want
> to with the SDK.
Yup, all good.  We just have to "automate" visiting the Adobe site and
viewing that paragraph about usage terms, which I think you've done.

-- 
Alex Harui
Flex SDK Team
Adobe Systems, Inc.
http://blogs.adobe.com/aharui


Mime
View raw message