flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexandre Madurell <alexandre.madurell.f...@gmail.com>
Subject Re: building flex
Date Mon, 02 Jul 2012 14:47:46 GMT
Thanks Justin,

Source, actually (at first I tried binary, then source... my current issues
are with source).

It's basically target PackageMXP that fails. It's looking for stuff in the
folder \frameworks\projects\ instead of

I've modified the build.xml and FlexComponentKit.mxi so as to point to the
correct folders, then it succesfully runs that target.

The build.xml gave me permission-related problems (it couldn't create
/frameworks/flash-integration/FlexComponentKit.mxp, so I replaced the code
to create it
in /frameworks/projects/flash-integration/FlexComponentKit.mxp).

    <target name="PackageMXP" if="ADOBE_EXTENSION_MANAGER.set" >
        <echo message="Creating MXP file
${FLEX_HOME}/frameworks/projects/flash-integration/FlexComponentKit.mxp" />
        <exec executable="${env.ADOBE_EXTENSION_MANAGER}" dir="${basedir}"
            <arg value="-suppress" />
            <arg value="-package" />
            <arg value="mxi=${basedir}/FlexComponentKit.mxi" />

Then, all source values in the FlexComponentKit.mxi needed to be preceded
with flash-integration/

Once I had that, the main build would run, but it would still get stuck in
the next step (Compiling frameworks/libs/authoringsupport.swc), with a:

[compc] Error: Inconsistant linkage in
flash.utils:CompressionAlgorithm, flash.utils:IDataInput2,
flash.utils:IDataOutput2) - 'flash.utils:ByteArray' is marked as external,
but 'flash.utils:IDataInput2' is not.

Any clues?

Thanks again,

On Mon, Jul 2, 2012 at 1:38 PM, Justin Mclean <justin@classsoftware.com>wrote:

> Hi,
> > I've skipped Nick's instructions, updated all code from the repository,
> run
> > the build.xml within the trunk folder (not the one within the frameworks
> > folder)
> Did you download the source or binary release? If it was release you need
> to do an "ant thirdparty-downloads" rather than just ant.
> Hope that helps,
> Justin

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message