flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carol Frampton <cfram...@adobe.com>
Subject Re: time to help test the release candidate
Date Thu, 28 Jun 2012 13:07:40 GMT


On 6/27/12 7 :13PM, "Dasa Paddock" <dpaddock@esri.com> wrote:

>This build does fix the issue below with Flex Library projects trying to
>merge in the Flex SDK swcs. My previous warnings are gone.
>
>Now the problem is that the textLayout.swc is missing so I'm getting
>errors about Interface IOperation was not found since my code imports
>flashx.undo.IOperation.
>
>I also tried creating a regular new Flex web project with this build, and
>it doesn't compile either since it gets a "ISWFContext was not found"
>error which also comes from textLayout.swc . This is just with Flash
>Builder's default application mxml file.

Yes.  textLayout.swc and osmf.swc were incorrectly in the bin kit and I
fixed that bug yesterday.

>
>Is the plan for makeApacheFlexForFlashBuilder.sh to also add the
>textLayout.swc?

I think the majority of people will use Om's tool
(https://issues.apache.org/jira/browse/FLEX-33106) which will take care of
these.

I've been thinking about makeApacheFlexForFlashBuilder.sh and how to
incorporate all the downloads.  I plan to do something about that today.
For now, after you build a Flex SDK with the script, cd to the frameworks
directory of the new Flex SDK and type "ant thirdparty-downloads" and that
will get you swfobject, textLayout.swc and osmf.swc downloaded into your
Flex SDK.  You will still be missing the BlazeDS integration and the
embedded font jars.

Carol

>
>Thanks,
>--Dasa
>
>On Jun 27, 2012, at 2:55 PM, Carol Frampton wrote:
>
>> http://people.apache.org/~cframpton/ApacheFlexRC/1354725/ which is the
>> currently, the current kit should have the fix for this problem.  If you
>> could give it a try I'd appreciate it.
>> 
>> 
>> Carol
>> 
>> On 6/26/12 11 :56AM, "Dasa Paddock" <dpaddock@esri.com> wrote:
>> 
>>> 
>>> On Jun 26, 2012, at 8:13 AM, Carol Frampton wrote:
>>> 
>>>> 
>>>> 
>>>> On 6/22/12 6 :46PM, "Dasa Paddock" <dpaddock@esri.com> wrote:
>>>> 
>>>>> I downloaded the latest from
>>>>> http://people.apache.org/~cframpton/ApacheFlexRC/current/, ran the
>>>>> makeApacheFlexForFlashBuilder.sh tool and then created a new SDK in
>>>>> Flash
>>>>> Builder 4.6. I updated my Flex Library Project to use my new 4.8.0
>>>>>SDK
>>>>> and my project compiles, but I get four warnings like this:
>>>>> 
>>>>> "The swc '/Applications/Adobe Flash Builder
>>>>> 4.6/sdks/4.8.0/frameworks/libs/charts.swc' has style defaults and is
>>>>>in
>>>>> the library-path, which means dependencies will be linked in without
>>>>> the
>>>>> styles.  This can cause applications, which use the output swc, to
>>>>>have
>>>>> missing skins.  The swc should be put in the external-library-path."
>>>>> 
>>>>> When I look at my project settings under Flex Library Build Path ->
>>>>> Library path, the Framework linkage is "Use default (external)".
>>>>> 
>>>>> If I then expand the charts.swc under Apache Flex 4.8.0, the Link
>>>>>Type
>>>>> is
>>>>> "Merged into code".
>>>>> 
>>>>> Do I need to manually change it to External like it was for 4.6.0?
>>>>> When I
>>>>> double click on that, the options dialog that opens does not have
>>>>>"Same
>>>>> as framework" checked.
>>>>> 
>>>>> Can this be changed so that it behaves the same as for SDK 4.6.0?
>>>> 
>>>> I'm not sure what you want changed.
>>>> 
>>>> I built a FlashBuilder SDK yesterday afternoon with
>>>> makeApacheFlexForFlashBuilder.sh
>>>> 
>>>> In FlashBuilder v4.6, I added my Apache Flex 4.8.0 SDK.  I created a
>>>>new
>>>> Flex project called charts, selected the Apache Flex 4.8.0 SDK, and
>>>>took
>>>> all the defaults.  I then cut and pasted the contents of BasicPie.mxml
>>>> from 
>>>> 
>>>> 
>>>>http://help.adobe.com/en_US/flex/using/WS2db454920e96a9e51e63e3d11c0bf6
>>>>56
>>>> 8f
>>>> -8000.html into the chart.mxml.  It build cleanly.
>>>> 
>>>> If I look at the project's Properties -> Library Path the Framework
>>>> linkage is "Use SDK default (merged into code)".  If I click into
>>>> charts.swc the Link Type is "merged into code".
>>>> 
>>>> Caro
>>> 
>>> 
>>> It is fine for a regular Flex Project. My issue is when creating a new
>>> "Flex Library Project". If you try that, the "Framework linkage" is
>>>"Use
>>> default (external)", but all the swcs are set to merge and their
>>>Linkage
>>> "Same as framework" checkbox is not checked. I don't think library
>>> projects should merge in the Flex SDK swcs and this was working fine
>>>with
>>> SDK 4.6.0.
>>> 
>>> Thanks,
>>> --Dasa
>> 
>> 
>


Mime
View raw message