flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Mclean <jus...@classsoftware.com>
Subject Re: minor Validator improvment
Date Wed, 28 Mar 2012 21:39:00 GMT

> True enough, and if enough people feel strongly about this, we can just add
> a new method instead of replacing the existing one (not sure what to call it
> though).  Personally, when using the validateAll method, I usually check the
> length of the return, but don't use many other Array properties or methods.

That I'd guess would be the most common way of using it followed by a cast (which this change
would avoid) if the length is greater than 1.

I'm a bit on the fence with this change having a typed return is better but existing code
would have to change. 

Perhaps it should be bundled up into with other validator changes to modernise the classes?
But not sure exactly what off the top of my head.

View raw message