flex-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pio...@apache.org
Subject svn commit: r22884 - in /dev/flex/installer/3.3: ./ rc1/ rc1/binaries/
Date Mon, 06 Nov 2017 17:24:52 GMT
Author: piotrz
Date: Mon Nov  6 17:24:52 2017
New Revision: 22884

Log:
Add once again Apache Flex Installer 3.3 RC1 with sources

Added:
    dev/flex/installer/3.3/
    dev/flex/installer/3.3/rc1/
    dev/flex/installer/3.3/rc1/ApproveInstaller.xml   (with props)
    dev/flex/installer/3.3/rc1/READme   (with props)
    dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz   (with props)
    dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz.asc   (with props)
    dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz.md5   (with props)
    dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip   (with props)
    dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip.asc   (with props)
    dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip.md5   (with props)
    dev/flex/installer/3.3/rc1/binaries/
    dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg   (with props)
    dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg.asc   (with
props)
    dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg.md5   (with
props)
    dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe   (with props)
    dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe.asc   (with
props)
    dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe.md5   (with
props)

Added: dev/flex/installer/3.3/rc1/ApproveInstaller.xml
==============================================================================
--- dev/flex/installer/3.3/rc1/ApproveInstaller.xml (added)
+++ dev/flex/installer/3.3/rc1/ApproveInstaller.xml Mon Nov  6 17:24:52 2017
@@ -0,0 +1,383 @@
+<?xml version="1.0"?>
+<!--
+
+  Licensed to the Apache Software Foundation (ASF) under one or more
+  contributor license agreements.  See the NOTICE file distributed with
+  this work for additional information regarding copyright ownership.
+  The ASF licenses this file to You under the Apache License, Version 2.0
+  (the "License"); you may not use this file except in compliance with
+  the License.  You may obtain a copy of the License at
+
+      http://www.apache.org/licenses/LICENSE-2.0
+
+  Unless required by applicable law or agreed to in writing, software
+  distributed under the License is distributed on an "AS IS" BASIS,
+  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+  See the License for the specific language governing permissions and
+  limitations under the License.
+
+-->
+
+<project name="ApproveApacheFlexInstaller" default="main" basedir=".">
+
+
+    <!-- Required for OSX 10.6 / Snow Leopard Performance. -->
+    <!-- Java 7 on Mac requires OSX 10.7.3 or higher and is 64-bit only -->
+    <!-- local.d32 is set/used in build.properties so this needs to be done first. -->
+    <condition property="local.d32" value="-d32">
+        <and>
+            <os family="windows"/>
+            <equals arg1="${sun.arch.data.model}" arg2="64"/>
+            <equals arg1="${os.arch}" arg2="x86_64"/>
+            <equals arg1="${ant.java.version}" arg2="1.6"/>
+        </and>
+    </condition>
+
+    <condition property="isMac" value="mac">
+        <os family="mac" />
+    </condition>
+    <condition property="isWindows" value="windows">
+        <os family="windows" />
+    </condition>
+    <condition property="isLinux" value="linux">
+		<and>
+			<os family="unix" />
+			<not>
+				<isset property="isMac" />
+			</not>
+		</and>
+    </condition>
+    <condition property="package.suffix" value="zip">
+        <os family="windows" />
+    </condition>
+	<property name="package.suffix" value="tar.gz" />
+	
+	<property name="rat.report" value="${basedir}/rat-report.txt"/>
+    <property name="apache.rat.jar" value="apache-rat-0.11.jar" />
+    <property name="apache.rat.tasks.jar" value="apache-rat-tasks-0.11.jar" />
+    <property name="apache.rat.url" value="http://search.maven.org/remotecontent?filepath=org/apache/rat/apache-rat/0.11"
/>
+    <property name="apache.rat.tasks.url" value="http://search.maven.org/remotecontent?filepath=org/apache/rat/apache-rat-tasks/0.11"
/>
+	
+	<property name="mac.text.display" value="cat" />
+	<property name="win.text.display" value="type" />
+	<property name="linux.text.display" value="cat" />
+    
+    <property file="${basedir}/approveinstaller.properties"/>
+    <property environment="env"/>
+
+    <property name="build.target" value="main" />
+    
+	<condition property="do.copy.downloads" >
+		<isset property="download.cache.dir" /> 
+	</condition>
+	
+    <fail message="The ANT_HOME environment variable is not set."
+        unless="env.ANT_HOME"/>
+		
+	<available file="${env.FLEX_HOME}" 
+		type="dir" 
+		property="FLEX_HOME" value="${env.FLEX_HOME}" />
+
+    <fail message="The FLEX_HOME property is not set in environment or command-line."
+        unless="FLEX_HOME"/>
+				
+	<available file="${env.AIR_HOME}" 
+		type="dir" 
+		property="AIR_HOME" value="${env.AIR_HOME}" />
+
+    <fail message="The AIR_HOME property is not set in environment or command-line."
+        unless="AIR_HOME"/>
+		
+    <available file="${env.ANT_HOME}/lib/${apache.rat.jar}"
+        type="file"
+        property="apache.rat.found"/>
+    <available file="${env.ANT_HOME}/lib/${apache.rat.tasks.jar}"
+        type="file"
+        property="apache.rat.tasks.found"/>
+		
+    <fail message="The release version is not set.  Specify -Drelease.version=&lt;release
version (e.g. 3.1, 3.2, etc)&gt;"
+    unless="release.version"/>
+
+    <condition property="package.url.path"
+        value="http://apacheflexbuild.cloudapp.net:8080/job/flex-sdk_installer_release-candidate/lastSuccessfulBuild/artifact/out">
+        <not>
+            <isset property="rc" />
+        </not>
+    </condition>
+
+	<property name="package.url.path" value="https://dist.apache.org/repos/dist/dev/flex/installer/${release.version}/rc${rc}"
/>
+	<property name="package.url.name" value="apache-flex-sdk-installer-${release.version}.0-src"
/>
+	
+    <condition property="zip.compressed">
+        <equals arg1="zip" arg2="${package.suffix}" />
+    </condition>
+    
+	<target name="display-text-mac" if="isMac">
+		<echo>========================= Begin ${file} ==============================</echo>
+		<exec executable="${mac.text.display}" >
+			<arg value="${file}" /> 
+		</exec>
+		<echo>========================= End ${file} ==============================</echo>
+	</target>
+	<target name="display-text-win" if="isWindows">
+		<pathconvert targetos="windows" property="winfile">
+			<path path="${file}" />
+		</pathconvert>
+		<echo>========================= Begin ${winfile} ==============================</echo>
+		<exec executable="cmd.exe" >
+			<arg value="/c" />
+			<arg value="${win.text.display}" />
+			<arg value="${winfile}" /> 
+		</exec>		
+		<echo>========================= End ${winfile} ==============================</echo>
+	</target>
+	<target name="display-text-linux" if="isLinux">
+		<echo>========================= Begin ${file} ==============================</echo>
+		<exec executable="${linux.text.display}" >
+			<arg value="${file}" /> 
+		</exec>
+		<echo>========================= End ${file} ==============================</echo>
+	</target>
+	
+	<target name="install-rat" depends="install-rat.jar,install-rat.tasks.jar" />
+	<target name="install-rat.jar" unless="apache.rat.found">
+		<get src="${apache.rat.url}/${apache.rat.jar}" dest="${env.ANT_HOME}/lib/${apache.rat.jar}"
/>
+	</target>
+	<target name="install-rat.tasks.jar" unless="apache.rat.tasks.found">
+		<get src="${apache.rat.url}/${apache.rat.tasks.jar}" dest="${env.ANT_HOME}/lib/${apache.rat.tasks.jar}"
/>
+	</target>
+	
+    <target name="rat-taskdef" description="Rat taskdef">
+        <typedef resource="org/apache/rat/anttasks/antlib.xml"
+        uri="antlib:org.apache.rat.anttasks"
+        classpathref="anttask.classpath"/>
+    </target>
+
+    <target name="main" depends="install-rat,download,check-sigs,uncompress,rat-check,check-notices,build,approve"
description="Perform required release approval steps">
+    </target>
+    
+    <target name="main-no-download" depends="install-rat,check-sigs,uncompress,rat-check,check-notices,build,approve"
description="Perform required release approval steps">
+    </target>
+	
+    <target name="test" >
+		<echo>${rat.report}.bin.txt</echo>
+		<replaceregexp file="${rat.report}.bin.txt" match="..AL.*" replace="" byline="true"/>
+    </target>
+	
+	<target name="display-text" >
+		<antcall target="display-text-mac" />
+		<antcall target="display-text-win" />
+		<antcall target="display-text-linux" />
+	</target>
+
+	<target name="display-text-test" >
+		<antcall target="display-text" >
+			<param name="file" value="${basedir}/rat-report.txt" />
+		</antcall>
+	</target>
+	
+    <target name="download" description="download the release package">
+        <get src="${package.url.path}/${package.url.name}.${package.suffix}"
+            dest="${basedir}/${package.url.name}.${package.suffix}" />
+        <get src="${package.url.path}/${package.url.name}.${package.suffix}.md5"
+            dest="${basedir}/${package.url.name}.${package.suffix}.md5" />
+            <antcall target="asc_get" />
+    </target>
+    
+    <target name="asc_get" if="rc" >
+        <get src="${package.url.path}/${package.url.name}.${package.suffix}.asc"
+        dest="${basedir}/${package.url.name}.${package.suffix}.asc" />
+    </target>
+    
+    <target name="check-sigs" description="check md5 and gpg sigs">
+		<replace file="${basedir}/${package.url.name}.${package.suffix}.md5"
+			token=" " />
+		<checksum file="${basedir}/${package.url.name}.${package.suffix}" algorithm="md5" verifyproperty="md5.ok"
/>
+        <condition property="MD5Invalid">
+			<not>
+				<equals arg1="${md5.ok}" arg2="true" />
+			</not>
+        </condition>
+        <fail message="MD5 checksum did not match" if="MD5Invalid" />
+        <echo>rc is ${rc}</echo>
+        <antcall target="gpg_check" />
+    </target>
+    
+    <target name="gpg_check" if="rc">
+        <exec executable="gpg" failonerror="true">
+            <arg value="--verify" />
+            <arg value="${basedir}/${package.url.name}.${package.suffix}.asc" />
+            <arg value="${basedir}/${package.url.name}.${package.suffix}" />
+        </exec>
+    </target>
+
+    <target name="uncompress" depends="pre-clean, untar-file, unzip-file" />
+
+    <target name="pre-clean" description="remove old uncompressed package" >
+		<delete dir="${basedir}/${package.url.name}" failonerror="false" />
+	</target>
+	
+    <target name="untar-file" unless="zip.compressed" description="Untars zipFile">
+        <untar src="${basedir}/${package.url.name}.${package.suffix}"
+                dest="${basedir}/${package.url.name}" compression="gzip"/>
+    </target>
+
+    <target name="unzip-file" if="zip.compressed" description="Unzips zipFile">
+        <unzip src="${basedir}/${package.url.name}.${package.suffix}"
+                dest="${basedir}/${package.url.name}"/>
+    </target>
+
+    <target name="rat-check" >
+
+        <echo message="Checking files at ${basedir}/${package.url.name}, report is ${rat.report}"/>
+
+        <rat:report xmlns:rat="antlib:org.apache.rat.anttasks"
+            reportFile="${rat.report}">
+            <fileset dir="${basedir}/${package.url.name}">
+                <!-- exclude media (png, gif, jpg, mp3, flv) -->
+                <exclude name="**/*.png"/>
+                <exclude name="**/*.gif"/>
+                <exclude name="**/*.jpg"/>
+                <exclude name="**/*.mp3"/>
+                <exclude name="**/*.flv"/>
+                <exclude name="build.number"/>
+                <exclude name="CONTRIBUTING"/>
+                <exclude name="CONTRIBUTORS"/>
+            </fileset>
+        </rat:report>
+		<antcall target="display-text" >
+            <param name="file" value="${rat.report}" />
+        </antcall>
+        <input
+			message="Check that there are no unknown or unapproved licenses or archives. Is it ok?"
+            validargs="y,n"
+        defaultvalue="y"
+        addproperty="rat.license.ok"/>
+		<echo>filtering out AL files to make it easier to see binary files</echo>
+		<copy file="${rat.report}" tofile="${rat.report}.bin.txt" />
+		<replaceregexp file="${rat.report}.bin.txt" match="..AL.*" replace="" byline="true"/>
+		<antcall target="display-text" >
+            <param name="file" value="${rat.report}.bin.txt" />
+        </antcall>
+        <input
+			message="Check that there are no unexpected binaries.  Is it ok?"
+            validargs="y,n"
+        defaultvalue="n"
+        addproperty="rat.binaries.ok"/>
+    </target>
+
+    <target name="check-notices" description="open each notice file for review, grep for
a few things" >
+        <fail message="README not in package">
+			<condition>
+	            <not>
+    	            <available file="${basedir}/${package.url.name}/README" />
+        	    </not>
+			</condition>
+        </fail>
+        <fail message="RELEASE_NOTES not in package">
+			<condition>
+				<not>
+					<available file="${basedir}/${package.url.name}/RELEASE_NOTES" />
+				</not>
+			</condition>
+        </fail>
+        <fail message="NOTICE not in package">
+			<condition>
+				<not>
+					<available file="${basedir}/${package.url.name}/NOTICE" />
+				</not>
+			</condition>
+        </fail>
+        <fail message="LICENSE not in package">
+			<condition>
+				<not>
+					<available file="${basedir}/${package.url.name}/LICENSE" />
+				</not>
+			</condition>
+        </fail>
+		<antcall target="display-text" >
+            <param name="file" value="${basedir}/${package.url.name}/README" />
+        </antcall>
+		<input
+			message="Check the README for version numbers, spelling, grammar, accuracy.  Is it ok?"
+            validargs="y,n"
+        defaultvalue="y"
+        addproperty="readme.ok"/>
+		
+		<antcall target="display-text" >
+            <param name="file" value="${basedir}/${package.url.name}/RELEASE_NOTES" />
+        </antcall>
+		<input
+			message="Check the RELEASE_NOTES for copyright years, spelling, grammar, accuracy. Is
it ok?"
+            validargs="y,n"
+        defaultvalue="y"
+        addproperty="releasenotes.ok"/>
+		
+		<antcall target="display-text" >
+            <param name="file" value="${basedir}/${package.url.name}/NOTICE" />
+        </antcall>
+		<input
+			message="Check the NOTICE for required notices from third-parties. Is it ok?"
+            validargs="y,n"
+        defaultvalue="y"
+        addproperty="notice.ok"/>
+
+		<antcall target="display-text" >
+            <param name="file" value="${basedir}/${package.url.name}/LICENSE" />
+        </antcall>
+		<input
+			message="Check the LICENSE for the Apache License and third-party licenses. Is it ok?"
+            validargs="y,n"
+        defaultvalue="y"
+        addproperty="license.ok"/>
+    </target>
+
+    <target name="build" depends="copy.downloads">
+		<input
+			message="The final step is to run the build and any tests the build script runs.  This
can take several minutes.  Press y to start the build."
+            validargs="y"
+        defaultvalue="y" />
+        <ant dir="${basedir}/${package.url.name}/ant_on_air" target="main" />
+        <ant dir="${basedir}/${package.url.name}" target="build" />
+    </target>
+
+    <target name="copy.downloads" if="${do.copy.downloads}" description="instead of actually
downloading all of the dependencies, you can save lots of time by just copying from some other
folder in some other SDK.">
+		<echo>Copying downloads</echo>
+        <copy todir="${basedir}/${package.url.name}/in" >
+			<fileset dir="${download.cache.dir}" />
+		</copy>
+    </target>
+    	
+	<target name="approve" >
+		<condition property="vote" value="+1">
+			<and>
+				<equals arg1="${rat.license.ok}" arg2="y" />
+				<equals arg1="${rat.binaries.ok}" arg2="y" />
+				<equals arg1="${readme.ok}" arg2="y" />
+				<equals arg1="${releasenotes.ok}" arg2="y" />
+				<equals arg1="${notice.ok}" arg2="y" />
+				<equals arg1="${license.ok}" arg2="y" />
+			</and>
+		</condition>
+		<property name="vote" value="-1" />
+		<echo>
+${vote}
+Package ${package.url.path}/${package.url.name}.${package.suffix}
+Java ${ant.java.version}
+OS: ${os.name} ${os.arch} ${os.version}
+Source kit signatures match: y
+Source kit builds: y
+README is ok: ${readme.ok}
+RELEASE_NOTES is ok: ${releasenotes.ok}
+NOTICE is ok: ${notice.ok}
+LICENSE is ok: ${license.ok}
+No unapproved licenses or archives: ${rat.license.ok}
+No unapproved binaries: ${rat.binaries.ok}
+		</echo>
+		<fail>
+			<condition>
+	            <equals arg1="-1" arg2="${vote}"/>
+			</condition>
+		</fail>
+	</target>
+</project>

Propchange: dev/flex/installer/3.3/rc1/ApproveInstaller.xml
------------------------------------------------------------------------------
    svn:eol-style = native

Added: dev/flex/installer/3.3/rc1/READme
==============================================================================
--- dev/flex/installer/3.3/rc1/READme (added)
+++ dev/flex/installer/3.3/rc1/READme Mon Nov  6 17:24:52 2017
@@ -0,0 +1,204 @@
+<!--
+
+Licensed to the Apache Software Foundation (ASF) under one or more
+contributor license agreements.  See the NOTICE file distributed with
+this work for additional information regarding copyright ownership.
+The ASF licenses this file to You under the Apache License, Version 2.0
+(the "License"); you may not use this file except in compliance with
+the License.  You may obtain a copy of the License at
+
+http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
+
+-->
+
+==========================================================================================
+Overview:
+==========================================================================================
+
+- The Apache Flex SDK Installer AIR application provides an easy installation of the 
+  Apache Flex SDK and all its dependencies.  This will make it suitable for working with

+  IDEs such as Adobe Flash Builder, FDT, IntelliJ IDEA, FlashDevelop, etc.  
+  When installing an Apache Flex SDK, the application downloads the following
+  dependencies:
+    - The AIR sdk (Windows vs. Mac) based on the current platform
+    - Adobe Flash Player playerglobal.swc
+    - SWFObject
+    - Open Source Media Framework (OSMF)
+	 
+  Optionally, the application will download these files if the user explicitly agrees to

+  the licensing terms:
+    - Adobe embedded font support
+
+  Other release packages may download different dependencies.
+ 
+- The Apache Flex SDK Installer 3.0 and later supports the ability to install 
+  virtually anything that can be installed via an Apache Ant script.  The list 
+  of choices to install are described in 
+  installer/src/installer/sdk-installer-config-4.0.xml and posted to
+  http://flex.apache.org/installer/sdk-installer-config-4.0.xml.  By default, the
+  installer looks there to determine the list of choices.  Once a selection is made,
+  the installer then looks in the folder of the install package for a -config.xml file
+  and if found, uses that to determine the set of licensing options that need to be
+  accepted before installing.  The installer then uncompresses the install package and
+  looks for installer.xml and runs that script via an approximation of Apache Ant that
+  has been written in ActionScript.  If the -config.xml file is not found, the Installer
+  assumes it is installing an older version of the Apache Flex SDK.
+
+- When installing an older version of the Apache Flex SDK, the installer
+  determines the file names and urls of the downloaded files from 
+  installer/src/installer/sdk-installer-config-4.0.xml. When the dependencies file 
+  names or urls change in future, update the sdk-installer-config-4.0.xml to ensure 
+  that the application works correctly.  For newer installs driven by Apache Ant
+  scripts, the file names and urls are determined by the script itself.
+    
+- The application uses http://flex.apache.org/single-mirror-url.cgi to determine
+  the preferred mirror url to use to download the binary package.  Newer installs
+  that use Apache Ant scripts use their own logic to select dependencies from mirrors.
+  
+- Once the binary package is downloaded, a MD5 hash is generated for it.  
+  This hash is compared with the hash from the Apache Flex SDK release site.  
+  If they match, we verify that the downloaded binary package is a valid Apache release and

+  proceed to unzip the file.  
+	
+- If required, the Adobe AIR SDK will be downloaded and the relevant files are copied 
+  to the required locations.
+  
+- If required, the Adobe Flash Player playerglobal.swc file and the config files 
+  are placed in the required locations.
+  
+- Then the rest of the external dependencies and the optional files (if selected by user)

+  are downloaded and copied into the appropriate locations.  
+
+- If you experience problems with the install, please try again, but right-click
+  and select "Verbose Logging" to add more information to the log. 
+
+- From the 2.6 version, you can select the version of Adobe Flash Player and Adobe AIR SDK
+  the installer downloads.
+
+- From the 2.5 version, by default, Apache Flex SDK Installer 2.5 downloads Adobe Flash 
+  Player 11.1 and Adobe AIR SDK 3.4. 
+  If you want to change it to any other supported combination, you save a copy of the 
+  config file found at: http://flex.apache.org/installer/sdk-installer-config-3.0.xml, 
+  modify the download urls to point to the required versions.  Then run the app from 
+  command line mode with the optional command line parameter: -config=<path to config
file>
+
+- If building the app for Linux, open InstallApacheFlex-app.xml and change the Adobe AIR

+  namespace from http://ns.adobe.com/air/application/4.0 to 
+  http://ns.adobe.com/air/application/2.6  This is because AIR 2.6 is the latest available

+  version on Linux.  
+	
+==========================================================================================
+How to build the installer using ANT (no Flash Builder or any other IDE required):
+==========================================================================================
+
+0.  Make sure you have the right version of the Adobe AIR SDK.  Apache Flex Installer
+    3.1 uses Adobe AIR SDK 4.0.  If you want to use an older version of the AIR SDK,
+    you will have to change the namespace in the following files:
+	installer/src/InstallApacheFlex-app.xml
+	ant_on_air/tests/AntOnAIR-app.xml.
+
+1.  Unzip the source distribution.  You should see the 'installer' directory and the 
+    'common' and 'ant_on_air' directories in the root.
+
+2.  In the ant_on_air directory, run:
+        ant [-DFLEX_HOME=/path/to/apache/flex/sdk] [-DAIR_HOME=/path/to/air/sdk]
+            
+    FLEX_HOME is the absolute path to the Apache Flex SDK
+        If you omit this argument, and the system environment variable, FLEX_HOME exists,
+        it is used.  Otherwise, the FLEX_HOME_MAC or FLEX_HOME_WIN property in 
+        installer/build.properties is used.
+        
+    AIR_HOME is the absolute path to the Adobe AIR SDK
+        If you omit this argument, and the system environment variable, AIR_HOME exists,
+        it is used.  Otherwise, the AIR_HOME_MAC or AIR_HOME_WIN property in 
+        installer/build.properties is used.
+          	
+3.  In the root directory, run:
+        ant build [-DFLEX_HOME=/path/to/apache/flex/sdk] [-DAIR_HOME=/path/to/air/sdk]
+        
+4.  The installer executable file created in the installer/release directory.  If you are

+    on Windows, you will see an .exe file; if you are on Mac OS, you will see a .dmg file.
 
+	A temporary digital signing certificate - temp.p12 will be created in the installer 
+	directory as well.  The password for this file is available in the build.properties 
+	file (var: TEMP_PASS_CHANGE_THIS)
+
+==========================================================================================
+How to set up the project for working with Adobe Flash Builder 4.7:
+==========================================================================================
+
+1.  Unzip the source distribution.  You should see the 'installer' directory and the 
+    'common' and 'ant_on_air' directories in the root.
+
+2.  In the installer directory run: 
+        ant get-as3commons.swc
+        ant get-as3httpdclient.swc
+    These step downloads the required libraries and saves it in the libs directory.
+
+3.  If using Adobe Flash Builder, add a linked resource called: 
+        APACHE_FLEX_UTILITIES_ROOT 
+    and point it to the directory path where the 'installer' and 'common' directories are

+    located.
+
+4.  In the installer project, add ${APACHE_FLEX_UTILITIES_ROOT}/common/src as a source path.
+
+5.  In the installer project, add ${APACHE_FLEX_UTILITIES_ROOT}/ant_on_air/src as a source
path.
+
+6.  In the installer project, add ${APACHE_FLEX_UTILITIES_ROOT}/ant_on_air/external as a
source path.
+
+7.  In the installer project, add ${APACHE_FLEX_UTILITIES_ROOT}/ant_on_air/locale/{locale}
as a source path.
+
+==========================================================================================
+How to set up the project for working with JetBrains IDEA 12+
+==========================================================================================
+
+1.  Setup a new project by either unzipping the downloaded source or grabbing the source
from the version control.
+
+2.  During the project setup, DO NOT search for modules or frameworks.  We will set these
up later.
+
+3.  Setup a new module by going to the File -> New Module menu.
+    Module Type :  Flash
+    Target Platform : Desktop
+    Output Type : Application
+    Create Sample App :  Unchecked
+    Create HTML Wrapper : Unchecked
+
+    Create the new module, name it "installer" and chose the ${APACHE_FLEX_UTILITIES_ROOT}/installer
directory
+
+4.  After the module is created, go into the installer module settings (Right-Click ->
 Open Module Settings)
+
+5.  Add the following Content Roots :
+    flex-utilities\ant_on_air
+    flex-utilities\common
+
+6.  Mark the following directories as Sources :   (some may already be marked as src)
+    flex-utilities\ant_on_air\src
+    flex-utilities\ant_on_air\external
+    flex-utilities\common\src
+    flex-utilities\installer\src
+
+7.  Close the Settings dialog
+
+8.  Open the Ant Build tab within IDEA.
+    Add the flex-utilities\build.xml ANT build script.
+
+9.  Run the get-as3commons.swc and get-as3httpdclient.swc ant target.  This will download
the required SWC to build the installer.
+
+10. Return to the module properties, and go to the dependencies tab.  Make sure the following
are listed :
+    Flex SDK
+    flex-utilities\installer\libs
+    flex-utilities\installer\common\bin\common.swc
+    flex-utilities\installer\ant_on_air\bin\ant_on_air.swc
+    flex-utilities\ant_on_air\external\libs\as3commons-zip-1.0.0-alpha.1.swc
+
+11. Apply and close the dialog box.
+
+12. Update the flex-utilities\installer\build.properties to match your settings.  In theory
you should only
+    have to update the FLEX_HOME_WIN or FLEX_HOME_MAC property to point to your SDK with
AIR 4.0 overlaid.
+
+You should now be able to build and debug the installer.

Propchange: dev/flex/installer/3.3/rc1/READme
------------------------------------------------------------------------------
    svn:eol-style = native

Propchange: dev/flex/installer/3.3/rc1/READme
------------------------------------------------------------------------------
    svn:executable = *

Added: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz
==============================================================================
Binary file - no diff available.

Propchange: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz
------------------------------------------------------------------------------
    svn:executable = *

Propchange: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz
------------------------------------------------------------------------------
    svn:mime-type = application/octet-stream

Added: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz.asc
==============================================================================
--- dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz.asc (added)
+++ dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz.asc Mon Nov  6 17:24:52
2017
@@ -0,0 +1,17 @@
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iQIcBAABCAAGBQJaAHRlAAoJEGsKfskFBh/In+oP/10MXi5b/0pQPrxyJO1+q1kZ
+4fnzSr6TxhleJsMTm5L7a96n04DSXPnreGOra0be7KcIZRtGBxhqCu0dPoEFrCdF
+GQAeL2QEqkN2QgsEsEpZK/MXcmzPLauTVxoIynbxLe1qkzmi1Gg+eOj+KWkM86mu
+iHR9gs3x3g3aymlmlmXAHzb1kIklj8N2IF6IiRCEPdvo6oS5BNcNB2rYI/ny3/dV
+0JjoPodZ4YmaP1r1KKY35CzC6txJ/59oJUOF7Wg7iIxouT8+weUr4wsSz24iRjaa
+Gt1VQ26Lrjy+Cizgv7X0GeaIrTs2ffKMjYld/zRBAMuvMe0/mefRn7gJy3wyaSNf
+/NXyqXNydrSNxz89cmxR8dACl9K2bG47cmleU4XD6yIyZjShvQ0kFDtd7OIML2hf
+2AM8kdwuY9O8oyksD/0H8+fI0rgQXykpowBeo9wlSq1Q8m/GZqyPnz4T8dZF5Qi2
+LM2uVSL8NTCHJn4cos10E9ZSfTY406x5lXitBrJvQCA2j2y1FUC1bjyKV7zcGn7d
+N33CpLMUao16QYLlQOmzJooKONJDUJG6aLmWgaTkGklhIoOKuNIzH4zMqSAC8zGF
+xJ9Tg4akjP4pco5ZGMVHAomMnI3t/6mhwhW7wPAirn/djTJBvWB6VowyBC6h2tlZ
+hRUlyWLmzJQrv15R4k5M
+=VB/r
+-----END PGP SIGNATURE-----

Propchange: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz.asc
------------------------------------------------------------------------------
    svn:eol-style = native

Propchange: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz.asc
------------------------------------------------------------------------------
    svn:executable = *

Added: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz.md5
==============================================================================
--- dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz.md5 (added)
+++ dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz.md5 Mon Nov  6 17:24:52
2017
@@ -0,0 +1 @@
+303c2c47f4d2c8fea60713ebe5ef11bb

Propchange: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.tar.gz.md5
------------------------------------------------------------------------------
    svn:eol-style = native

Added: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip
==============================================================================
Binary file - no diff available.

Propchange: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip
------------------------------------------------------------------------------
    svn:executable = *

Propchange: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip
------------------------------------------------------------------------------
    svn:mime-type = application/octet-stream

Added: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip.asc
==============================================================================
--- dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip.asc (added)
+++ dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip.asc Mon Nov  6 17:24:52
2017
@@ -0,0 +1,17 @@
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iQIcBAABCAAGBQJaAHRlAAoJEGsKfskFBh/IbKgP/j3cIkyMUyBV+iJ38HJH0lOB
+Z+cJceKFhu6lUGgzbIZN0UbkWpm2/o7gqOY9Y5/zhzQ15STLX5DlyG+82jvmzWkW
+YyRP9H6owgwIRlHZb7kStaN8qucY7nqC2dF4wOhl8BzOJIBF5rfYcgtqtfnY9XNU
+6VK86nvomt2oYf/FUDIh4RrSmnQZ34A6152TDW50vlRlatVL+1M6YyLoBCHaZie7
+53GO0SkNPjwseXoHbFBryPpcrsTH4CftopO59Be17eYWuZnOX4OD7SbJrxsckDWJ
+zm9uHFgQvaWrh5c0pedKAbmmc+mkUyRwsh5EYcWl2zEjIJbZZsJUkk3uCzdJzqps
+Xb/e0jFoSx36sbZjW8+vGBrrQE/eMRIko8EOmOUB8Z3a3YPxK56VgGPrW4Iz7AD0
+y6vbSPAwvpP9XwiRL+48njR3SoKK2qGSl5A5Q+nkqwMDL7fzmOvfHRDonMF9oGaP
+3Wt1fSfv4exq5Zds0Fzaxyr/uRd481Ygkae0I2iFLQLgi2/JFBWnlasWYoXcD5UE
+xWFEZRCFICZHO1VOAlsupb2vcUgDnd1ZZ2IlUQikrjYBeE97Dj3jotJwrPE2pO7M
+xzITKXL7I2rCvNEHN2VmQsg5rfTwLGDJEnITj8iQwdMmrJ6/41eNq+gmxs5SUGRo
+9eyZ6pKSdx/wUo2V8iSj
+=C2Zo
+-----END PGP SIGNATURE-----

Propchange: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip.asc
------------------------------------------------------------------------------
    svn:eol-style = native

Propchange: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip.asc
------------------------------------------------------------------------------
    svn:executable = *

Added: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip.md5
==============================================================================
--- dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip.md5 (added)
+++ dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip.md5 Mon Nov  6 17:24:52
2017
@@ -0,0 +1 @@
+d3dabc3d75f58ca4325dc9510888f45d
\ No newline at end of file

Propchange: dev/flex/installer/3.3/rc1/apache-flex-sdk-installer-3.3.0-src.zip.md5
------------------------------------------------------------------------------
    svn:eol-style = native

Added: dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg
==============================================================================
Binary file - no diff available.

Propchange: dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg
------------------------------------------------------------------------------
    svn:mime-type = application/octet-stream

Added: dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg.asc
==============================================================================
--- dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg.asc (added)
+++ dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg.asc Mon Nov
 6 17:24:52 2017
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNATURE-----
+
+iQIzBAABCAAdFiEERJmPPiQnJ+lMS63rawp+yQUGH8gFAloAiZQACgkQawp+yQUG
+H8hs6Q//QXqpdp0FDJeR06fa32kPq1G13sE/EfI6uYaAoyEtiAyG9Ys0XNsb84j2
+z82FAWzDyy/ecYmwmbFxqvupgoyKHIUYikwl/ir/Mks8JnZ5Xm5pcXh5ojFcr9Kz
+hUaTntb50VVKFaeC97odW5J2xWYp8MCPiyvK4V4BUvWGwftg+QgL/ViyrAiXVMfJ
+e+mBF6wX5CuPqUmEEhz3cLJdEreNDtoL7geWet9ok34ZIjpwsA3tZ1virdnSTyE4
+UBMYC5t9bwMhjf1Ki+1bAYB6/ExwdZ5NQ68B+fML1aRDV/NqVlvvxZ4D60Uwxcez
+xDndf5hcpKIzyOgUQusaJvrgbv9AKIgRSv7FcFXimZmMc5eHiYZD49v4UT420zn8
+FC9+RuIympc+XHKc0HiSxbi/2csWSVdGtBjTdUAdDtlNCeFcHghyBoL9mIB3oynv
+oQu1oHtN/uFWC8Yuvwf3RGqOS/Z+xTAsfpXuJr5Tta9xzNZojgNqXuWlfEvMndhx
+9Y/eR20rWG4kpo2gs1phQ4EGJkP8i6gmz/Ke4hvlsSmQ8OdguhXb9TbJq+E6mbUj
+yZMJy/UiBLgPPdB7EnWKpOrcS1inr2DBjBrasZnTnl3fDnA+fZWRWsjdAyuE3ijk
+13beRf2aW+d70rKXXfJJS0D0NlGibEvpPzwmg/5aMm3P7FUvClU=
+=87N8
+-----END PGP SIGNATURE-----

Propchange: dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg.asc
------------------------------------------------------------------------------
    svn:eol-style = native

Added: dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg.md5
==============================================================================
--- dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg.md5 (added)
+++ dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg.md5 Mon Nov
 6 17:24:52 2017
@@ -0,0 +1 @@
+b5676d089103e01b2d945f0c05bfa3a6
\ No newline at end of file

Propchange: dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.dmg.md5
------------------------------------------------------------------------------
    svn:eol-style = native

Added: dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe
==============================================================================
Binary file - no diff available.

Propchange: dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe
------------------------------------------------------------------------------
    svn:mime-type = application/octet-stream

Added: dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe.asc
==============================================================================
--- dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe.asc (added)
+++ dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe.asc Mon Nov
 6 17:24:52 2017
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNATURE-----
+
+iQIzBAABCAAdFiEERJmPPiQnJ+lMS63rawp+yQUGH8gFAloAjp8ACgkQawp+yQUG
+H8gXLBAAtLTgINcjHNEgNMNWrpguPQaMtMv7NpVYXzkW5xYS7MwwkMNbJsNI6dL+
+HxfJdbEA282bDerveNnmjbZnKrTm0rfTP98kcTegEwtyG1sIiFjt0UwY56TLjaH+
+a570oM2KUo+BcPUjA7NMsn+YuvRrVvuOhtR85p2MbxDu6BJMq65mfFDOYKbS/g0s
+rs0t4QO9npdYqhhjADy627Z1KSuRfufrThyJIGl32J8lGIbZbb/2pe/0lisYFs75
+VUKM37gHCyWoC/LVVIEBRss2jpHGNTpsw8hOQxFO31jY8qWPFzX3PHVQ/hTFbvPr
+oW6kTaiMiEBAC/Np0t2r8H8SaX55/hgYnaSBw56T1K0N/X7UNreUy/X2QnidgHgo
+8Az2ZCyvNZ2GlUCJTVgvJRJPB9FOASSK3V32UdAnloodHb4HZGhp0vgdVqi/ZeJY
+zymUXLazESWXDXFeNoL99htdXLS7Jeu/tXufJK13mkzQFB9W/Yd47kNmwLeh5QVr
+/SymIfzwrpYCyclKGihdFxX6V/zbDCa/HCiuB1U2Q9AqO69Xu2zUjxTU/fG/odbZ
+ztVx6TxRDXNuVE/HoTCKE+FJHyJeoLVXKzMlLepzdDXCO6a5mwVKWibI2UubNcEQ
+gB0MwfeP1XD57mo061JKos4+669m5Rl2kaH4b6U4ZEdgnlACUrY=
+=MzxK
+-----END PGP SIGNATURE-----

Propchange: dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe.asc
------------------------------------------------------------------------------
    svn:eol-style = native

Added: dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe.md5
==============================================================================
--- dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe.md5 (added)
+++ dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe.md5 Mon Nov
 6 17:24:52 2017
@@ -0,0 +1 @@
+0c87b574a7bcd48f8fbdb7a4bffb1c2e

Propchange: dev/flex/installer/3.3/rc1/binaries/apache-flex-sdk-installer-3.3.0-bin.exe.md5
------------------------------------------------------------------------------
    svn:eol-style = native



Mime
View raw message