flex-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jmcl...@apache.org
Subject [1/4] git commit: [flex-sdk] [refs/heads/release4.16.0] - Added support for AIR and flash player 24.0
Date Sun, 18 Dec 2016 23:19:10 GMT
Repository: flex-sdk
Updated Branches:
  refs/heads/release4.16.0 77268745e -> 9e7632dfe


Added support for AIR and flash player 24.0


Project: http://git-wip-us.apache.org/repos/asf/flex-sdk/repo
Commit: http://git-wip-us.apache.org/repos/asf/flex-sdk/commit/f6b22628
Tree: http://git-wip-us.apache.org/repos/asf/flex-sdk/tree/f6b22628
Diff: http://git-wip-us.apache.org/repos/asf/flex-sdk/diff/f6b22628

Branch: refs/heads/release4.16.0
Commit: f6b226284e318d2ee24e12c9ba90bcc9719bdd8f
Parents: 7726874
Author: Justin Mclean <jmclean@apache.org>
Authored: Mon Dec 19 09:57:38 2016 +1100
Committer: Justin Mclean <jmclean@apache.org>
Committed: Mon Dec 19 09:57:38 2016 +1100

----------------------------------------------------------------------
 ide/addAIRtoSDK.sh           | 29 ++++++++++++++++++++++++++---
 ide/checkAllPlayerGlobals.sh |  1 +
 ide/setFlashPlayerVersion.sh | 18 ++++++++++++++----
 3 files changed, 41 insertions(+), 7 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/flex-sdk/blob/f6b22628/ide/addAIRtoSDK.sh
----------------------------------------------------------------------
diff --git a/ide/addAIRtoSDK.sh b/ide/addAIRtoSDK.sh
index 23b3a31..50fdb97 100755
--- a/ide/addAIRtoSDK.sh
+++ b/ide/addAIRtoSDK.sh
@@ -30,7 +30,8 @@
 AIR_VERSION="$1"
 OS=`uname`
 
-if [[ "${AIR_VERSION}" != "23.0"  && "${AIR_VERSION}" != "22.0"  && "${AIR_VERSION}"
!= "21.0"
+if [[ "${AIR_VERSION}" != "24.0"
+  && "${AIR_VERSION}" != "23.0"  && "${AIR_VERSION}" != "22.0"  &&
"${AIR_VERSION}" != "21.0"
   &&  "${AIR_VERSION}" != "20.0"  && "${AIR_VERSION}" != "19.0"  &&
"${AIR_VERSION}" != "18.0"
   && "${AIR_VERSION}" != "17.0" && "${AIR_VERSION}" != "16.0" &&
"${AIR_VERSION}" != "15.0" 
   && "${AIR_VERSION}" != "14.0" && "${AIR_VERSION}" != "13.0" &&
"${AIR_VERSION}" != "4.0" 
@@ -39,7 +40,7 @@ if [[ "${AIR_VERSION}" != "23.0"  && "${AIR_VERSION}" != "22.0"
 && "${AIR_VERSI
   && "${AIR_VERSION}" != "3.3" && "${AIR_VERSION}" != "3.2" && "${AIR_VERSION}"
!= "3.1" 
   && "${AIR_VERSION}" != "3.0" && "${AIR_VERSION}" != "2.7" && "${AIR_VERSION}"
!= "2.6" ]]
 then
-	echo Unknown version ${AIR_VERISON} of AIR. Versions 2.6, 2.7, 3.0, 3.1, 3.2, 3.3, 3.4,
3.5, 3.6, 3.7, 3.8, 3.9, 4.0, 13.0, 14.0, 15.0, 16.0, 17.0, 18.0, 19.0, 20.0, 21.0, 22.0 and
23.0 are supported.
+	echo Unknown version ${AIR_VERISON} of AIR. Versions 2.6, 2.7, 3.0, 3.1, 3.2, 3.3, 3.4,
3.5, 3.6, 3.7, 3.8, 3.9, 4.0, 13.0, 14.0, 15.0, 16.0, 17.0, 18.0, 19.0, 20.0, 21.0, 22.0,
 23.0 and 24.0 are supported.
 	exit 1;
 fi
 
@@ -106,13 +107,28 @@ downloadAIR()
     else
         airDownload="https://airdownload.adobe.com/air/lin/download/${version}/AdobeAIRSDK.tbz2"
     fi
+
+    if [[ "${AIR_VERSION}" == "24.0" ]]
+    then
+        airDownload="https://airdownload.adobe.com/air/mac/download/24.0/AdobeAIRSDK.dmg"
+	echo Downloading AIR ${version}
+	echo from ${airDownload}
+	curl ${airDownload} > "${airTempDir}/air.dmg"
+	
+	echo Extracting into SDK 
+	hdiutil attach "${airTempDir}"/air.dmg
+	cp -R "/Volumes/AIR SDK" "${IDE_SDK_DIR}"
+	umount "/Volumes/AIR SDK"
+    else
 	echo Downloading AIR ${version}
+	echo from ${airDownload}
 	curl ${airDownload} > "${airTempDir}/air.tbz2"
 	
 	echo Extracting into SDK  
 	tar xf "${airTempDir}/air.tbz2" -C "${IDE_SDK_DIR}"
+    fi
 
-	rm -rf "${airTempDir}"	
+    rm -rf "${airTempDir}"	
 }
 
 agreeLicense
@@ -157,6 +173,13 @@ for configFile in "${configFiles[@]}"
 do
 	echo Updating ${configFile}
 	
+	# 24.0 needs FP 24 and swf version 35
+	if [ ${AIR_VERSION} = "23.0" ]
+	then
+		updatePlayerVersion 24.0 "${configFile}"
+		updateSWFVersion 35 "${configFile}"
+	fi
+
 	# 23.0 needs FP 23 and swf version 34
 	if [ ${AIR_VERSION} = "23.0" ]
 	then

http://git-wip-us.apache.org/repos/asf/flex-sdk/blob/f6b22628/ide/checkAllPlayerGlobals.sh
----------------------------------------------------------------------
diff --git a/ide/checkAllPlayerGlobals.sh b/ide/checkAllPlayerGlobals.sh
index 2d9c194..5a8aaa2 100755
--- a/ide/checkAllPlayerGlobals.sh
+++ b/ide/checkAllPlayerGlobals.sh
@@ -132,3 +132,4 @@ downloadPlayerGlobal 20.0 444ea8e8f2cddec22ed8b77e0d61bfe2 playerglobal20_0.swc
 downloadPlayerGlobal 21.0 1dd14e80b962327ccd17ce1321dc2135 playerglobal21_0.swc
 downloadPlayerGlobal 22.0 177e7f8cb98bc874b73296791b747128 playerglobal22_0.swc
 downloadPlayerGlobal 23.0 1a7cd9b61930be524e9c98e1a85feebe playerglobal23_0.swc
+downloadPlayerGlobal 24.0 aea2bcc689232752ef68efbf98368066 playerglobal24_0.swc

http://git-wip-us.apache.org/repos/asf/flex-sdk/blob/f6b22628/ide/setFlashPlayerVersion.sh
----------------------------------------------------------------------
diff --git a/ide/setFlashPlayerVersion.sh b/ide/setFlashPlayerVersion.sh
index fbde916..63dccec 100755
--- a/ide/setFlashPlayerVersion.sh
+++ b/ide/setFlashPlayerVersion.sh
@@ -99,13 +99,13 @@ determineVersion()
         then 
             FLASH_VERSION="11.1"
         else
-            FLASH_VERSION="23.0"
+            FLASH_VERSION="24.0"
         fi
     fi
     
     if [ ${latest} = "Y" ]
     then
-    	FLASH_VERSION="23.0"
+    	FLASH_VERSION="24.0"
     fi
 
     echo "Setting minimum Flash Player version to ${FLASH_VERSION}"
@@ -126,9 +126,9 @@ if [[ "${FLASH_VERSION}" != "10.2" && "${FLASH_VERSION}" != "10.3"
 && "${FLASH_
   && "${FLASH_VERSION}" != "15.0" && "${FLASH_VERSION}" != "16.0" &&
"${FLASH_VERSION}" != "17.0"
   && "${FLASH_VERSION}" != "17.0" && "${FLASH_VERSION}" != "18.0" &&
"${FLASH_VERSION}" != "19.0"
   && "${FLASH_VERSION}" != "20.0" && "${FLASH_VERSION}" != "21.0" &&
"${FLASH_VERSION}" != "22.0"
-  && "${FLASH_VERSION}" != "23.0" ]]
+  && "${FLASH_VERSION}" != "23.0" && "${FLASH_VERSION}" != "24.0" ]]
 then
-	echo Unknown version ${FLASH_VERSION} of Flash Player. Versions 10.2, 10.3, 11.0, 11.1,
11.2, 11.3, 11.4, 11.5, 11.6, 11.7, 11.8, 11.9, 12.0, 13.0, 14.0, 15.0, 16.0, 17.0, 18.0,
19.0, 20.0, 21.0, 22.0 and 23.0 are supported.
+	echo Unknown version ${FLASH_VERSION} of Flash Player. Versions 10.2, 10.3, 11.0, 11.1,
11.2, 11.3, 11.4, 11.5, 11.6, 11.7, 11.8, 11.9, 12.0, 13.0, 14.0, 15.0, 16.0, 17.0, 18.0,
19.0, 20.0, 21.0, 22.0, 23.0 and 24.0 are supported.
 	exit 1;
 fi
 
@@ -149,6 +149,11 @@ then
 	echo Installing AIR
 	echo
 
+	if [[ $FLASH_VERSION = "24.0" ]]
+    then
+        ./addAIRtoSDK.sh 24.0 "$IDE_SDK_DIR"
+    fi
+
 	if [[ $FLASH_VERSION = "23.0" ]]
     then
         ./addAIRtoSDK.sh 23.0 "$IDE_SDK_DIR"
@@ -267,6 +272,11 @@ do
 	
 	updatePlayerVersion "${FLASH_VERSION}" "${configFile}"
 
+	if [ ${FLASH_VERSION} = "24.0" ]
+	then
+		updateSWFVersion 35 "${configFile}"
+	fi
+
 	if [ ${FLASH_VERSION} = "23.0" ]
 	then
 		updateSWFVersion 34 "${configFile}"


Mime
View raw message