flex-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aha...@apache.org
Subject svn commit: r1737737 - in /flex/site/trunk: content/download-flexjs.cmsPage content/installer/sdk-installer-config-4.0.xml templates/flex-v2-footer.html
Date Mon, 04 Apr 2016 19:44:24 GMT
Author: aharui
Date: Mon Apr  4 19:44:24 2016
New Revision: 1737737

URL: http://svn.apache.org/viewvc?rev=1737737&view=rev
Log:
"update sdk-installer-config-4.0 and other files for flexjs 0.6.0 rc3"

Modified:
    flex/site/trunk/content/download-flexjs.cmsPage
    flex/site/trunk/content/installer/sdk-installer-config-4.0.xml
    flex/site/trunk/templates/flex-v2-footer.html

Modified: flex/site/trunk/content/download-flexjs.cmsPage
URL: http://svn.apache.org/viewvc/flex/site/trunk/content/download-flexjs.cmsPage?rev=1737737&r1=1737736&r2=1737737&view=diff
==============================================================================
--- flex/site/trunk/content/download-flexjs.cmsPage (original)
+++ flex/site/trunk/content/download-flexjs.cmsPage Mon Apr  4 19:44:24 2016
@@ -1,6 +1,6 @@
 Title:  Download Apache FlexJS
 
-Use the links below to download the Apache FlexJS™ 0.5.0 ‘beta’ release from
one of our mirrors. You must verify the integrity of the downloaded files using signatures
downloaded from this page.
+Use the links below to download the Apache FlexJS™ 0.6.0 ‘beta’ release from
one of our mirrors. You must verify the integrity of the downloaded files using signatures
downloaded from this page.
 
 Only current recommended releases are available on the main distribution site and its mirrors.
 
@@ -8,19 +8,19 @@ The Apache FlexJS SDK has some compile-t
 
 **Please review the release notes before installing or compiling this release.**
 
-<div class="headline"><h4>Current Release (0.5.0)</h4></div>
-The Apache Flex team is pleased to offer this release, available as of 16 November 2015.
 Expect lots of bugs and missing features.
+<div class="headline"><h4>Current Release (0.6.0)</h4></div>
+The Apache Flex team is pleased to offer this release, available as of 04 April 2016.  Expect
lots of bugs and missing features.
 
-Binaries are provided as a convenience for those who do not wish to compile FlexJS themselves.
 The 0.5.0 binaries were published on 16 November 2015.
+Binaries are provided as a convenience for those who do not wish to compile FlexJS themselves.
 The 0.6.0 binaries were published on 04 April 2016.
 
 **Please be aware of the dependencies listed in the section below.**  They are required in
order to compile the Apache FlexJS SDK.  The [README][15] explains these requirements further.
 
 - Release Notes : [RELEASE_NOTES][2]
 - README : [README][15]
-- Source (tar.gz) : [apache-flex-flexjs-0.5.0-src.tar.gz][3] [[PGP](http://www.apache.org/dist/flex/flexjs/0.5.0/apache-flex-flexjs-0.5.0-src.tar.gz.asc)]
[[MD5](http://www.apache.org/dist/flex/flexjs/0.5.0/apache-flex-flexjs-0.5.0-src.tar.gz.md5)]
-- Source (zip) : [apache-flex-flexjs-0.5.0-src.zip][4] [[PGP](http://www.apache.org/dist/flex/flexjs/0.5.0/apache-flex-flexjs-0.5.0-src.zip.asc)]
[[MD5](http://www.apache.org/dist/flex/flexjs/0.5.0/apache-flex-flexjs-0.5.0-src.zip.md5)]
-- Binaries (tar.gz) : [apache-flex-flexjs-0.5.0-bin.tar.gz][7] [[PGP](http://www.apache.org/dist/flex/flexjs/0.5.0/binaries/apache-flex-flexjs-0.5.0-bin.tar.gz.asc)]
[[MD5](http://www.apache.org/dist/flex/flexjs/0.5.0/binaries/apache-flex-flexjs-0.5.0-bin.tar.gz.md5)]
-- Binaries (zip) : [apache-flex-flexjs-0.5.0-bin.zip][8] [[PGP](http://www.apache.org/dist/flex/flexjs/0.5.0/binaries/apache-flex-flexjs-0.5.0-bin.zip.asc)]
[[MD5](http://www.apache.org/dist/flex/flexjs/0.5.0/binaries/apache-flex-flexjs-0.5.0-bin.zip.md5)]
+- Source (tar.gz) : [apache-flex-flexjs-0.6.0-src.tar.gz][3] [[PGP](http://www.apache.org/dist/flex/flexjs/0.6.0/apache-flex-flexjs-0.6.0-src.tar.gz.asc)]
[[MD5](http://www.apache.org/dist/flex/flexjs/0.6.0/apache-flex-flexjs-0.6.0-src.tar.gz.md5)]
+- Source (zip) : [apache-flex-flexjs-0.6.0-src.zip][4] [[PGP](http://www.apache.org/dist/flex/flexjs/0.6.0/apache-flex-flexjs-0.6.0-src.zip.asc)]
[[MD5](http://www.apache.org/dist/flex/flexjs/0.6.0/apache-flex-flexjs-0.6.0-src.zip.md5)]
+- Binaries (tar.gz) : [apache-flex-flexjs-0.6.0-bin.tar.gz][7] [[PGP](http://www.apache.org/dist/flex/flexjs/0.6.0/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz.asc)]
[[MD5](http://www.apache.org/dist/flex/flexjs/0.6.0/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz.md5)]
+- Binaries (zip) : [apache-flex-flexjs-0.6.0-bin.zip][8] [[PGP](http://www.apache.org/dist/flex/flexjs/0.6.0/binaries/apache-flex-flexjs-0.6.0-bin.zip.asc)]
[[MD5](http://www.apache.org/dist/flex/flexjs/0.6.0/binaries/apache-flex-flexjs-0.6.0-bin.zip.md5)]
 
 <div class="headline"><h4>Dependencies</h4></div>
 Apache FlexJS requires some build tools which must be installed prior to building FlexJS.
 Some of these have different licenses. See the Software [Dependencies section][15] within
the [README][15] for more information on the external software dependencies.  If you plan
to compile the sources, it is best to follow the instructions for downloading (and building)
[Apache Flex FlexUnit][16] and [Apache Flex FalconJX][17] first.  Click on the links to access
instructions for those dependencies.
@@ -32,7 +32,7 @@ Apache FlexJS requires some build tools
 - Google Closure Linter
 - Adobe Flash Player playerglobal.swc
 - JSHint
-- Apache Flex FalconJX 0.5.0 or greater
+- Apache Flex FalconJX 0.6.0 or greater
 - Apache Flex FlexUnit 4.2 or greater
 - Apache Flex 4.8 or greater
 
@@ -48,34 +48,34 @@ The PGP signatures can be verified using
 
     % pgpk -a KEYS
 
-    % pgpv apache-flex-flexjs-0.5.0-src.tar.gz.asc
+    % pgpv apache-flex-flexjs-0.6.0-src.tar.gz.asc
 
 *or*
 
     % pgp -ka KEYS
 
-    % pgp apache-flex-flexjs-0.5.0-src.tar.gz.asc
+    % pgp apache-flex-flexjs-0.6.0-src.tar.gz.asc
 
 *or*
 
     % gpg --import KEYS
 
-    % gpg --verify apache-flex-flexjs-0.5.0-src.tar.gz.asc
+    % gpg --verify apache-flex-flexjs-0.6.0-src.tar.gz.asc
 
 
 Alternatively, you can verify the MD5 signature on the files. A unix/Mac program called `md5`
or `md5sum` is included in many unix distributions. It is also available as part of [GNU Textutils][11].
Windows users can get binary md5 programs from [here][12] , [here][13] , or [here][14]. An
MD5 signature consists of 32 hex characters, and a SHA1 signature consists of 40 hex characters.
Ensure your generated signature string matches the signature string published in the files
above.
 
 
-[2]: http://www.apache.org/dyn/closer.lua/flex/flexjs/0.5.0/RELEASE_NOTES
-[3]: http://www.apache.org/dyn/closer.lua/flex/flexjs/0.5.0/apache-flex-flexjs-0.5.0-src.tar.gz
-[4]: http://www.apache.org/dyn/closer.lua/flex/flexjs/0.5.0/apache-flex-flexjs-0.5.0-src.zip
-[7]: http://www.apache.org/dyn/closer.lua/flex/flexjs/0.5.0/binaries/apache-flex-flexjs-0.5.0-bin.tar.gz
-[8]: http://www.apache.org/dyn/closer.lua/flex/flexjs/0.5.0/binaries/apache-flex-flexjs-0.5.0-bin.zip
+[2]: http://www.apache.org/dyn/closer.lua/flex/flexjs/0.6.0/RELEASE_NOTES
+[3]: http://www.apache.org/dyn/closer.lua/flex/flexjs/0.6.0/apache-flex-flexjs-0.6.0-src.tar.gz
+[4]: http://www.apache.org/dyn/closer.lua/flex/flexjs/0.6.0/apache-flex-flexjs-0.6.0-src.zip
+[7]: http://www.apache.org/dyn/closer.lua/flex/flexjs/0.6.0/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz
+[8]: http://www.apache.org/dyn/closer.lua/flex/flexjs/0.6.0/binaries/apache-flex-flexjs-0.6.0-bin.zip
 [10]: http://www.apache.org/dist/flex/KEYS
 [11]: http://www.gnu.org/software/textutils/textutils.html
 [12]: http://www.fourmilab.ch/md5/
 [13]: http://www.pc-tools.net/win32/freeware/console/
 [14]: http://www.slavasoft.com/fsum/
-[15]: http://www.apache.org/dyn/closer.lua/flex/flexjs/0.5.0/READme
+[15]: http://www.apache.org/dyn/closer.lua/flex/flexjs/0.6.0/READme
 [16]: http://flex.apache.org/download-flexunit.html
 [17]: http://flex.apache.org/download-falconjx.html

Modified: flex/site/trunk/content/installer/sdk-installer-config-4.0.xml
URL: http://svn.apache.org/viewvc/flex/site/trunk/content/installer/sdk-installer-config-4.0.xml?rev=1737737&r1=1737736&r2=1737737&view=diff
==============================================================================
--- flex/site/trunk/content/installer/sdk-installer-config-4.0.xml (original)
+++ flex/site/trunk/content/installer/sdk-installer-config-4.0.xml Mon Apr  4 19:44:24 2016
@@ -76,14 +76,15 @@ limitations under the License.
                 <Nightly id="Nightly" version="Nightly" path="http://apacheflexbuild.cloudapp.net:8080/job/flex-sdk_nightly/lastSuccessfulBuild/artifact/out/"
file="apache-flex-sdk-4.16.0-bin" dev="true" nocache="true"/>
             </versions>
         </ApacheFlexSDK>
-        <ApacheFlexJS name="Apache FlexJS" prefix="apache-flex-flexjs-" icon="http://flex.apache.org/installer/icons/apache_flexjs_logo_text.png"
developmentVersion="0.6.0" latestVersion="0.5.0">
+        <ApacheFlexJS name="Apache FlexJS" prefix="apache-flex-flexjs-" icon="http://flex.apache.org/installer/icons/apache_flexjs_logo_text.png"
developmentVersion="0.6.0" latestVersion="0.6.0">
             <versions>
                 <!--<versionAA id="FlexJS0.0.1" version="0.0.1" path="http://archive.apache.org/dist/flex/flexjs/0.0.1/binaries/"
file="apache-flex-flexjs-0.0.1-bin"/>
                 <versionBB id="FlexJS0.0.2" version="0.0.2" path="flex/flexjs/0.0.2/binaries/"
file="apache-flex-flexjs-0.0.2-bin"/>
                 <versionCC id="FlexJS0.0.2a" version="0.0.2 (with JBurg)" path="http://apacheflexbuild.cloudapp.net:8080/job/FlexJS002Workaround/ws/"
file="apache-flex-flexjs-0.0.2-bin"/> -->
                 <versionDD id="FlexJS0.5.0" version="0.5.0" path="flex/flexjs/0.5.0/binaries/"
file="apache-flex-flexjs-0.5.0-bin"/>
                 <!--<versionDD id="FlexJS0.5.0" version="0.5.0" path="http://archive.apache.org/dist/flex/flexjs/0.5.0/binaries/"
file="apache-flex-flexjs-0.5.0-bin" />-->
-                <rc id="FlexJSRC" version="0.6.0 RC3" path="https://dist.apache.org/repos/dist/dev/flex/flexjs/0.6.0/rc3/binaries/"
file="apache-flex-flexjs-0.6.0-bin" dev="true"/>
+                <VersionX id="0.6.0" version="0.6.0" path="flex/flexjs/0.6.0/binaries/"
file="apache-flex-flexjs-0.6.0-bin" />
+    <rc id="FlexJSRC" version="0.6.0 RC3" path="https://dist.apache.org/repos/dist/dev/flex/flexjs/0.6.0/rc3/binaries/"
file="apache-flex-flexjs-0.6.0-bin" dev="true"/>
                 <!--<Nightly id="FlexJSNightly" version="Nightly Build" path="http://people.apache.org/~aharui/nightly/flexjs/"
file="apache-flex-flexjs-0.5.0-bin" dev="true" nocache="true"/> -->
                 <Nightly id="FlexJSNightly" version="Nightly" path="http://apacheflexbuild.cloudapp.net:8080/job/flex-asjs/lastSuccessfulBuild/artifact/out/"
file="apache-flex-flexjs-0.6.0-bin" dev="true" nocache="true"/>
             </versions>

Modified: flex/site/trunk/templates/flex-v2-footer.html
URL: http://svn.apache.org/viewvc/flex/site/trunk/templates/flex-v2-footer.html?rev=1737737&r1=1737736&r2=1737737&view=diff
==============================================================================
--- flex/site/trunk/templates/flex-v2-footer.html (original)
+++ flex/site/trunk/templates/flex-v2-footer.html Mon Apr  4 19:44:24 2016
@@ -33,7 +33,7 @@
             <div class="footer-headline"><h4>Latest Releases</h4></div>
             <p>
             	Apache Flex SDK : <a href="/download-binaries.html">4.15 (January 2016)</a><br
/>
-                Apache FlexJS SDK : <a href="/download-flexjs.html">0.5.0 (November
2015)</a><br />
+                Apache FlexJS SDK : <a href="/download-flexjs.html">0.6.0 (April 2016)</a><br
/>
                 Blaze DS : <a href="/download-blazeds.html">4.7.0 (Mar 2015)</a><br
/>
                 Flex Mavenizer : <a href="http://svn.apache.org/viewvc/flex/utilities/trunk/mavenizer/">
4.8.0 (Jan 2013)</a><br />
                 FlexUnit : <a href="/download-flexunit.html">4.2.0 (Apr 2014)</a><br
/>



Mime
View raw message