flex-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aha...@apache.org
Subject svn commit: r12927 - in /dev/flex/flexjs/0.6.0/rc2: ./ binaries/ doc/
Date Wed, 30 Mar 2016 04:59:04 GMT
Author: aharui
Date: Wed Mar 30 04:59:04 2016
New Revision: 12927

Log:
rc2 of Apache FlexJS 0.6.0

Added:
    dev/flex/flexjs/0.6.0/rc2/
    dev/flex/flexjs/0.6.0/rc2/ApproveFlexJS.xml
    dev/flex/flexjs/0.6.0/rc2/READme
    dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.tar.gz   (with props)
    dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.tar.gz.asc
    dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.tar.gz.md5
    dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.zip   (with props)
    dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.zip.asc
    dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.zip.md5
    dev/flex/flexjs/0.6.0/rc2/binaries/
    dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz   (with props)
    dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz.asc
    dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz.md5
    dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.zip   (with props)
    dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.zip.asc
    dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.zip.md5
    dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-installer-config.xml
    dev/flex/flexjs/0.6.0/rc2/doc/
    dev/flex/flexjs/0.6.0/rc2/doc/apache-flex-flexjs-0.6.0-asdocs.zip   (with props)
    dev/flex/flexjs/0.6.0/rc2/doc/apache-flex-flexjs-0.6.0-asdocs.zip.asc
    dev/flex/flexjs/0.6.0/rc2/doc/apache-flex-flexjs-0.6.0-asdocs.zip.md5

Added: dev/flex/flexjs/0.6.0/rc2/ApproveFlexJS.xml
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/ApproveFlexJS.xml (added)
+++ dev/flex/flexjs/0.6.0/rc2/ApproveFlexJS.xml Wed Mar 30 04:59:04 2016
@@ -0,0 +1,827 @@
+<?xml version="1.0"?>
+<!--
+
+  Licensed to the Apache Software Foundation (ASF) under one or more
+  contributor license agreements.  See the NOTICE file distributed with
+  this work for additional information regarding copyright ownership.
+  The ASF licenses this file to You under the Apache License, Version 2.0
+  (the "License"); you may not use this file except in compliance with
+  the License.  You may obtain a copy of the License at
+
+      http://www.apache.org/licenses/LICENSE-2.0
+
+  Unless required by applicable law or agreed to in writing, software
+  distributed under the License is distributed on an "AS IS" BASIS,
+  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+  See the License for the specific language governing permissions and
+  limitations under the License.
+
+-->
+
+<project name="ApproveApacheFlexJS" default="main" basedir=".">
+
+
+    <!-- Required for OSX 10.6 / Snow Leopard Performance. -->
+    <!-- Java 7 on Mac requires OSX 10.7.3 or higher and is 64-bit only -->
+    <!-- local.d32 is set/used in build.properties so this needs to be done first. -->
+    <condition property="local.d32" value="-d32">
+        <and>
+            <os family="windows"/>
+            <equals arg1="${sun.arch.data.model}" arg2="64"/>
+            <equals arg1="${os.arch}" arg2="x86_64"/>
+            <equals arg1="${ant.java.version}" arg2="1.6"/>
+        </and>
+    </condition>
+
+    <condition property="isMac" value="mac">
+        <os family="mac" />
+    </condition>
+    <condition property="isWindows" value="windows">
+        <os family="windows" />
+    </condition>
+    <condition property="isLinux" value="linux">
+		<and>
+			<os family="unix" />
+			<not>
+				<isset property="isMac" />
+			</not>
+		</and>
+    </condition>
+    <condition property="package.suffix" value="zip">
+        <os family="windows" />
+    </condition>
+	<property name="package.suffix" value="tar.gz" />
+	
+    <property name="src.rat.report" value="${basedir}/rat-report-src.txt"/>
+    <property name="bin.rat.report" value="${basedir}/rat-report-bin.txt"/>
+    <property name="doc.rat.report" value="${basedir}/rat-report-doc.txt"/>
+	<property name="apache.rat.jar" value="apache-rat-0.11.jar" />
+	<property name="apache.rat.tasks.jar" value="apache-rat-tasks-0.11.jar" />
+	<property name="apache.rat.url" value="http://search.maven.org/remotecontent?filepath=org/apache/rat/apache-rat/0.11" />
+    <property name="apache.rat.tasks.url" value="http://search.maven.org/remotecontent?filepath=org/apache/rat/apache-rat-tasks/0.11" />
+	   
+    <property file="${basedir}/approvefalcon.properties"/>
+    
+	<property name="mac.text.display" value="cat" />
+	<property name="win.text.display" value="type" />
+	<property name="linux.text.display" value="cat" />
+    <property environment="env"/>
+
+    <property name="build.target" value="main" />
+	
+	<available file="${env.APPDATA}/npm/jshint.cmd" 
+		type="file" 
+		property="jshint" value="${env.APPDATA}/npm/jshint.cmd" />
+	<property name="jshint" value="jshint" />
+    
+	<available file="${env.ProgramFiles}/Mozilla Firefox/firefox.exe" 
+		type="file" 
+		property="browser" value="${env.ProgramFiles}/Mozilla Firefox/firefox.exe" />
+	<available file="${env.ProgramFiles(x86)}/Mozilla Firefox/firefox.exe" 
+		type="file" 
+		property="browser" value="${env.ProgramFiles}/Mozilla Firefox/firefox.exe" />
+
+	<condition property="do.copy.downloads" >
+		<isset property="download.cache.dir" /> 
+	</condition>
+	
+    <fail message="The ANT_HOME environment variable is not set."
+        unless="env.ANT_HOME"/>
+		
+	<available file="${env.AIR_HOME}"
+		type="dir" 
+		property="AIR_HOME" value="${env.AIR_HOME}" />
+
+    <fail message="The AIR_HOME property is not set in environment or command-line."
+        unless="AIR_HOME"/>
+		
+    <available file="${env.PLAYERGLOBAL_HOME}"
+        type="dir"
+        property="PLAYERGLOBAL_HOME" value="${env.PLAYERGLOBAL_HOME}" />
+    
+    <fail message="The PLAYERGLOBAL_HOME property is not set in environment or command-line."
+        unless="PLAYERGLOBAL_HOME"/>
+    
+    <available file="${env.FLASHPLAYER_DEBUGGER}"
+        type="file"
+        property="FLASHPLAYER_DEBUGGER" value="${env.FLASHPLAYER_DEBUGGER}" />
+    
+    <fail message="The FLASHPLAYER_DEBUGGER property is not set in environment or command-line."
+        unless="FLASHPLAYER_DEBUGGER"/>
+    
+    <available file="${env.FALCON_HOME}"
+        type="dir"
+        property="FALCON_HOME" value="${env.FALCON_HOME}" />
+    
+    <available file="${env.FALCONJX_HOME}"
+        type="dir"
+        property="FALCONJX_HOME" value="${env.FALCONJX_HOME}" />
+    
+    <available file="${env.FLEXUNIT_HOME}"
+        type="dir"
+        property="FLEXUNIT_HOME" value="${env.FLEXUNIT_HOME}" />
+    
+    <available file="${env.FLEX_HOME}"
+        type="dir"
+        property="FLEX_SDK_HOME" value="${env.FLEX_HOME}" />
+    
+    <available file="${env.ANT_HOME}/lib/${apache.rat.jar}"
+        type="file"
+        property="apache.rat.found"/>
+    <available file="${env.ANT_HOME}/lib/${apache.rat.tasks.jar}"
+        type="file"
+        property="apache.rat.tasks.found"/>
+		
+    <fail message="The release version is not set.  Specify -Drelease.version=&lt;release version (e.g. 3.1, 3.2, etc)&gt;"
+    unless="release.version"/>
+
+    <condition property="package.url.path"
+        value="http://apacheflexbuild.cloudapp.net:8080/job/flex-asjs/lastSuccessfulBuild/artifact/out">
+        <not>
+            <isset property="rc" />
+        </not>
+    </condition>
+    <condition property="bin.package.url.path"
+        value="${package.url.path}">
+        <not>
+            <isset property="rc" />
+        </not>
+    </condition>
+    <condition property="doc.package.url.path"
+        value="${package.url.path}">
+        <not>
+            <isset property="rc" />
+        </not>
+    </condition>
+
+	<property name="package.url.path" value="https://dist.apache.org/repos/dist/dev/flex/flexjs/${release.version}/rc${rc}" />
+	<property name="package.url.name" value="apache-flex-flexjs-${release.version}-src" />
+    <property name="bin.package.url.path" value="${package.url.path}/binaries" />
+    <property name="bin.package.url.name" value="apache-flex-flexjs-${release.version}-bin" />
+    <property name="doc.package.url.path" value="${package.url.path}/doc" />
+    <property name="doc.package.url.name" value="apache-flex-flexjs-${release.version}-asdocs" />
+	
+    <condition property="zip.package">
+        <equals arg1="zip" arg2="${package.suffix}" />
+    </condition>
+    
+	<target name="display-text-mac" if="isMac">
+		<echo>========================= Begin ${file} ==============================</echo>
+		<exec executable="${mac.text.display}" >
+			<arg value="${file}" /> 
+		</exec>
+		<echo>========================= End ${file} ==============================</echo>
+	</target>
+	<target name="display-text-win" if="isWindows">
+		<pathconvert targetos="windows" property="winfile">
+			<path path="${file}" />
+		</pathconvert>
+		<echo>========================= Begin ${winfile} ==============================</echo>
+		<exec executable="cmd.exe" >
+			<arg value="/c" />
+			<arg value="${win.text.display}" />
+			<arg value="${winfile}" /> 
+		</exec>		
+		<echo>========================= End ${winfile} ==============================</echo>
+	</target>
+	<target name="display-text-linux" if="isLinux">
+		<echo>========================= Begin ${file} ==============================</echo>
+		<exec executable="${linux.text.display}" >
+			<arg value="${file}" /> 
+		</exec>
+		<echo>========================= End ${file} ==============================</echo>
+	</target>
+	
+	<target name="install-rat" depends="install-rat.jar,install-rat.tasks.jar" />
+	<target name="install-rat.jar" unless="apache.rat.found">
+		<get src="${apache.rat.url}/${apache.rat.jar}" dest="${env.ANT_HOME}/lib/${apache.rat.jar}" />
+	</target>
+	<target name="install-rat.tasks.jar" unless="apache.rat.tasks.found">
+		<get src="${apache.rat.tasks.url}/${apache.rat.tasks.jar}" dest="${env.ANT_HOME}/lib/${apache.rat.tasks.jar}" />
+	</target>
+	
+    <target name="rat-taskdef" description="Rat taskdef">
+        <typedef resource="org/apache/rat/anttasks/antlib.xml"
+        uri="antlib:org.apache.rat.anttasks"
+        classpathref="anttask.classpath"/>
+    </target>
+
+    <target name="main" depends="install-rat,download,check-sigs,uncompress,rat-check,binary-rat,doc-rat,check-notices,build,approve" description="Perform required release approval steps">
+    </target>
+    
+    <target name="main-no-download" depends="install-rat,check-sigs,uncompress,rat-check,binary-rat,doc-rat,check-notices,build,approve" description="Perform required release approval steps">
+    </target>
+	
+    <target name="test" >
+		<echo>${rat.report}.bin.txt</echo>
+		<replaceregexp file="${rat.report}.bin.txt" match="..AL.*" replace="" byline="true"/>
+    </target>
+	
+	<target name="display-text" >
+		<antcall target="display-text-mac" />
+		<antcall target="display-text-win" />
+		<antcall target="display-text-linux" />
+	</target>
+
+	<target name="display-text-test" >
+		<antcall target="display-text" >
+			<param name="file" value="${basedir}/rat-report.txt" />
+		</antcall>
+	</target>
+	
+    <target name="download" description="download the release package">
+        <get src="${package.url.path}/${package.url.name}.${package.suffix}"
+            dest="${basedir}/${package.url.name}.${package.suffix}" />
+        <get src="${package.url.path}/${package.url.name}.${package.suffix}.md5"
+            dest="${basedir}/${package.url.name}.${package.suffix}.md5" />
+        <get src="${bin.package.url.path}/${bin.package.url.name}.${package.suffix}"
+            dest="${basedir}/${bin.package.url.name}.${package.suffix}" />
+        <get src="${bin.package.url.path}/${bin.package.url.name}.${package.suffix}.md5"
+            dest="${basedir}/${bin.package.url.name}.${package.suffix}.md5" />
+        <get src="${doc.package.url.path}/${doc.package.url.name}.zip"
+            dest="${basedir}/${doc.package.url.name}.zip" />
+        <get src="${doc.package.url.path}/${doc.package.url.name}.zip.md5"
+            dest="${basedir}/${doc.package.url.name}.zip.md5" />
+        <antcall target="get_asc" />
+    </target>
+
+    <target name="get_asc" if="rc" >
+        <get src="${package.url.path}/${package.url.name}.${package.suffix}.asc"
+        dest="${basedir}/${package.url.name}.${package.suffix}.asc" />
+        <get src="${bin.package.url.path}/${bin.package.url.name}.${package.suffix}.asc"
+        dest="${basedir}/${bin.package.url.name}.${package.suffix}.asc" />
+        <get src="${doc.package.url.path}/${doc.package.url.name}.zip.asc"
+        dest="${basedir}/${doc.package.url.name}.zip.asc" />
+    </target>
+    
+    <target name="check-sigs" description="check md5 and gpg sigs">
+		<replace file="${basedir}/${package.url.name}.${package.suffix}.md5"
+			token=" " />
+		<checksum file="${basedir}/${package.url.name}.${package.suffix}" algorithm="md5" verifyproperty="md5.ok" />
+        <condition property="MD5Invalid">
+			<not>
+				<equals arg1="${md5.ok}" arg2="true" />
+			</not>
+        </condition>
+        <fail message="MD5 checksum did not match" if="MD5Invalid" />
+        <replace file="${basedir}/${bin.package.url.name}.${package.suffix}.md5"
+        token=" " />
+        <checksum file="${basedir}/${bin.package.url.name}.${package.suffix}" algorithm="md5" verifyproperty="bin.md5.ok" />
+        <condition property="BinaryMD5Invalid">
+            <not>
+                <equals arg1="${bin.md5.ok}" arg2="true" />
+            </not>
+        </condition>
+        <fail message="Binary Package MD5 checksum did not match" if="BinaryMD5Invalid" />
+        <replace file="${basedir}/${doc.package.url.name}.zip.md5"
+        token=" " />
+        <checksum file="${basedir}/${doc.package.url.name}.zip" algorithm="md5" verifyproperty="doc.md5.ok" />
+        <condition property="DocMD5Invalid">
+            <not>
+                <equals arg1="${doc.md5.ok}" arg2="true" />
+            </not>
+        </condition>
+        <fail message="Doc Package MD5 checksum did not match" if="DocMD5Invalid" />
+        <antcall target="gpg_check" />
+    </target>
+
+    <target name="gpg_check" if="rc">
+        <exec executable="gpg" failonerror="true">
+            <arg value="--verify" />
+            <arg value="${basedir}/${package.url.name}.${package.suffix}.asc" />
+            <arg value="${basedir}/${package.url.name}.${package.suffix}" />
+        </exec>
+        <exec executable="gpg" failonerror="true">
+            <arg value="--verify" />
+            <arg value="${basedir}/${bin.package.url.name}.${package.suffix}.asc" />
+            <arg value="${basedir}/${bin.package.url.name}.${package.suffix}" />
+        </exec>
+        <exec executable="gpg" failonerror="true">
+            <arg value="--verify" />
+            <arg value="${basedir}/${doc.package.url.name}.${package.suffix}.asc" />
+            <arg value="${basedir}/${doc.package.url.name}.${package.suffix}" />
+        </exec>
+    </target>
+    
+    <target name="uncompress" depends="pre-clean, untar-file, unzip-file" />
+
+    <target name="pre-clean" description="remove old uncompressed package" >
+		<delete dir="${basedir}/${package.url.name}" failonerror="false" />
+        <delete dir="${basedir}/${bin.package.url.name}" failonerror="false" />
+        <delete dir="${basedir}/${doc.package.url.name}" failonerror="false" />
+	</target>
+	
+    <target name="untar-file" unless="zip.package" description="Untars zipFile">
+        <untar src="${basedir}/${package.url.name}.${package.suffix}"
+                dest="${basedir}" compression="gzip"/>
+        <untar src="${basedir}/${bin.package.url.name}.${package.suffix}"
+                dest="${basedir}" compression="gzip"/>
+        <unzip src="${basedir}/${doc.package.url.name}.zip"
+                dest="${basedir}/${doc.package.url.name}"/>
+    </target>
+
+    <target name="unzip-file" if="zip.package" description="Unzips zipFile">
+        <unzip src="${basedir}/${package.url.name}.${package.suffix}"
+                dest="${basedir}/${package.url.name}"/>
+        <unzip src="${basedir}/${bin.package.url.name}.${package.suffix}"
+                dest="${basedir}/${bin.package.url.name}"/>
+        <unzip src="${basedir}/${doc.package.url.name}.${package.suffix}"
+                dest="${basedir}/${doc.package.url.name}"/>
+    </target>
+
+    <target name="rat-check" >
+
+        <echo message="Checking files at ${basedir}/${package.url.name}, report is ${src.rat.report}"/>
+
+        <rat:report xmlns:rat="antlib:org.apache.rat.anttasks"
+            reportFile="${src.rat.report}">
+            <fileset dir="${basedir}/${package.url.name}">
+                <!-- exclude media (png, gif, jpg, mp3, flv) -->
+                <exclude name="**/*.png"/>
+                <exclude name="**/*.gif"/>
+                <exclude name="**/*.jpg"/>
+                <exclude name="**/*.mp3"/>
+                <exclude name="**/*.flv"/>
+                <!--          JSON doesn't really have a comment format     -->
+                <exclude name="**/*.json"/>
+                <!--          JSHint properties file           -->
+                <exclude name="frameworks/js/jshint.properties"/>
+                <exclude name="frameworks/js/.jshintrc"/>
+                <!--          fragments           -->
+                <exclude name="LICENSE.bin"/>
+                <exclude name="LICENSE.base"/>
+            </fileset>
+        </rat:report>
+		<antcall target="display-text" >
+            <param name="file" value="${src.rat.report}" />
+        </antcall>
+        <input
+			message="Check that there are no unknown or unapproved licenses or archives. Is it ok?"
+            validargs="y,n"
+        defaultvalue="y"
+        addproperty="rat.license.ok"/>
+		<echo>filtering out AL files to make it easier to see binary files</echo>
+		<copy file="${src.rat.report}" tofile="${src.rat.report}.bin.txt" />
+        <replaceregexp file="${src.rat.report}.bin.txt" match="..AL.*" replace="__AL" byline="true"/>
+        <replaceregexp file="${src.rat.report}.bin.txt" flags="gs" match="__AL." replace="" byline="false"/>
+		<antcall target="display-text" >
+            <param name="file" value="${src.rat.report}.bin.txt" />
+        </antcall>
+        <input
+			message="Check that there are no unexpected binaries.  Is it ok?"
+            validargs="y,n"
+        defaultvalue="n"
+        addproperty="rat.binaries.ok"/>
+    </target>
+
+    <target name="binary-rat" >
+        <echo message="Checking files at ${basedir}/${bin.package.url.name}, report is ${bin.rat.report}"/>
+        <rat:report xmlns:rat="antlib:org.apache.rat.anttasks"
+            reportFile="${bin.rat.report}">
+            <fileset dir="${basedir}/${bin.package.url.name}">
+                <!-- exclude media (png, gif, jpg, mp3, flv) -->
+                <exclude name="**/*.png"/>
+                <exclude name="**/*.gif"/>
+                <exclude name="**/*.jpg"/>
+                <exclude name="**/*.mp3"/>
+                <exclude name="**/*.flv"/>
+                <!--          JSON doesn't really have a comment format     -->
+                <exclude name="**/*.json"/>
+                <!--          JSHint properties file           -->
+                <exclude name="frameworks/js/jshint.properties"/>
+                <exclude name="frameworks/js/.jshintrc"/>
+                <!--          fragments           -->
+                <exclude name="LICENSE.bin"/>
+                <exclude name="LICENSE.base"/>
+                <!--          Google Closure Library     -->
+                <exclude name="js/lib/google/**"/>
+                <!--          compiled output     -->
+                <exclude name="frameworks/projects/*/target/**"/>
+                <!--          swcs     -->
+                <exclude name="frameworks/libs/Binding.swc"/>
+                <exclude name="frameworks/libs/Charts.swc"/>
+                <exclude name="frameworks/libs/Collections.swc"/>
+                <exclude name="frameworks/libs/Core.swc"/>
+                <exclude name="frameworks/libs/CreateJS.swc"/>
+                <exclude name="frameworks/libs/DragDrop.swc"/>
+                <exclude name="frameworks/libs/Effects.swc"/>
+                <exclude name="frameworks/libs/Flat.swc"/>
+                <exclude name="frameworks/libs/Formatters.swc"/>
+                <exclude name="frameworks/libs/GoogleMaps.swc"/>
+                <exclude name="frameworks/libs/Graphics.swc"/>
+                <exclude name="frameworks/libs/HTML.swc"/>
+                <exclude name="frameworks/libs/HTML5.swc"/>
+                <exclude name="frameworks/libs/JQuery.swc"/>
+                <exclude name="frameworks/libs/Mobile.swc"/>
+                <exclude name="frameworks/libs/Network.swc"/>
+                <exclude name="frameworks/libs/Reflection.swc"/>
+                <exclude name="frameworks/libs/Storage.swc"/>
+                <exclude name="frameworks/externs/Binding.swc"/>
+                <exclude name="frameworks/externs/Charts.swc"/>
+                <exclude name="frameworks/externs/Collections.swc"/>
+                <exclude name="frameworks/externs/Core.swc"/>
+                <exclude name="frameworks/externs/CreateJS.swc"/>
+                <exclude name="frameworks/externs/DragDrop.swc"/>
+                <exclude name="frameworks/externs/Effects.swc"/>
+                <exclude name="frameworks/externs/Flat.swc"/>
+                <exclude name="frameworks/externs/Formatters.swc"/>
+                <exclude name="frameworks/externs/GoogleMaps.swc"/>
+                <exclude name="frameworks/externs/Graphics.swc"/>
+                <exclude name="frameworks/externs/HTML.swc"/>
+                <exclude name="frameworks/externs/HTML5.swc"/>
+                <exclude name="frameworks/externs/JQuery.swc"/>
+                <exclude name="frameworks/externs/Mobile.swc"/>
+                <exclude name="frameworks/externs/Network.swc"/>
+                <exclude name="frameworks/externs/Reflection.swc"/>
+                <exclude name="frameworks/externs/Storage.swc"/>
+            </fileset>
+        </rat:report>
+        
+        <antcall target="display-text" >
+            <param name="file" value="${bin.rat.report}" />
+        </antcall>
+        <input
+        message="Check that there are no unknown or unapproved licenses or archives. Is it ok?"
+        validargs="y,n"
+        defaultvalue="y"
+        addproperty="rat.bin.license.ok"/>
+        <echo>filtering out AL files to make it easier to see binary files</echo>
+        <copy file="${bin.rat.report}" tofile="${bin.rat.report}.bin.txt" />
+        <replaceregexp file="${bin.rat.report}.bin.txt" match="..AL.*" replace="__AL" byline="true"/>
+        <replaceregexp file="${bin.rat.report}.bin.txt" flags="gs" match="__AL." replace="" byline="false"/>
+        <antcall target="display-text" >
+            <param name="file" value="${bin.rat.report}.bin.txt" />
+        </antcall>
+        <input
+        message="Check that there are no unexpected binaries.  Is it ok?"
+        validargs="y,n"
+        defaultvalue="n"
+        addproperty="rat.bin.binaries.ok"/>
+    </target>
+
+    <target name="doc-rat" >
+        <echo message="Checking files at ${basedir}/${doc.package.url.name}, report is ${doc.rat.report}"/>
+        <rat:report xmlns:rat="antlib:org.apache.rat.anttasks"
+            reportFile="${doc.rat.report}">
+            <fileset dir="${basedir}/${doc.package.url.name}">
+                <!-- exclude generated html -->
+                <exclude name="asdoc/index.html"/>
+                <exclude name="asdoc/index-*.html"/>
+                <exclude name="asdoc/google/maps/**/*.html"/>
+                <exclude name="asdoc/org/**/*.html"/>
+                <exclude name="asdoc/package*.html"/>
+                <exclude name="asdoc/all-classes.html"/>
+                <exclude name="asdoc/all-index*.html"/>
+                <exclude name="asdoc/class-*.html"/>
+                <exclude name="asdoc/title-bar.html"/>
+                <exclude name="asdoc/Namespace.html"/>
+                <exclude name="asdoc/QName.html"/>
+                <!-- exclude log -->
+                <exclude name="asdoc/validation_errors.log"/>
+            </fileset>
+        </rat:report>
+        
+        <antcall target="display-text" >
+            <param name="file" value="${doc.rat.report}" />
+        </antcall>
+        <input
+        message="Check that there are no unknown or unapproved licenses or archives. Is it ok?"
+        validargs="y,n"
+        defaultvalue="y"
+        addproperty="rat.doc.license.ok"/>
+        <echo>filtering out AL files to make it easier to see binary files</echo>
+        <copy file="${doc.rat.report}" tofile="${doc.rat.report}.bin.txt" />
+        <replaceregexp file="${doc.rat.report}.bin.txt" match="..AL.*" replace="__AL" byline="true"/>
+        <replaceregexp file="${doc.rat.report}.bin.txt" flags="gs" match="__AL." replace="" byline="false"/>
+        <antcall target="display-text" >
+            <param name="file" value="${doc.rat.report}.bin.txt" />
+        </antcall>
+        <input
+        message="Check that there are no unexpected binaries.  Is it ok?"
+        validargs="y,n"
+        defaultvalue="n"
+        addproperty="rat.doc.binaries.ok"/>
+    </target>
+
+    <target name="check-notices" description="open each notice file for review, grep for a few things" >
+        <fail message="README not in package">
+			<condition>
+	            <not>
+    	            <available file="${basedir}/${package.url.name}/README" />
+        	    </not>
+			</condition>
+        </fail>
+        <fail message="RELEASE_NOTES not in package">
+			<condition>
+				<not>
+					<available file="${basedir}/${package.url.name}/RELEASE_NOTES" />
+				</not>
+			</condition>
+        </fail>
+        <fail message="NOTICE not in package">
+			<condition>
+				<not>
+					<available file="${basedir}/${package.url.name}/NOTICE" />
+				</not>
+			</condition>
+        </fail>
+        <fail message="LICENSE not in package">
+			<condition>
+				<not>
+					<available file="${basedir}/${package.url.name}/LICENSE" />
+				</not>
+			</condition>
+        </fail>
+		<antcall target="display-text" >
+            <param name="file" value="${basedir}/${package.url.name}/README" />
+        </antcall>
+		<input
+			message="Check the README for version numbers, spelling, grammar, accuracy.  Is it ok?"
+            validargs="y,n"
+        defaultvalue="y"
+        addproperty="readme.ok"/>
+		<antcall target="display-text" >
+            <param name="file" value="${basedir}/${package.url.name}/RELEASE_NOTES" />
+        </antcall>
+		<input
+			message="Check the RELEASE_NOTES for copyright years, spelling, grammar, accuracy. Is it ok?"
+            validargs="y,n"
+        defaultvalue="y"
+        addproperty="releasenotes.ok"/>
+		
+        
+		<antcall target="display-text" >
+            <param name="file" value="${basedir}/${package.url.name}/NOTICE" />
+        </antcall>
+		<input
+			message="Check the NOTICE for required notices from third-parties. Is it ok?"
+            validargs="y,n"
+        defaultvalue="y"
+        addproperty="notice.ok"/>
+
+		<antcall target="display-text" >
+            <param name="file" value="${basedir}/${package.url.name}/LICENSE" />
+        </antcall>
+		<input
+			message="Check the LICENSE for the Apache License and third-party licenses. Is it ok?"
+            validargs="y,n"
+        defaultvalue="y"
+        addproperty="license.ok"/>
+        
+        <antcall target="display-text" >
+            <param name="file" value="${basedir}/${bin.package.url.name}/NOTICE" />
+        </antcall>
+        <input
+        message="Check the binary package NOTICE for required notices from third-parties. Is it ok?"
+        validargs="y,n"
+        defaultvalue="y"
+        addproperty="bin.notice.ok"/>
+        
+        <antcall target="display-text" >
+            <param name="file" value="${basedir}/${bin.package.url.name}/LICENSE" />
+        </antcall>
+        <input
+        message="Check the binary package LICENSE for the Apache License and third-party licenses. Is it ok?"
+        validargs="y,n"
+        defaultvalue="y"
+        addproperty="bin.license.ok"/>
+        
+        <antcall target="display-text" >
+            <param name="file" value="${basedir}/${doc.package.url.name}/asdoc/NOTICE" />
+        </antcall>
+        <input
+        message="Check the doc package NOTICE for required notices from third-parties. Is it ok?"
+        validargs="y,n"
+        defaultvalue="y"
+        addproperty="doc.notice.ok"/>
+        
+        <antcall target="display-text" >
+            <param name="file" value="${basedir}/${doc.package.url.name}/asdoc/LICENSE" />
+        </antcall>
+        <input
+        message="Check the doc package LICENSE for the Apache License and third-party licenses. Is it ok?"
+        validargs="y,n"
+        defaultvalue="y"
+        addproperty="doc.license.ok"/>
+    </target>
+
+    <target name="ask.build">
+        <input
+        message="The final step is to run the build and any tests the build script runs.  This can take several minutes.  You will be asked to accept the Adobe license for the font jars.  Press y to start the build."
+        validargs="y"
+        defaultvalue="y" />
+    </target>
+
+    <target name="build" depends="ask.build,ask-font,get.dependencies,copy.downloads">
+        <property name="no.lint" value="true" />
+        <ant dir="${basedir}/${package.url.name}" target="main" />
+        <ant dir="${basedir}/${package.url.name}" target="examples" />
+    </target>
+
+    <target name="copy.downloads" if="${do.copy.downloads}" description="instead of actually downloading all of the dependencies, you can save lots of time by just copying from some other folder in some other SDK.">
+		<echo>Copying downloads</echo>
+        <copy todir="${basedir}/${package.url.name}/in" >
+			<fileset dir="${download.cache.dir}" />
+		</copy>
+    </target>
+    
+    <!-- Prompt before downloading.  -->
+    <target name="ask-font" unless="font.donot.ask"
+        description="Prompt the user before downloading BlaseDS">
+        
+        <property name="font.prompt.text"
+        value="Apache Flex can optionally integrate with Adobe's embedded font support.
+        ${line.separator}This feature requires a few font jars from the Adobe Flex SDK.
+        ${line.separator}The Adobe SDK license agreement for Adobe Flex 4.6 applies to these jars.
+        ${line.separator}This license is not compatible with the Apache v2 license.
+        ${adobe.flex.license}
+        ${line.separator}Do you want to install these jars from the Adobe Flex SDK?"/>
+        <input
+        message="${font.prompt.text}"
+        validargs="y,n"
+        defaultvalue="n"
+        addproperty="input.font.download"/>
+        <condition property="do.font.install">
+            <equals arg1="y" arg2="${input.font.download}"/>
+        </condition>
+        <!-- Only ask once per ant run.  -->
+        <property name="font.donot.ask" value="set"/>
+    </target>
+    
+    <target name="get.dependencies" depends="set.falcon.flags,get.falcon.if.needed,get.sdk.if.needed,get.flexunit.if.needed" />
+    <target name="set.falcon.flags" >
+        <condition property="falcon.nightly">
+            <and>
+                <not>
+                    <isset property="FALCON_HOME" />
+                </not>
+                <not>
+                    <isset property="rc" />
+                </not>
+            </and>
+        </condition>
+        <condition property="falcon.rc">
+            <and>
+                <not>
+                    <isset property="FALCON_HOME" />
+                </not>
+                <isset property="rc" />
+            </and>
+        </condition>
+    </target>
+    <target name="get.falcon.if.needed" depends="get.falcon.nightly,get.falcon.rc" unless="FALCON_HOME" />
+    <target name="get.falcon.nightly" if="falcon.nightly">
+        <property name="kit.jx.prefix" value="apache-flex-falconjx-0.6.0"/>
+        <property name="binary.jx.kit" value="${kit.jx.prefix}-bin"/>
+        <get src="http://apacheflexbuild.cloudapp.net:8080/job/flex-falcon/lastSuccessfulBuild/artifact/out/${binary.jx.kit}.zip"
+             dest="${basedir}/${binary.jx.kit}.zip" verbose="true" skipexisting="true"/>
+        <get src="http://apacheflexbuild.cloudapp.net:8080/job/flex-falcon/lastSuccessfulBuild/artifact/out/${binary.jx.kit}.zip.md5"
+             dest="${basedir}/${binary.jx.kit}.zip.md5" verbose="true" skipexisting="true"/>
+        <checksum file="${basedir}/${binary.jx.kit}.zip" algorithm="md5" verifyproperty="falcon.md5.ok" />
+        <condition property="FalconMD5Invalid">
+            <not>
+                <equals arg1="${falcon.md5.ok}" arg2="true" />
+            </not>
+        </condition>
+        <fail message="MD5 checksum did not match" if="FalconMD5Invalid" />
+        <unzip src="${basedir}/${binary.jx.kit}.zip" dest="${basedir}/falconjx" />
+        <ant dir="${basedir}/falconjx/compiler" antfile="downloads.xml" />
+        <ant dir="${basedir}/falconjx/compiler.jx" antfile="downloads.xml" />
+        <!-- Copy compiler external dependencies -->
+        <copy todir="${basedir}/falconjx/compiler/generated/dist/sdk/lib/external" overwrite="true" includeEmptyDirs="false">
+            <fileset dir="${basedir}/falconjx/compiler/lib">
+                <include name="**"/>
+            </fileset>
+        </copy>
+        <!-- Copy compiler.jx external dependencies -->
+        <copy todir="${basedir}/falconjx/js/lib" overwrite="true" includeEmptyDirs="false">
+            <fileset dir="${basedir}/falconjx/compiler.jx/lib">
+                <include name="**"/>
+            </fileset>
+        </copy>
+        <property name="FALCON_HOME" value="${basedir}/falconjx/compiler/generated/dist/sdk" />
+        <property name="FALCONJX_HOME" value="${basedir}/falconjx/js" />
+    </target>
+    <target name="get.falcon.rc" if="falcon.rc">
+        <property name="kit.jx.prefix" value="apache-flex-falconjx-0.6.0"/>
+        <property name="binary.jx.kit" value="${kit.jx.prefix}-bin"/>
+        <get src="https://dist.apache.org/repos/dist/dev/flex/falcon/0.6.0/rc1/binaries/${binary.jx.kit}.zip"
+        dest="${basedir}/${binary.jx.kit}.zip" verbose="true" skipexisting="true"/>
+        <get src="https://dist.apache.org/repos/dist/dev/flex/falcon/0.6.0/rc1/binaries/${binary.jx.kit}.zip.md5"
+        dest="${basedir}/${binary.jx.kit}.zip.md5" verbose="true" skipexisting="true"/>
+        <checksum file="${basedir}/${binary.jx.kit}.zip" algorithm="md5" verifyproperty="falcon.md5.ok" />
+        <condition property="FalconMD5Invalid">
+            <not>
+                <equals arg1="${falcon.md5.ok}" arg2="true" />
+            </not>
+        </condition>
+        <fail message="MD5 checksum did not match" if="FalconMD5Invalid" />
+        <unzip src="${basedir}/${binary.jx.kit}.zip" dest="${basedir}/falconjx" />
+        <ant dir="${basedir}/falconjx/compiler" antfile="downloads.xml" />
+        <ant dir="${basedir}/falconjx/compiler.jx" antfile="downloads.xml" />
+        <!-- Copy compiler external dependencies -->
+        <copy todir="${basedir}/falconjx/compiler/generated/dist/sdk/lib/external" overwrite="true" includeEmptyDirs="false">
+            <fileset dir="${basedir}/falconjx/compiler/lib">
+                <include name="**"/>
+            </fileset>
+        </copy>
+        <!-- Copy compiler.jx external dependencies -->
+        <copy todir="${basedir}/falconjx/js/lib" overwrite="true" includeEmptyDirs="false">
+            <fileset dir="${basedir}/falconjx/compiler.jx/lib">
+                <include name="**"/>
+            </fileset>
+        </copy>
+        <property name="FALCON_HOME" value="${basedir}/falconjx/compiler/generated/dist/sdk" />
+        <property name="FALCONJX_HOME" value="${basedir}/falconjx/js" />
+    </target>
+    <target name="get.flexunit.if.needed" unless="FLEXUNIT_HOME" >
+        <property name="binary.flexunit.kit" value="apache-flex-flexunit-4.2.0-4.12.0-bin"/>
+        <get src="https://archive.apache.org/dist/flex/flexunit/4.2.0/binaries/${binary.flexunit.kit}.zip"
+        dest="${basedir}/${binary.flexunit.kit}.zip" verbose="true" skipexisting="true"/>
+        <get src="https://archive.apache.org/dist/flex/flexunit/4.2.0/binaries/${binary.flexunit.kit}.zip.md5"
+        dest="${basedir}/${binary.flexunit.kit}.zip.md5" verbose="true" skipexisting="true"/>
+        <checksum file="${basedir}/${binary.flexunit.kit}.zip" algorithm="md5" verifyproperty="flexunit.md5.ok" />
+        <condition property="FlexUnitMD5Invalid">
+            <not>
+                <equals arg1="${flexunit.md5.ok}" arg2="true" />
+            </not>
+        </condition>
+        <fail message="MD5 checksum did not match" if="FlexUnitMD5Invalid" />
+        <unzip src="${basedir}/${binary.flexunit.kit}.zip" dest="${basedir}/flexunit" />
+        <property name="FLEXUNIT_HOME" value="${basedir}/flexunit" />
+    </target>
+    <target name="get.sdk.if.needed" depends="get.sdk" unless="FLEX_SDK_HOME" />
+    <target name="get.sdk">
+        <property name="kit.sdk.prefix" value="apache-flex-sdk-4.14.1"/>
+        <property name="binary.sdk.kit" value="${kit.sdk.prefix}-bin"/>
+        <get src="https://archive.apache.org/dist/flex/4.14.1/binaries/${binary.sdk.kit}.zip"
+        dest="${basedir}/${binary.sdk.kit}.zip" verbose="true" skipexisting="true"/>
+        <get src="https://archive.apache.org/dist/flex/4.14.1/binaries/${binary.sdk.kit}.zip.md5"
+        dest="${basedir}/${binary.sdk.kit}.zip.md5" verbose="true" skipexisting="true"/>
+        <checksum file="${basedir}/${binary.sdk.kit}.zip" algorithm="md5" verifyproperty="sdk.md5.ok" />
+        <condition property="SDKMD5Invalid">
+            <not>
+                <equals arg1="${sdk.md5.ok}" arg2="true" />
+            </not>
+        </condition>
+        <fail message="MD5 checksum did not match" if="SDKMD5Invalid" />
+        <unzip src="${basedir}/${binary.sdk.kit}.zip" dest="${basedir}/sdk" />
+        <ant dir="${basedir}/sdk/frameworks" antfile="downloads.xml" />
+        <property name="FLEX_SDK_HOME" value="${basedir}/sdk" />
+    </target>
+    
+	<target name="approve" >
+		<condition property="vote" value="+1">
+			<and>
+				<equals arg1="${rat.license.ok}" arg2="y" />
+				<equals arg1="${rat.binaries.ok}" arg2="y" />
+                <equals arg1="${rat.bin.license.ok}" arg2="y" />
+                <equals arg1="${rat.bin.binaries.ok}" arg2="y" />
+                <equals arg1="${rat.doc.license.ok}" arg2="y" />
+                <equals arg1="${rat.doc.binaries.ok}" arg2="y" />
+				<equals arg1="${readme.ok}" arg2="y" />
+				<equals arg1="${releasenotes.ok}" arg2="y" />
+				<equals arg1="${notice.ok}" arg2="y" />
+				<equals arg1="${license.ok}" arg2="y" />
+                <equals arg1="${bin.notice.ok}" arg2="y" />
+                <equals arg1="${bin.license.ok}" arg2="y" />
+                <equals arg1="${doc.notice.ok}" arg2="y" />
+                <equals arg1="${doc.license.ok}" arg2="y" />
+			</and>
+		</condition>
+		<property name="vote" value="-1" />
+		<echo>
+${vote}
+Package ${package.url.path}/${package.url.name}.${package.suffix}
+Java ${ant.java.version}
+OS: ${os.name} ${os.arch} ${os.version}
+Source kit signatures match: y
+Source kit builds: y
+README is ok: ${readme.ok}
+RELEASE_NOTES is ok: ${releasenotes.ok}
+NOTICE is ok: ${notice.ok}
+LICENSE is ok: ${license.ok}
+No unapproved licenses or archives: ${rat.license.ok}
+No unapproved binaries: ${rat.binaries.ok}
+
+Package ${bin.package.url.path}/${bin.package.url.name}.${package.suffix}
+Binary kit signatures match: y
+NOTICE is ok: ${bin.notice.ok}
+LICENSE is ok: ${bin.license.ok}
+No unapproved licenses or archives in binary package: ${rat.bin.license.ok}
+No unapproved binaries in binary package: ${rat.bin.binaries.ok}
+
+Package ${doc.package.url.path}/${doc.package.url.name}.zip
+Doc kit signatures match: y
+NOTICE is ok: ${doc.notice.ok}
+LICENSE is ok: ${doc.license.ok}
+No unapproved licenses or archives in doc package: ${rat.doc.license.ok}
+No unapproved binaries in doc package: ${rat.doc.binaries.ok}
+        </echo>
+		<fail>
+			<condition>
+	            <equals arg1="-1" arg2="${vote}"/>
+			</condition>
+		</fail>
+	</target>
+</project>

Added: dev/flex/flexjs/0.6.0/rc2/READme
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/READme (added)
+++ dev/flex/flexjs/0.6.0/rc2/READme Wed Mar 30 04:59:04 2016
@@ -0,0 +1,270 @@
+Apache FlexJS
+=============
+
+    Apache FlexJS is a next-generation Flex SDK that has the goal of allowing 
+    applications developed in MXML and ActionScript to not only run in the 
+    Flash/AIR runtimes, but also to run natively in the browser without Flash, 
+    on mobile devices as a PhoneGap/Cordova application, and in embedded JS 
+    environments such as Chromium Embedded Framework.  FlexJS has the potential 
+    to allow your MXML and ActionScript code to run in even more places than 
+    Flash currently does. 
+
+    For detailed information about Apache Flex please visit
+    https://cwiki.apache.org/confluence/display/FLEX/FlexJS
+
+    For detailed information about Apache Flex please visit
+    http://flex.apache.org/
+
+Getting the latest sources via git
+==================================
+
+    Getting the source code is the recommended way to get Apache FlexJS.  
+    We also offer an automated installer along with binary distributions on our 
+    website at http://flex.apache.org/.
+
+    You can always checkout the latest source via git using the following
+    command:
+
+	 git clone https://git-wip-us.apache.org/repos/asf/flex-asjs.git flex-asjs
+	 cd flex-asjs
+	 git checkout develop
+
+    Apache FlexJS also requires code from several other Apache Flex git
+    repositories.  To get the latest sources via git, first follow the
+    instructions in ‘Install Prerequisites’, then from the flex-asjs
+    directory, run:
+    
+         ant all
+
+    This will clone all of the upstream repositories, checkout the develop branches
+    then run the builds in those repositories in the correct order.
+
+Building Apache FlexJS
+======================
+
+    Apache FlexJS is a large project. It requires some build tools 
+    which must be installed prior to building the SDK.  
+    Some of these have different licenses.  See the Software Dependencies section 
+    for more information on the external software dependencies.
+
+    Linux support is currently experimental and while it is possible to compile
+    the SDK it has not been fully tested so you may run into issues.
+
+Install Prerequisites
+---------------------
+
+    Before building Apache FlexJS you must install the following software 
+    and set the corresponding environment variables using absolute file paths.  
+    Relative file paths will result in build errors.
+
+    ==================================================================================
+    SOFTWARE                                    ENVIRONMENT VARIABLE (absolute paths)
+    ==================================================================================
+
+    Java SDK 1.6 or greater (*1)                JAVA_HOME
+        (for Java 1.7 see note at (*2))
+
+    Ant 1.7.1 or greater (*1)                   ANT_HOME
+        (for Java 1.7 see note at (*2))
+
+    Google Closure Library (*3)                 GOOG_HOME
+
+    Google Closure Linter (*4)                  see note
+
+    Adobe Flash Player playerglobal swcs (*5)   PLAYERGLOBAL_HOME
+
+    Adobe AIR Integration Kit (* 6)             AIR_HOME
+
+    Adobe Flash Player Content Debugger (* 7)   FLASHPLAYER_DEBUGGER
+
+    JSHint (*8)                                 see note
+
+    Apache Flex 'Falcon' Compiler (*9)          FALCON_HOME
+
+    Apache Flex 'FalconJX' Compiler (*10)       FALCONJX_HOME
+
+    Apache Flex FlexUnit (*11)                  FLEXUNIT_HOME
+
+    Apache Flex SDK or repository               FLEX_HOME
+
+    ==================================================================================
+
+    *1) The bin directories for ANT_HOME and JAVA_HOME should be added to your
+        PATH.
+
+        On Windows, set PATH to
+
+            PATH=%PATH%;%ANT_HOME%\bin;%JAVA_HOME%\bin
+
+        On the Mac (bash), set PATH to
+
+            export PATH="$PATH:$ANT_HOME/bin:$JAVA_HOME/bin"
+
+         On Linux make sure you path include ANT_HOME and JAVA_HOME.
+
+    *2)  If you are using Java SDK 1.7 or greater on a Mac you must use Ant 1.8
+         or greater. If you use Java 1.7 with Ant 1.7, ant reports the java
+         version as 1.6 so the JVM args for the data model (-d32/-d64) will not
+         be set correctly and you will get compile errors.
+
+    *3) The Google Closure Library can be downloaded or cloned from GitHub:
+           https://github.com/google/closure-library
+
+        Set GOOG_HOME to the absolute path of the folder that contains the 
+        third_party and closure sub-folders.
+
+    *4) The Google Closure Linter can be installed by following the directions here:
+            https://developers.google.com/closure/utilities/docs/linter_howto
+
+        It should automatically make the linter available.  No need to change paths 
+        or environment variables.  Some folks on OSX had permission issues after the
+        install.  See their support channels for assistance.
+
+    *5) The Adobe Flash Player playerglobal.swc for 11.1 can be downloaded from:
+            http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_1.swc
+
+        Use URL above to download playerglobal11_1.swc. Create the directory,
+        player/11.1 and copy playerglobal11_1.swc to
+        player/11.1/playerglobal.swc.
+
+        Set PLAYERGLOBAL_HOME to the absolute path of the player directory (not
+        including the version subdirectory). The target-player option controls
+        which PLAYERGLOBAL_HOME subdirectory is used.
+
+        Other more recent versions of Adobe Flash Player playerglobal.swc can be
+        downloaded from:
+            http://download.macromedia.com/get/flashplayer/updaters/<version.major>/playerglobal<version.major>_<version.minor>.swc
+
+        (e.g. http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_1.swc)
+
+        These can be used with Apache FlexJS but not all have not been fully
+        tested.
+
+
+         Copy the target playerglobal.swc to the directory:
+
+            frameworks/libs/player/<version.major>.<version.minor>/playerglobal.swc
+
+    *6) The Adobe AIR integration kit for Windows can be downloaded from:
+
+           http://airdownload.adobe.com/air/win/download/16.0/AdobeAIRSDK.zip
+
+        The Adobe AIR integration kit for Mac can be downloaded from:
+
+           http://airdownload.adobe.com/air/mac/download/16.0/AdobeAIRSDK.tbz2
+
+        The Adobe AIR integration kit for Linux can be downloaded from:
+
+           http://airdownload.adobe.com/air/lin/download/2.6/AdobeAIRSDK.tbz2
+
+        Download the AIR SDK for your platform and unzip it. Set AIR_HOME to the
+        absolute path of the AIR SDK directory.
+
+        This version of Apache FlexJS was certified for use with Adobe AIR 16
+        and is compatible with version 3.1 and up.
+
+    *7) The Adobe Flash Player content debuggers can be found here:
+
+           http://www.adobe.com/support/flashplayer/downloads.html
+
+        This version of Apache FlexJS was certified for use with Adobe Flash
+        Player 11.1, and is compatible with version 10.2 and up. It has been tested
+        with versions 16.0 on Windows and Mac. It has been compiled, but not fully
+        tested, with other Adobe Flash Player versions. It has not been 
+        fully tested on Linux.
+
+        On Windows, set FLASHPLAYER_DEBUGGER to the absolute path including the
+        filename of the FlashPlayerDebugger.exe. Note the filename of flash player
+        debugger may be different, e.g. C:\MyPath\FlashPlayerDebugger.exe.
+
+        On the Mac, set FLASHPLAYER_DEBUGGER to the absolute path of
+        'Flash Player Debugger.app/Contents/MacOS/Flash Player Debugger'
+
+        On Linux, set FLASHPLAYER_DEBUGGER to the absolute path of flashplayerdebugger.
+
+    *8) You will need npm (Node Package Manager) to install JSHint. You can get npm from here:
+            https://nodejs.org/
+    
+        The JSHint utility can be installed by following the instructions here:
+            http://www.jshint.com/install/
+
+        JSHint will also be automatically available.  No need to change paths or
+        environment variables.  On OSX some folks had permission issues after
+        the install.  See their documentation on using -g and sudo.
+
+    *9) Set FALCON_HOME to the root of its SDK.  If you have cloned the flex-falcon
+        repository as a sibling of the flex-asjs repository, you don’t need to
+        set this variable, otherwise, set it as: 
+             FALCON_HOME=<repo-path>/compiler/generated/dist/sdk
+			 
+	    Look at flex-falcon/README for instructions on how to build Falcon
+
+    *10) Set FALCONJX_HOME to the root of its SDK.  If you have cloned the flex-falcon
+         repositoryas a sibling of the flex-asjs repository, you don’t need to
+         set this variable, otherwise, set it as
+             FALCONJX_HOME=<repo-path>/compiler.jx
+        
+	 Look at flex-falcon/README_JX for instructions on how to build FalconJX
+			 
+    *11) Set FLEXUNIT_HOME to the root of a FlexUnit release or repo.  If you
+         have cloned the flex-flexunit repository as a sibling of the flex-asjs
+         repository, you don’t need to set this variable. 
+	 Look at flex-flexunit/README for instructions on how to build FlexUnit
+
+Software Dependencies
+---------------------
+
+    The Apache FlexJS framework depends on the Google Closure Library.
+
+Using the Binary Distribution
+-----------------------------
+
+    The binary distribution requires the download and installation of the third-party
+    dependencies before it can be used.
+
+    There is an Apache Ant script in the binary distribution that will copy the 
+    files into the right places.
+
+    To run it, use:
+        ant -f installer.xml
+
+    Another option is to use the InstallApacheFlex (version 3.0 or higher).
+
+    Other Ant targets, such as the examples target, expect certain environment
+    variables to be set as described earlier in this README.  However, because
+    the installer copies various SDKs into an IDE compatible SDK, you can set
+    PLAYERGLOBAL_HOME to the absolute path of the distribution's 
+    frameworks/libs/player folder, set FALCON_HOME to the SDK's root folder,
+    set FALCONJX_HOME to the SDK's js folder, and set GOOG_HOME to the SDK's
+    js/lib/google/closure-library folder. 
+
+Building the Source in the Source Distribution
+----------------------------------------------
+
+    When you have all the prerequisites in place and the environment variables
+    set (see Install Prerequisites above), use
+
+        cd <flex-asjs.dir>
+        ant main        (or just ant since the default target is main)
+
+    To clean the build, of everything other than the downloaded third-party
+    dependencies use
+
+        ant clean
+
+    To generate a source distribution package and a binary distribution package
+    use
+
+        ant -Dbuild.number=<YYYYMMDD> -Dbuild.noprompt= release
+
+    The packages can be found in the "out" subdirectory.
+
+    To get a brief listing of all the targets type
+
+        ant -projecthelp
+
+
+Thanks for using Apache FlexJS.  Enjoy!
+
+                                          The Apache Flex Project
+                                          <http://flex.apache.org>

Added: dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.tar.gz
==============================================================================
Binary file - no diff available.

Propchange: dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.tar.gz
------------------------------------------------------------------------------
    svn:mime-type = application/octet-stream

Added: dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.tar.gz.asc
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.tar.gz.asc (added)
+++ dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.tar.gz.asc Wed Mar 30 04:59:04 2016
@@ -0,0 +1,18 @@
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG/MacGPG2 v2
+Comment: GPGTools - http://gpgtools.org
+
+iQIcBAABCAAGBQJW+10BAAoJEIPgQxzanM/yisEQAI8FQWnhhkVVja4E7qVfS0ix
++I5gceddcHSJ3DiRPfK9rwR2NBO0L/bSArovlz2Z2wpJetxVW67R35sAKIKGDpt+
+E2PtCNqIzjEP2v18Z2gq/WDL5e80Wu30mkunqMoeQatYvjnsj9GN4HkQ0GGTJu17
+pio2Goq5gcREv9zIYriYh5uc/4dAs9uO5bB9CM5emf6Z/71aeb3HBwKjlILp7lyG
+yENqXeyGc+V8y1AMI5HHZoN/Um183lowlKaE8ycc6G18xSf0Bun/xE3fqxGNuLPy
+0RYIsip/oj+T0LtIFVj6YD2v6E0ckF3Emq4KuLa+UUbIU3DYkPkP/2PLZ53USZ1a
+11NKJIlKxlERLf3S/uJCMH+JpW8aUqx6vtxqagBdFbQZ2hy7capbBy7ZYSXFFl+C
+CqUFgHbjBOGXLSRkmzgjxN2fMhbIgCzCNGw3sEgJVFWECuj77IFplXqHVt6KjDI5
+jbO0BphhW6mvCKpqvd0WpnltL9Fm5K249FxrXaEoI6TzCSe2pxwEstbd1lpWnelP
+UqSaNmvIM+r6NUAwB9Q6/XD9HTN8BW5rHtj1oMf6NVa8MouXEIu6bmKvOkA6Zu3f
+fSsoSgFtQMWyU3zzaowEUyOemJKWb9ECKNwa1Uo2QokTtkTEa8hZtO6B/V/iBjWl
+3KbsHT+vBCdh1AvdP3OC
+=0+Ko
+-----END PGP SIGNATURE-----

Added: dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.tar.gz.md5
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.tar.gz.md5 (added)
+++ dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.tar.gz.md5 Wed Mar 30 04:59:04 2016
@@ -0,0 +1 @@
+ae306fc12d0d12d638ac553abf223b30

Added: dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.zip
==============================================================================
Binary file - no diff available.

Propchange: dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.zip
------------------------------------------------------------------------------
    svn:mime-type = application/octet-stream

Added: dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.zip.asc
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.zip.asc (added)
+++ dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.zip.asc Wed Mar 30 04:59:04 2016
@@ -0,0 +1,18 @@
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG/MacGPG2 v2
+Comment: GPGTools - http://gpgtools.org
+
+iQIcBAABCAAGBQJW+10BAAoJEIPgQxzanM/yRL0P/0IgzhXQiXzCY3i+fWa7HYoV
+Letk0oyYeEqBTwR5qBNb4H0Gcz2Hqp3knidrxAMGrJ+LyZf7fJGRx/iWT+l4k1z2
+WNfqFIJ4KzRQMbq0G3X3qfLAWin25H5KV6ZytHIH5dUCaDn3NyDuDIP5hzDnwFdG
+McHwktcyKq1UvaX/N89caV8X9k0oB6awWQkWompG8+S6DEq4grkAUmlSMll+B0E5
+jAR6N2sD1B6BQi8knSZWnaWupOxXRyoKaBYZRGlp3b3cGD3p2Oq7ejPh3IkkO1XF
+ekJJJSR6BOurQSX5ezt8Amt57MOp9FlsY8flDDS2Olx5r9E+BQSGt28TiDfrIYzT
+7BWiOf3rLWoENyF+cYJDP5lXfLhYtJAQtR/+4qHV7/7p2qqLFhOAS4kTBLe+nHg6
+QOWojsz4e869NubniwlKRKcnXNeAgLEtOztLHBreDHJ6DtW5QwKJhJNtpp+8hrhF
+Q04iWROm/XJN4w0GuBtsu2COtpiU3peNwbs0hgWQ0H+iaBKnLKSpai+j23vHqRhW
+VWxJDBSDCxpfBvJ418F/55D7lNJnO/4DQQOsHBE9ykkzNJLX8UKguEaIU+2p29bH
+p3JwSBFDojXHD2Zwvtsl+DoIbQl76Cf7TW0fZDQON1N6AtKUVb/QI41qViBkX4s5
+FyWKsag41adNdJe7+RpA
+=9D5E
+-----END PGP SIGNATURE-----

Added: dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.zip.md5
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.zip.md5 (added)
+++ dev/flex/flexjs/0.6.0/rc2/apache-flex-flexjs-0.6.0-src.zip.md5 Wed Mar 30 04:59:04 2016
@@ -0,0 +1 @@
+2152dc1b88a2a5c5d3cba616bf01a84d

Added: dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz
==============================================================================
Binary file - no diff available.

Propchange: dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz
------------------------------------------------------------------------------
    svn:mime-type = application/octet-stream

Added: dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz.asc
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz.asc (added)
+++ dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz.asc Wed Mar 30 04:59:04 2016
@@ -0,0 +1,18 @@
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG/MacGPG2 v2
+Comment: GPGTools - http://gpgtools.org
+
+iQIcBAABCAAGBQJW+10BAAoJEIPgQxzanM/yzHcP/21yYoJ15xO/zCI0q6DdfE82
+6outsHeewwPALLc+xeo/M0y9y6VoM3QdzSmxHjFp14YPjEtSpGxI5OEiv9Yp4/Ys
+Uf/etTWLyy33YxSH0YsuDKKjTwbjQGOHoDyscQMboQA1mdQ/JKK5pBLlKesuVSzK
+UYPsVv85kUTl8lhFZ5zh/NOofVxy0cSUC24eSJ/5egBTLlNVoZgUosAMrlEGsUtn
+4p9CD1RalLsnp0JJA5rujxcPk6cJVx8r6whtaQa9CkeLezYHfKmAnc5+ncabO1cG
+HVin/jglWJsh4miVqwzseaCUIpN0FTmWtgqm1Rb7hslg6vZSFtLVj3AVl4RjVsoq
+58MBGUd/pOCIRZp3mToViloCH/u990IaJhSR681CKMqJWcRE57MENrLsx6fB4QAv
+NHLCKPIDyKIR1rN8e5HY82SJT5lunGblQYm1+Lct1tcOelaHMAaLsuzuKf4OMZGh
+xit6gkHb/lCv0t6CibDuCBULlN2+RAycDD1W3TGjB/Pw6wdVF2ZCrCx4Cr6D7+fh
+gGc+rxZZYN7VzxLQGtQUUkH8I80KBH5ogwt7ppmWWlhKE5HQEEiwhWKnPUtaYOpq
+CB1YnzNKG8nfExUyEuwGpghAnxJMdUcUlo/dEQuhnXl3YshTnbuY6aoSR1IRN2lD
+J7OZmXu7XdJl0KV3hT9V
+=NB7k
+-----END PGP SIGNATURE-----

Added: dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz.md5
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz.md5 (added)
+++ dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.tar.gz.md5 Wed Mar 30 04:59:04 2016
@@ -0,0 +1 @@
+67ae90c450ca44d13cbb20317f2944ff

Added: dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.zip
==============================================================================
Binary file - no diff available.

Propchange: dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.zip
------------------------------------------------------------------------------
    svn:mime-type = application/octet-stream

Added: dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.zip.asc
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.zip.asc (added)
+++ dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.zip.asc Wed Mar 30 04:59:04 2016
@@ -0,0 +1,18 @@
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG/MacGPG2 v2
+Comment: GPGTools - http://gpgtools.org
+
+iQIcBAABCAAGBQJW+10BAAoJEIPgQxzanM/yeXcQALVcfgKw+V4Uh8orYT7kSVnc
+pXU+GgbcegiTrPSBKHr3BKwHd/WQAMrKFKgMn4gn4ib3TeKvZ+uWl9vSl2QZF+BX
+fn0oU8pZvFGjiN8v7Tazh5x0yjsRLVor3ei1ofFiemxUPE2Qz2Lwj6nJlclZdCRi
+Zy7xMkZ5FRgFtyqi+vdH4NBxRokR1+DlWYyz3PNc//w74K3J4F55OR4xBEzFwrYy
+ZTKk3qHn6rCPbHhRZK7C/tPbCdi98bgdV9kZWNPibb/n700cLCQ5koM6zPAZ9F8J
++WnudOYXd/9xZgUXmrKLFjGXwEtWknjsAbZ0vc1Qig8PBesyGm7lGxHJ1oTZftti
+icvQ51RYI6qgpy6FOaDvKB00wRcF8WZkE60wLnAeov6L2ejDxatsBLxf0CH+YB6U
+NSWJ04rb/R18NYntiQkvThqIgGgBT4SJN7A1CHdIXBHKzimD+tRK3oQtu5Ctyh4v
+mKFHJJFXdhReaSYHQJTxdusxiyIJ90ONDbHRHkNePz0rReBRQ24WjHMkDf9hPW7k
+SzlHU4vfQ2xYDlwQ+rCE48kqp+xuhNL18OQK3fdreJGCS2zTc7xl+MQ07sb6/XU+
+KdbOAyDQbfYJ6CcUx3n+2KZBQqZ9SYw2/PtKfXdvYz9oAJ47sMrt0SVDGdzeXhRO
+15Tb3s+7a5cJZTCFCZVU
+=dW3N
+-----END PGP SIGNATURE-----

Added: dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.zip.md5
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.zip.md5 (added)
+++ dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-0.6.0-bin.zip.md5 Wed Mar 30 04:59:04 2016
@@ -0,0 +1 @@
+fef531149bec237940d91bf4e17c5dd7

Added: dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-installer-config.xml
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-installer-config.xml (added)
+++ dev/flex/flexjs/0.6.0/rc2/binaries/apache-flex-flexjs-installer-config.xml Wed Mar 30 04:59:04 2016
@@ -0,0 +1,265 @@
+<?xml version="1.0"?>
+<!--
+
+  Licensed to the Apache Software Foundation (ASF) under one or more
+  contributor license agreements.  See the NOTICE file distributed with
+  this work for additional information regarding copyright ownership.
+  The ASF licenses this file to You under the Apache License, Version 2.0
+  (the "License"); you may not use this file except in compliance with
+  the License.  You may obtain a copy of the License at
+
+      http://www.apache.org/licenses/LICENSE-2.0
+
+  Unless required by applicable law or agreed to in writing, software
+  distributed under the License is distributed on an "AS IS" BASIS,
+  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+  See the License for the specific language governing permissions and
+  limitations under the License.
+
+-->
+
+<config>
+	<!--
+	<progressLabels>
+
+		<en_US>
+
+			<Copy>Copying %1 of %2</Copy>
+
+			<Get>Downloading bytes %1 of %2</Get>
+
+			<Checksum>Computing checksum: bytes %1 of %2</Checksum>
+		</en_US>
+	</progressLabels>
+
+	-->
+	<properties>
+
+	</properties>
+	<strings description="override default installer strings here">
+		<string id="INFO_CREATING_FLEX_HOME">
+			<el_GR>Δημιουργία αρχικού καταλόγου για το Apache FlexJS</el_GR>
+			<en_US>Creating Apache FlexJS home</en_US>
+			<zh_CN>正在创建 Apache FlexJS 主目录</zh_CN>
+			<zh_TW>正在創建 Apache FlexJS 主目錄</zh_TW>
+		</string>
+		<string id="INFO_DOWNLOADING_FLEX_SDK">
+			<el_GR>Γίνεται λήψη του Apache FlexJS από:</el_GR>
+			<en_US>Downloading Apache FlexJS from: </en_US>
+			<zh_CN>正在下载 Apache FlexJS: </zh_CN>
+			<zh_TW>正在下載 Apache FlexJS: </zh_TW>
+		</string>
+		<string id="INFO_ENTER_VALID_FLEX_SDK_PATH">
+			<el_GR>Παρακαλώ εισάγετε μια έγκυρη διαδρομή καταλόγου για το FlexJS</el_GR>
+			<en_US>Please enter valid directory path for the FlexJS SDK</en_US>
+			<zh_CN>请为 FlexJS SDK 输入有效的目录路径</zh_CN>
+			<zh_TW>請為 FlexJS SDK 輸入有效的目錄路徑</zh_TW>
+		</string>
+		<string id="INFO_SELECT_DIRECTORY">
+			<el_GR>Επιλέξτε τον κατάλογο στον οποίο θέλετε να εγκαταστήσετε το FlexJS</el_GR>
+			<en_US>Select the directory where you want to install the FlexJS files</en_US>
+			<zh_CN>请选择您想要安装 FlexJS 文件的目录</zh_CN>
+			<zh_TW>請選擇您想要安裝 FlexJS 檔案的目錄</zh_TW>
+		</string>
+		<string id="INFO_VERIFY_FLEX_SDK_DONE">
+			<el_GR>Η επαλήθευση των ληφθέντων αρχείων είναι επιτυχής.</el_GR>
+			<en_US>The Apache FlexJS MD5 Signature of the downloaded files matches the reference. The file is valid.</en_US>
+			<zh_CN>所下载文件的 MD5 签名和 Apache FlexJS 的官方签名一致, 此文件有效.</zh_CN>
+			<zh_TW>所下載檔案的 MD5 簽名和 Apache FlexJS 的官方簽名一致, 此檔案有效.</zh_TW>
+		</string>
+		<string id="SELECT_PATH_PROMPT">
+			<el_GR>Πληκτρολογήστε η επιλέξτε μια έγκυρη διαδρομή για το FlexJS SDK</el_GR>
+			<en_US>Where do you want to install the Apache FlexJS SDK?</en_US>
+			<zh_CN>您想在哪里安装 Apache FlexJS SDK?</zh_CN>
+			<zh_TW>您想在哪裡安裝 Apache FlexJS SDK?</zh_TW>
+		</string>
+		<string id="ERROR_VERIFY_FLEX_SDK">
+			<el_GR>Η επαλήθευση των ληφθέντων αρχείων απέτυχε. Η εγκατάσταση σταμάτησε.</el_GR>
+			<en_US>The Apache FlexJS MD5 Signature of the downloaded files does not match the reference value. The file is invalid, installation is aborted.</en_US>
+			<zh_CN>所下载文件的 MD5 签名和 Apache FlexJS 的官方签名不一致, 此文件无效, 安装中止.</zh_CN>
+			<zh_TW>所下載檔案的 MD5 簽名和 Apache FlexJS 的官方簽名不一致, 此檔案無效, 安裝中止.</zh_TW>
+		</string>
+		<string id="BTN_LABEL_OPEN_APACHE_FLEX_FOLDER">
+			<el_GR>ΑΝΟΙΓΜΑ ΦΑΚΕΛΟΥ APACHE FLEXJS</el_GR>
+			<en_US>OPEN APACHE FLEXJS FOLDER</en_US>
+			<zh_CN>打开 Apache FlexJS 目录</zh_CN>
+			<zh_TW>打開 Apache FlexJS 目錄</zh_TW>
+		</string>
+		<string id="STEP_REQUIRED_INSTALL_APACHE_FLEX_SDK">
+			<el_GR>Λήψη Apache FlexJS SDK</el_GR>
+			<en_US>Apache FlexJS SDK (Required)</en_US>
+			<zh_CN>Apache FlexJS SDK (必须的)</zh_CN>
+			<zh_TW>Apache FlexJS SDK (必須的)</zh_TW>
+		</string>
+		<string id="STEP_VERIFY_FLEX_SDK">
+			<el_GR>Γίνεται επαλήθευση του Apache Flex SDK MD5 Signature</el_GR>
+			<en_US>Verifying Apache FlexJS MD5 Signature</en_US>
+			<zh_CN>正在检查 Apache FlexJS 的 MD5 签名</zh_CN>
+			<zh_TW>正在檢查 Apache FlexJS 的 MD5 簽名</zh_TW>
+		</string>
+		<string id="STEP_UNZIP_FLEX_SDK">
+			<el_GR>Αποσυμπίεση του Apache Flex SDK</el_GR>
+			<en_US>Uncompress Apache FlexJS SDK</en_US>
+			<zh_CN>解压 Apache FlexJS SDK</zh_CN>
+			<zh_TW>解壓 Apache FlexJS SDK</zh_TW>
+		</string>
+	</strings>
+	<steps description="targets that should have a 'step' in the GUI progress indicator, in order of appearance.">
+		<step id="falcon-get">
+			<el_GR>Λήψη Apache Flex Falcon SDK</el_GR>
+			<en_US>Apache Flex Falcon SDK (Required)</en_US>
+			<zh_CN>Apache Flex Falcon SDK (必须的)</zh_CN>
+			<zh_TW>Apache Flex Falcon SDK (必須的)</zh_TW>
+		</step>
+		<step id="get-falcon">
+			<el_GR>Αποσυμπίεση του Apache Flex Falcon SDK</el_GR>
+			<en_US>Uncompress Apache Flex Falcon SDK</en_US>
+			<zh_CN>解压 Apache Flex Falcon SDK</zh_CN>
+			<zh_TW>解壓 Apache Flex Falcon SDK</zh_TW>
+		</step>
+		<step id="download">
+			<el_GR></el_GR>
+			<en_US>Download Falcon dependencies</en_US>
+			<zh_CN>下载 Falcon 所需组件</zh_CN>
+			<zh_TW>下載 Falcon 所需組件</zh_TW>
+		</step>
+		<step id="copyfiles">
+			<el_GR></el_GR>
+			<en_US>Copy Falcon SDK files</en_US>
+			<zh_CN>拷贝 Falcon SDK 文件</zh_CN>
+			<zh_TW>拷貝 Falcon SDK 檔案</zh_TW>
+		</step>
+		<step id="download.jx">
+			<en_US>Download FalconJX Dependencies</en_US>
+			<zh_CN>下载 FalconJX 所需组件</zh_CN>
+			<zh_TW>下載 FalconJX 所需組件</zh_TW>
+		</step>
+		<step id="copyfiles.jx">
+			<el_GR></el_GR>
+			<en_US>Copy FalconJX SDK files</en_US>
+			<zh_CN>拷贝 FalconJX SDK 文件</zh_CN>
+			<zh_TW>拷貝 FalconJX SDK 檔案</zh_TW>
+		</step>
+        <step id="air-download" property="do.air.install">
+			<el_GR>Αποσυμπίεση του Adobe AIR Runtime Kit</el_GR>
+			<en_US>Adobe AIR SDK (Required)</en_US>
+			<zh_CN>Adobe AIR SDK (必须的)</zh_CN>
+			<zh_TW>Adobe AIR SDK (必須的)</zh_TW>
+		</step>
+		<step id="flash-download" property="do.flash.install">
+			<el_GR>Λήψη Flash Player swc</el_GR>
+			<en_US>Adobe Flash Player playerglobal.swc (Required)</en_US>
+			<zh_CN>Adobe Flash Player playerglobal.swc (必须的)</zh_CN>
+			<zh_TW>Adobe Flash Player playerglobal.swc (必須的)</zh_TW>
+		</step>
+        <step id="flat-download" property="do.flat.install">
+            <el_GR>DesignModo fonts</el_GR>
+            <en_US>DesignModo fonts (Optional)</en_US>
+            <zh_CN>DesignModo fonts (必须的)</zh_CN>
+            <zh_TW>DesignModo fonts (必須的)</zh_TW>
+        </step>
+		<step id="swfobject-download">
+			<el_GR>SWFObject (Απαιτούμενο)</el_GR>
+			<en_US>SWFObject (Required)</en_US>
+			<zh_CN>SWFObject (必须的)</zh_CN>
+			<zh_TW>SWFObject (必須的)</zh_TW>
+		</step>
+		<step id="fixup-config-files">
+			<el_GR>Εγκατάσταση των αρχείων ρυθμίσεων του Framework</el_GR>
+			<en_US>Install Framework Configuration Files</en_US>
+			<zh_CN>安装框架配置文件</zh_CN>
+			<zh_TW>安裝框架設定檔案</zh_TW>
+		</step>
+	</steps>
+	<component id="STEP_REQUIRED_INSTALL_APACHE_FLEXJS" required="true" property="do.flexjs.install">
+		<el_GR>
+			<label>Apache FlexJS (Απαιτούμενο)</label>
+			<message>Για το Apache FlexJS ισχύει η συμφωνία χρήσης του Apache License V2. Θέλετε να εγκαταστήσετε το Apache FlexJS;</message>
+		</el_GR>
+		<en_US>
+			<label>Apache FlexJS (Required)</label>
+			<message>The Apache License V2 applies to the Apache FlexJS.  Do you want to install the Apache FlexJS?</message>
+			<license>Apache V2 License</license>
+			<licenseURL>http://www.apache.org/licenses/LICENSE-2.0.html</licenseURL>
+		</en_US>
+		<zh_CN>
+			<label>Apache FlexJS (必须的)</label>
+			<message>Apache V2 许可协议适用于 Apache FlexJS. 您想要安装 Apache FlexJS 吗?</message>
+			<license>Apache V2 许可协议</license>
+		</zh_CN>
+		<zh_TW>
+			<label>Apache FlexJS (必須的)</label>
+			<message>Apache V2 授權合約適用於 Apache FlexJS. 您想要安裝 Apache FlexJS 嗎?</message>
+			<license>Apache V2 授權合約</license>
+		</zh_TW>
+	</component>
+	<component id="STEP_REQUIRED_INSTALL_ADOBE_AIR_SDK" required="true" property="do.air.install">
+		<el_GR>
+			<label>Adobe AIR SDK (Απαιτούμενο)</label>
+			<message>Για το Adobe AIR SDK ισχύει η συμφωνία χρήσης του Adobe SDK License. Θέλετε να εγκαταστήσετε το Adobe AIR SDK;</message>
+			<license>'Αδεια χρήσης Adobe AIR SDK</license>
+		</el_GR>
+		<en_US>
+			<label>Adobe AIR SDK (Required)</label>
+			<message>The Adobe SDK license agreement applies to the Adobe AIR SDK.  Do you want to install the Adobe AIR SDK?</message>
+			<license>Adobe AIR SDK License</license>
+			<licenseURL>http://www.adobe.com/products/air/sdk-eula.html</licenseURL>
+		</en_US>
+		<zh_CN>
+			<label>Adobe AIR SDK (必须的)</label>
+			<message>Adobe SDK 许可协议适用于 Adobe AIR SDK. 您想要安装 Adobe AIR SDK 吗?</message>
+			<license>Adobe AIR SDK 许可协议</license>
+		</zh_CN>
+		<zh_TW>
+			<label>Adobe AIR SDK (必須的)</label>
+			<message>Adobe SDK 授權合約適用於 Adobe AIR SDK. 您想要安裝 Adobe AIR SDK 嗎?</message>
+			<license>Adobe AIR SDK 授權合約</license>
+		</zh_TW>
+	</component>
+	<component id="STEP_REQUIRED_INSTALL_FLASH_PLAYER_GLOBAL_SWC" required="true" property="do.flash.install">
+		<el_GR>
+			<label>Adobe Flash Player playerglobal.swc (Απαιτούμενο)</label>
+			<message>Για το Adobe Flash Player playerglobal.swc ισχύει η συμφωνία χρήσης του Adobe SDK License. Θέλετε να εγκαταστήσετε το Adobe Flash Player playerglobal.swc;</message>
+			<license>'Αδεια χρήσης Adobe Flex SDK</license>
+		</el_GR>
+		<en_US>
+			<label>Adobe Flash Player playerglobal.swc (Required)</label>
+			<message>The Adobe SDK license agreement applies to the Adobe Flash Player playerglobal.swc.  Do you want to install the Adobe Flash Player playerglobal.swc?</message>
+			<license>Adobe Flex SDK License</license>
+			<licenseURL>http://www.adobe.com/products/eulas/pdfs/adobe_flex_software_development_kit-combined-20110916_0930.pdf</licenseURL>
+		</en_US>
+		<zh_CN>
+			<label>Adobe Flash Player playerglobal.swc (必须的)</label>
+			<message>Adobe SDK 许可协议适用于 Adobe Flash Player 的 playerglobal.swc 文件. 您想要安装 Adobe Flash Player 的 playerglobal.swc 文件吗?</message>
+			<license>Adobe Flex SDK 许可协议</license>
+		</zh_CN>
+		<zh_TW>
+			<label>Adobe Flash Player playerglobal.swc (必須的)</label>
+			<message>Adobe SDK 授權合約適用於 Adobe Flash Player 的 playerglobal.swc 檔案. 您想要安裝 Adobe Flash Player 的 playerglobal.swc 檔案嗎?</message>
+			<license>Adobe Flex SDK 授權合約</license>
+		</zh_TW>
+	</component>
+    <component id="STEP_REQUIRED_INSTALL_FLAT_FONTS" required="false" property="do.flat.install">
+        <el_GR>
+            <label>designmodo fonts (Προαιρετικό)</label>
+            <message>Για το designmodo fonts ισχύει η συμφωνία χρήσης του CC-BY-NC-ND License. Θέλετε να εγκαταστήσετε το designmodo fonts;</message>
+            <license>'Αδεια χρήσης CC-BY-NC-ND</license>
+        </el_GR>
+        <en_US>
+            <label>designmodo fonts (Optional)</label>
+            <message>The CC-BY-NC-ND license applies to the designmodo fonts.  Do you want to install the designmodo fonts?</message>
+            <license>CC-BY-NC-ND</license>
+            <licenseURL>http://creativecommons.org/licenses/by-nc-nd/3.0/</licenseURL>
+        </en_US>
+        <zh_CN>
+            <label>designmodo (必须的)</label>
+            <message>CC-BY-NC-ND 许可协议适用于 designmodo 的 fonts 文件. 您想要安装 designmodo 的 fonts 文件吗?</message>
+            <license>C-BY-NC-ND 许可协议</license>
+        </zh_CN>
+        <zh_TW>
+            <label>designmodo fonts(必須的)</label>
+            <message>CC-BY-NC-ND 授權合約適用於 designmodo 的 fonts 檔案. 您想要安裝 designmodo 的 fonts 檔案嗎?</message>
+            <license>CC-BY-NC-ND 授權合約</license>
+        </zh_TW>
+    </component>
+</config>
\ No newline at end of file

Added: dev/flex/flexjs/0.6.0/rc2/doc/apache-flex-flexjs-0.6.0-asdocs.zip
==============================================================================
Binary file - no diff available.

Propchange: dev/flex/flexjs/0.6.0/rc2/doc/apache-flex-flexjs-0.6.0-asdocs.zip
------------------------------------------------------------------------------
    svn:mime-type = application/octet-stream

Added: dev/flex/flexjs/0.6.0/rc2/doc/apache-flex-flexjs-0.6.0-asdocs.zip.asc
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/doc/apache-flex-flexjs-0.6.0-asdocs.zip.asc (added)
+++ dev/flex/flexjs/0.6.0/rc2/doc/apache-flex-flexjs-0.6.0-asdocs.zip.asc Wed Mar 30 04:59:04 2016
@@ -0,0 +1,18 @@
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG/MacGPG2 v2
+Comment: GPGTools - http://gpgtools.org
+
+iQIcBAABCAAGBQJW+10BAAoJEIPgQxzanM/y1GIP/1sZ+SKNaFEabXg/LWnuITXr
+nVWYolJl7PvUodqVgZlYbjjxcZnUxhaEZD7acDw0Zu6x4gY3IuKXdIInhyYBZ/nJ
+s8Gp8hN9Ez95i2fgnN9E0wahFdCpPEr1wzfw2EPlSRrLy8HHzgn7zRtShi7QUNlP
+hK+KVRuNzrVE9f16/RTUwwndyia1azziv55+mjL87TB3/KoBvVsJnSyj8fR32OLd
++eGxZPyxdYG65GMXOffeZHROTbZ/gWEggN74jnD9huRFXtrYXMZZilcKEx+7CIz2
+OLOrlNgf/oZKFsM26GNYBPN07PWakTMS+hhZtJ+FeUIB3cklkYdlcj/Cqpw24rgv
+yAh2hXlRcwKTAHva4qbpoZRd1tIw8eXwrGvvzF/Qz/uSamCmTLGLOoxut7M5DcLz
+ac8Rz/vykYTzYFjH8iquOYVPJtvrjVTaO4/p9k5A9m2eO+NvBqjSls+fWNhgGzx2
+e6TE0/R90JvZBA0ajkj2CLwkhu3sBVQgo5s+RW1Mef2mYVNDTO6XoJypmDqiBAUf
+VEfijyucpzeuXCm8TBZ6tmQp+aYaykgHASkporkXmnDO6ZDmPDBaMRyjmhrticeB
+ygd2IME3t5mLDjdXLtDjs0h6o2iczQXx2EVR56uH3ar5n8m4WdcVcCKlfkys/Bau
+Y4CXHhoY2ClwQSICrkGX
+=FoKq
+-----END PGP SIGNATURE-----

Added: dev/flex/flexjs/0.6.0/rc2/doc/apache-flex-flexjs-0.6.0-asdocs.zip.md5
==============================================================================
--- dev/flex/flexjs/0.6.0/rc2/doc/apache-flex-flexjs-0.6.0-asdocs.zip.md5 (added)
+++ dev/flex/flexjs/0.6.0/rc2/doc/apache-flex-flexjs-0.6.0-asdocs.zip.md5 Wed Mar 30 04:59:04 2016
@@ -0,0 +1 @@
+5dc5382b16f9e74e63864741cb05cb49



Mime
View raw message