flex-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aha...@apache.org
Subject [2/2] git commit: [flex-utilities] [refs/heads/develop] - updates to notice files
Date Tue, 04 Mar 2014 05:46:38 GMT
updates to notice files


Project: http://git-wip-us.apache.org/repos/asf/flex-utilities/repo
Commit: http://git-wip-us.apache.org/repos/asf/flex-utilities/commit/c6d5523e
Tree: http://git-wip-us.apache.org/repos/asf/flex-utilities/tree/c6d5523e
Diff: http://git-wip-us.apache.org/repos/asf/flex-utilities/diff/c6d5523e

Branch: refs/heads/develop
Commit: c6d5523e0682cdceb855311b716862dbdb7bfaab
Parents: a82bf1e
Author: Alex Harui <aharui@apache.org>
Authored: Mon Mar 3 21:46:20 2014 -0800
Committer: Alex Harui <aharui@apache.org>
Committed: Mon Mar 3 21:46:20 2014 -0800

----------------------------------------------------------------------
 installer/NOTICE        |  2 +-
 installer/README        |  8 +++++++-
 installer/RELEASE_NOTES | 25 +++++++++++++++++--------
 3 files changed, 25 insertions(+), 10 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/flex-utilities/blob/c6d5523e/installer/NOTICE
----------------------------------------------------------------------
diff --git a/installer/NOTICE b/installer/NOTICE
index 2ffe2e4..a272b53 100644
--- a/installer/NOTICE
+++ b/installer/NOTICE
@@ -1,5 +1,5 @@
 Apache Flex
-Copyright 2013 The Apache Software Foundation
+Copyright 2014 The Apache Software Foundation
 
 This product includes software developed at
 The Apache Software Foundation (http://www.apache.org/).

http://git-wip-us.apache.org/repos/asf/flex-utilities/blob/c6d5523e/installer/README
----------------------------------------------------------------------
diff --git a/installer/README b/installer/README
index 1cbd81c..7051f4a 100644
--- a/installer/README
+++ b/installer/README
@@ -83,7 +83,7 @@ Overview:
   command line mode with the optional command line parameter: -config=<path to config
file>
 
 - If building the app for Linux, open InstallApacheFlex-app.xml and change the Adobe AIR

-  namespace from http://ns.adobe.com/air/application/3.4 to 
+  namespace from http://ns.adobe.com/air/application/4.0 to 
   http://ns.adobe.com/air/application/2.6  This is because AIR 2.6 is the latest available

   version on Linux.  
 	
@@ -91,6 +91,12 @@ Overview:
 How to build the installer using ANT (no Flash Builder or any other IDE required):
 ==========================================================================================
 
+0.  Make sure you have the right version of the Adobe AIR SDK.  Apache Flex Installer
+    3.0 uses Adobe AIR SDK 4.0.  If you want to use an older version of the AIR SDK,
+    you will have to change the namespace in the following files:
+	installer/src/InstallApacheFlex-app.xml
+	ant_on_air/tests/AntOnAIR-app.xml.
+
 1.  Unzip the source distribution.  You should see the 'installer' directory and the 
     'common' and 'ant_on_air' directories in the root.
 

http://git-wip-us.apache.org/repos/asf/flex-utilities/blob/c6d5523e/installer/RELEASE_NOTES
----------------------------------------------------------------------
diff --git a/installer/RELEASE_NOTES b/installer/RELEASE_NOTES
index a5412c4..2aa3108 100644
--- a/installer/RELEASE_NOTES
+++ b/installer/RELEASE_NOTES
@@ -26,7 +26,7 @@ Apache Flex SDK Installer 3.0
 
 Apache Flex SDK Installer 2.7
 1. Added support for OSMF2.0 [http://blogs.adobe.com/osmf/2012/03/osmf-2-0-now-available.html]
-	From Apache Flex 4.11.0 onwards, support for OSMF2.0 has been added.  
+   From Apache Flex 4.11.0 onwards, support for OSMF2.0 has been added.  
 2. The osmf.swf RSL now gets generated by the Installer.  
 
 Apache Flex SDK Installer 2.6
@@ -43,21 +43,30 @@ Here is a list of significant issues that were fixed with this release:
 4.  French and Dutch language locale fixes.
 5.  Added the SDK version number to be downloaded in the window title.
 6.  https://issues.apache.org/jira/browse/FLEX-33202 (more issues).
-7.  https://issues.apache.org/jira/browse/FLEX-33419 (added germain language).
+7.  https://issues.apache.org/jira/browse/FLEX-33419 (added german language).
 
 
 Apache Flex SDK Installer 2.0
-1.  If you have previously installed a release candidate (RC) version of  Apache Flex SDK
Installer, you need to uninstall it first.  And then run the downloaded installer file.
-2.  From Flex 4.9 onwards, the Text Layout Framework (TLF) is part of the Flex SDK.  So the
installer does not download it separately anymore.
-3.  By default, Apache Flex SDK Installer 2.0 downloads Adobe Flash Player 11.1 and Adobe
AIR SDK 3.4.  If you want to change it to any other supported combination, save a copy
-	of the config file found at: http://incubator.apache.org/flex/sdk-installer-config-2.0.xml,
modify the download urls to point to the required versions.  Then run the app from command
-	line mode with the optional command line parameter: -config=<path to config file>.
 The new urls will be used to download the required dependencies.
+1.  If you have previously installed a release candidate (RC) version of
+    Apache Flex SDK Installer, you need to uninstall it first.  
+    And then run the downloaded installer file.
+2.  From Flex 4.9 onwards, the Text Layout Framework (TLF) is part of the Flex SDK.  
+    So the installer does not download it separately anymore.
+3.  By default, Apache Flex SDK Installer 2.0 downloads Adobe Flash Player 11.1 
+    and Adobe AIR SDK 3.4.  If you want to change it to any other supported 
+    combination, save a copy of the config file found at: 
+       http://incubator.apache.org/flex/sdk-installer-config-2.0.xml, 
+    modify the download urls to point to the required versions.  Then run the app 
+    from command line mode with the optional command line parameter:
+	 -config=<path to config file>.  
+    The new urls will be used to download the required dependencies.
 
 Issues addressed in this release:
 Here is a list of significant issues that were fixed with this release:
 1.  https://issues.apache.org/jira/browse/FLEX-33214 (Fix UI of license screen)
 2.  https://issues.apache.org/jira/browse/FLEX-33122 (Enable language switching)
-	Available languages: English(US), English(AU), English(GB), Español (ES), Français, Greek,
Nederlands and Português
+    Available languages: English(US), English(AU), English(GB), Español (ES), 
+                         Français, Greek, Nederlands and Português
 
 Apache Flex Installer SDK 1.0
 


Mime
View raw message