flex-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jmcl...@apache.org
Subject [24/50] git commit: [flex-sdk] [refs/heads/master] - Updated with the release of FP 11.9 and AIR 3.9
Date Mon, 21 Oct 2013 22:37:16 GMT
Updated with the release of FP 11.9 and AIR 3.9


Project: http://git-wip-us.apache.org/repos/asf/flex-sdk/repo
Commit: http://git-wip-us.apache.org/repos/asf/flex-sdk/commit/922b10dd
Tree: http://git-wip-us.apache.org/repos/asf/flex-sdk/tree/922b10dd
Diff: http://git-wip-us.apache.org/repos/asf/flex-sdk/diff/922b10dd

Branch: refs/heads/master
Commit: 922b10dd6c34fb47010fbea6ea1cd66723f45a89
Parents: cb64e35
Author: Justin Mclean <jmclean@apache.org>
Authored: Sat Oct 12 08:32:30 2013 +1100
Committer: Justin Mclean <jmclean@apache.org>
Committed: Sat Oct 12 08:32:30 2013 +1100

----------------------------------------------------------------------
 README                                   | 24 ++++++++++++------------
 RELEASE_NOTES                            |  4 ++--
 ide/addAIRtoSDK.sh                       |  5 -----
 ide/checkAllPlayerGlobals.sh             |  2 +-
 ide/flashbuilder/makeApacheFlexForIDE.sh |  4 ++--
 jenkins.xml                              |  2 +-
 6 files changed, 18 insertions(+), 23 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/flex-sdk/blob/922b10dd/README
----------------------------------------------------------------------
diff --git a/README b/README
index 2ed02f9..eca4ce0 100644
--- a/README
+++ b/README
@@ -166,15 +166,15 @@ Install Prerequisites
          you will get compile errors.
         
     *3) The Adobe AIR integration kit for Windows can be downloaded from:
-           http://airdownload.adobe.com/air/win/download/3.8/AdobeAIRSDK.zip
+           http://airdownload.adobe.com/air/win/download/3.9/AdobeAIRSDK.zip
         
          The Adobe AIR integration kit for Mac can be downloaded from:
-            http://airdownload.adobe.com/air/mac/download/3.8/AdobeAIRSDK.tbz2
+            http://airdownload.adobe.com/air/mac/download/3.9/AdobeAIRSDK.tbz2
             
           The Adobe AIR integration kit for Linux can be downloaded from:
             http://airdownload.adobe.com/air/lin/download/2.6/AdobeAIRSDK.tbz2        
 
-        This version of Apache Flex was certified for use with AIR 3.8, and should
+        This version of Apache Flex was certified for use with AIR 3.9, and should
         be compatible with other versions of AIR newer than 3.1. However it hasn't
         been fully tested on AIR 3.2, 3.3, 3.5, 3.6 or 3.7.
 
@@ -185,8 +185,8 @@ Install Prerequisites
             http://www.adobe.com/support/flashplayer/downloads.html
 
         This version of Apache Flex was certified for use with Adobe Flash Player 11.1,
-        and is compatible with versions 10.2 through 11.9 beta. It has been tested with
-        versions 11.1, 11.7, 11.8 and 11.9 beta on Windows and Mac. It has been compiled
+        and is compatible with versions 10.2 through 11.9. It has been tested with
+        versions 11.1, 11.7, 11.8 and 11.9 on Windows and Mac. It has been compiled
         against other Adobe Flash Player versions but has not been fully tested. It has
         not been fully tested on Linux.
             
@@ -234,7 +234,7 @@ Install Prerequisites
             http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_6.swc
             http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_7.swc
             http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_8.swc
-            http://labsdownload.adobe.com/pub/labs/flashruntimes/flashplayer/flashplayer11-9_playerglobal.swc
+            http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_9.swc
             
         These can be used with Apache Flex but have not been fully tested.
         
@@ -305,7 +305,7 @@ Adobe Flash Player Version Support
 
     The Apache Flex SDK defaults to using the Adobe Flash Player 11.1. The SDK can be
     used with Flash Player versions 10.2, 10.3, 11.0, 11.1, 11.2, 11.3, 11.4, 11.5,
-    11.6, 11.7, 11.8 and 11.9 beta.
+    11.6, 11.7, 11.8 and 11.9.
     
     It is recommended that you update to the latest version of Adobe Flash Player.
     Newer versions of the Adobe Flash player address security vulnerabilities, fix
@@ -347,8 +347,8 @@ Adobe Flash Player Version Support
     http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_6.swc
     http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_7.swc
     http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_8.swc
-    http://labsdownload.adobe.com/pub/labs/flashruntimes/flashplayer/flashplayer11-9_playerglobal.swc
-    
+    http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_9.swc
+     
     Copy the target playerglobal.swc to the directory:
     
         frameworks/libs/player/<version>/playerglobal.swc
@@ -388,7 +388,7 @@ Adobe Flash Player Version Support
                          /playerglobal.swc  
     
     Apache Flex has been tested with Adobe Flash Player 11.1, 11.5, 11.7, 11.8 and
-    11.9 beta on Windows and Mac.
+    11.9 on Windows and Mac.
     
     Apache Flex has not been tested on Linux so some issue may exist in this release.
     
@@ -483,14 +483,14 @@ Using the Binary Distribution
 	This will create an Apache Flex 4.11 SDK that can be used with Flash Builder by
 	copying the required files from the Adobe Flex 4.6 SDK.
 	
-	To create an SDK for other IDE or if you want to use Adobe AIR 3.8 (rather than
+	To create an SDK for other IDE or if you want to use Adobe AIR 3.9 (rather than
 	AIR 3.1 contained in Adobe Flex 4.6) run:
 	
 		/ide/flashbuilder/makeApacheFlexForIDE.sh (on Mac and Linux)
 		/ide/flashbuilder/makeApacheFlexForIDE.bat (on Windows)
 		
 	This will create an Apache Flex 4.11 SDK that can be used by an IDE by downloading
-	Adobe Flex 4.6 SDK and Adobe AIR 3.8.
+	Adobe Flex 4.6 SDK and Adobe AIR 3.9.
     
 Building the Framework in a Binary Distribution
 -----------------------------------------------

http://git-wip-us.apache.org/repos/asf/flex-sdk/blob/922b10dd/RELEASE_NOTES
----------------------------------------------------------------------
diff --git a/RELEASE_NOTES b/RELEASE_NOTES
index 59480cc..05b6ff3 100644
--- a/RELEASE_NOTES
+++ b/RELEASE_NOTES
@@ -31,8 +31,8 @@ Differences from Apache Flex 4.9 include:
 
 AIR and Flash Player support
 ------------------------------
- - Support Flash Player 11.9 beta.
- - Support for AIR 3.9 beta.
+ - Support Flash Player 11.9.
+ - Support for AIR 3.9.
 
 SDK Changes
 -------------

http://git-wip-us.apache.org/repos/asf/flex-sdk/blob/922b10dd/ide/addAIRtoSDK.sh
----------------------------------------------------------------------
diff --git a/ide/addAIRtoSDK.sh b/ide/addAIRtoSDK.sh
index 67b9f77..b5174ac 100755
--- a/ide/addAIRtoSDK.sh
+++ b/ide/addAIRtoSDK.sh
@@ -103,11 +103,6 @@ downloadAIR()
         airDownload="http://airdownload.adobe.com/air/lin/download/${version}/AdobeAIRSDK.tbz2"
     fi
     
-    if [[ "${AIR_VERSION}" == "3.9" ]]
-    then
-        airDownload="http://labsdownload.adobe.com/pub/labs/flashruntimes/air/air3-9_sdk_sa_mac.tbz2"
-    fi
-    
 	echo Downloading AIR ${version}
 	curl ${airDownload} > "${airTempDir}/air.tbz2"
 	

http://git-wip-us.apache.org/repos/asf/flex-sdk/blob/922b10dd/ide/checkAllPlayerGlobals.sh
----------------------------------------------------------------------
diff --git a/ide/checkAllPlayerGlobals.sh b/ide/checkAllPlayerGlobals.sh
index 67bd613..4dd8ab5 100755
--- a/ide/checkAllPlayerGlobals.sh
+++ b/ide/checkAllPlayerGlobals.sh
@@ -119,5 +119,5 @@ downloadPlayerGlobal 11.5 00384b24157442c59ca5d625ecfd11a2 http://download.macro
 downloadPlayerGlobal 11.6 1b841a0a26ada3e5da26eb70c32ab263 http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_6.swc
 downloadPlayerGlobal 11.7 12656571c57b2ad641838e5695a00e27 http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_7.swc
 downloadPlayerGlobal 11.8 35bc69eec5091f70e221b4e63b66b60f http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_8.swc
-downloadPlayerGlobal 11.9 51694a3670a14c380b01a73907134ebc http://labsdownload.adobe.com/pub/labs/flashruntimes/flashplayer/flashplayer11-9_playerglobal.swc
+downloadPlayerGlobal 11.9 4cac2727e7b7e741075581f47c35f3af http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_9.swc
 

http://git-wip-us.apache.org/repos/asf/flex-sdk/blob/922b10dd/ide/flashbuilder/makeApacheFlexForIDE.sh
----------------------------------------------------------------------
diff --git a/ide/flashbuilder/makeApacheFlexForIDE.sh b/ide/flashbuilder/makeApacheFlexForIDE.sh
index 9c1c277..c3b096f 100755
--- a/ide/flashbuilder/makeApacheFlexForIDE.sh
+++ b/ide/flashbuilder/makeApacheFlexForIDE.sh
@@ -37,8 +37,8 @@
 # Apache Flex binary distribution
 APACHE_FLEX_BIN_DIR="$( cd $( dirname -- "$0" ) > /dev/null ; pwd )"/../..
 
-# Adobe AIR SDK Version 3.8
-ADOBE_AIR_SDK_MAC_URL=http://airdownload.adobe.com/air/mac/download/3.8/AdobeAIRSDK.tbz2
+# Adobe AIR SDK Version 3.9
+ADOBE_AIR_SDK_MAC_URL=http://airdownload.adobe.com/air/mac/download/3.9/AdobeAIRSDK.tbz2
 
 # Adobe Flash Player Version 11.1
 ADOBE_FLASHPLAYER_GLOBALPLAYER_SWC_URL=http://fpdownload.macromedia.com/get/flashplayer/updaters/11/playerglobal11_1.swc

http://git-wip-us.apache.org/repos/asf/flex-sdk/blob/922b10dd/jenkins.xml
----------------------------------------------------------------------
diff --git a/jenkins.xml b/jenkins.xml
index 8846e57..a0ec5b1 100644
--- a/jenkins.xml
+++ b/jenkins.xml
@@ -176,7 +176,7 @@
 	
     <target name="playerglobal11.9-download" if="target11.9">
     	<mkdir dir="${basedir}/lib/player/${playerglobal.version}"/>
-        <get src="http://labsdownload.adobe.com/pub/labs/flashruntimes/flashplayer/flashplayer11-9_playerglobal.swc"

+        <get src="http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_9.swc"

             dest="${basedir}/lib/player/${playerglobal.version}/playerglobal.swc" 
             verbose="false"/>
     </target>


Mime
View raw message