flex-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jmcl...@apache.org
Subject git commit: [flex-sdk] [refs/heads/develop] - Updated default version to Flash Player 11.7 and added support for Flash Player 11.8
Date Mon, 13 May 2013 14:57:53 GMT
Updated Branches:
  refs/heads/develop 188fa2d03 -> 1eaf95479


Updated default version to Flash Player 11.7 and added support for Flash Player 11.8


Project: http://git-wip-us.apache.org/repos/asf/flex-sdk/repo
Commit: http://git-wip-us.apache.org/repos/asf/flex-sdk/commit/1eaf9547
Tree: http://git-wip-us.apache.org/repos/asf/flex-sdk/tree/1eaf9547
Diff: http://git-wip-us.apache.org/repos/asf/flex-sdk/diff/1eaf9547

Branch: refs/heads/develop
Commit: 1eaf9547975f1043f20a47f1043c4efc72838e87
Parents: 188fa2d
Author: Justin Mclean <jmclean@apache.org>
Authored: Tue May 14 00:57:35 2013 +1000
Committer: Justin Mclean <jmclean@apache.org>
Committed: Tue May 14 00:57:35 2013 +1000

----------------------------------------------------------------------
 ide/setFlashPlayerVersion.sh |   19 ++++++++++++-------
 1 files changed, 12 insertions(+), 7 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/flex-sdk/blob/1eaf9547/ide/setFlashPlayerVersion.sh
----------------------------------------------------------------------
diff --git a/ide/setFlashPlayerVersion.sh b/ide/setFlashPlayerVersion.sh
index 881f414..429ae17 100755
--- a/ide/setFlashPlayerVersion.sh
+++ b/ide/setFlashPlayerVersion.sh
@@ -95,13 +95,13 @@ determineVersion()
         then 
             FLASH_VERSION="11.1"
         else
-            FLASH_VERSION="11.6"
+            FLASH_VERSION="11.7"
         fi
     fi
     
     if [ ${latest} = "Y" ]
     then
-    	FLASH_VERSION="11.6"
+    	FLASH_VERSION="11.7"
     fi
     
     echo "Setting minimum Flash Player version to ${FLASH_VERSION}"
@@ -114,9 +114,9 @@ then
 	determineVersion
 fi
 
-if [[ "${FLASH_VERSION}" != "10.2" && "${FLASH_VERSION}" != "10.3"  && "${FLASH_VERSION}"
!= "11.0"  && "${FLASH_VERSION}" != "11.1" && "${FLASH_VERSION}" != "11.2"
&& "${FLASH_VERSION}" != "11.3" && "${FLASH_VERSION}" != "11.4" &&
"${FLASH_VERSION}" != "11.5" && "${FLASH_VERSION}" != "11.6" && "${FLASH_VERSION}"
!= "11.7" ]]
+if [[ "${FLASH_VERSION}" != "10.2" && "${FLASH_VERSION}" != "10.3"  && "${FLASH_VERSION}"
!= "11.0"  && "${FLASH_VERSION}" != "11.1" && "${FLASH_VERSION}" != "11.2"
&& "${FLASH_VERSION}" != "11.3" && "${FLASH_VERSION}" != "11.4" &&
"${FLASH_VERSION}" != "11.5" && "${FLASH_VERSION}" != "11.6" && "${FLASH_VERSION}"
!= "11.7" && "${FLASH_VERSION}" != "11.8" ]]
 then
-	echo Unknown version ${FLASH_VERSION} of Flash Player. Versions 10.2, 10.3, 11.0, 11.1,
11.2, 11.3, 11.4, 11.5, 11.6 and 11.7 are supported.
+	echo Unknown version ${FLASH_VERSION} of Flash Player. Versions 10.2, 10.3, 11.0, 11.1,
11.2, 11.3, 11.4, 11.5, 11.6, 11.7 and 11.8 are supported.
 	exit 1;
 fi
 
@@ -137,9 +137,9 @@ then
 	echo Installing AIR
 	echo
 
-    if [[ $FLASH_VERSION = "11.6" ]]
+    if [[ $FLASH_VERSION = "11.7" ]]
     then
-        ./addAIRtoSDK.sh 3.6 "$IDE_SDK_DIR"
+        ./addAIRtoSDK.sh 3.7 "$IDE_SDK_DIR"
     fi
     
     if [[ $FLASH_VERSION = "11.1" ]]
@@ -189,7 +189,12 @@ do
 	echo Updating ${configFile}
 	
 	updatePlayerVersion "${FLASH_VERSION}" "${configFile}"
-		
+
+	if [ ${FLASH_VERSION} = "11.8" ]
+	then
+		updateSWFVersion 21 "${configFile}"
+	fi
+			
 	if [ ${FLASH_VERSION} = "11.7" ]
 	then
 		updateSWFVersion 20 "${configFile}"


Mime
View raw message