flex-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jmcl...@apache.org
Subject svn commit: r1445460 - in /flex/sdk/branches/develop/ide: addAIRtoSDK.sh checkAllPlayerGlobals.sh setFlashPlayerVersion.sh
Date Wed, 13 Feb 2013 02:40:55 GMT
Author: jmclean
Date: Wed Feb 13 02:40:54 2013
New Revision: 1445460

URL: http://svn.apache.org/r1445460
Log:
updated to support Flash Player 11.6 and AIR 3.6

Modified:
    flex/sdk/branches/develop/ide/addAIRtoSDK.sh
    flex/sdk/branches/develop/ide/checkAllPlayerGlobals.sh
    flex/sdk/branches/develop/ide/setFlashPlayerVersion.sh

Modified: flex/sdk/branches/develop/ide/addAIRtoSDK.sh
URL: http://svn.apache.org/viewvc/flex/sdk/branches/develop/ide/addAIRtoSDK.sh?rev=1445460&r1=1445459&r2=1445460&view=diff
==============================================================================
--- flex/sdk/branches/develop/ide/addAIRtoSDK.sh (original)
+++ flex/sdk/branches/develop/ide/addAIRtoSDK.sh Wed Feb 13 02:40:54 2013
@@ -29,9 +29,9 @@
 
 AIR_VERSION="$1"
 
-if [[ "${AIR_VERSION}" != "3.5" && "${AIR_VERSION}" != "3.4"  && "${AIR_VERSION}"
!= "3.3"  && "${AIR_VERSION}" != "3.2" && "${AIR_VERSION}" != "3.1" ]]
+if [[ "${AIR_VERSION}" != "3.6" && "${AIR_VERSION}" != "3.5" && "${AIR_VERSION}"
!= "3.4"  && "${AIR_VERSION}" != "3.3"  && "${AIR_VERSION}" != "3.2" &&
"${AIR_VERSION}" != "3.1" ]]
 then
-	echo Unknown version ${AIR_VERISON} of AIR. Versions 3.1, 3.2, 3.3, 3.4 and 3.5 are supported.
+	echo Unknown version ${AIR_VERISON} of AIR. Versions 3.1, 3.2, 3.3, 3.4, 3.5 and 3.6 are
supported.
 	exit 1;
 fi
 
@@ -91,7 +91,7 @@ downloadAIR()
 	curl ${airDownload} > "${airTempDir}/air.tbz2"
 	
 	echo Extracting into SDK  
-	tar xf "${airTempDir}/air.tbz2" -C "${IDE_SDK_DIR}/frameworks/"
+	tar xf "${airTempDir}/air.tbz2" -C "${IDE_SDK_DIR}"
 
 	rm -rf "${airTempDir}"	
 }
@@ -125,6 +125,12 @@ configFiles=(
 for configFile in "${configFiles[@]}"
 do
 	echo Updating ${configFile}
+	# 3.6 needs FP 11.6 and swf version 19
+	if [ ${AIR_VERSION} = "3.6" ]
+	then
+		updatePlayerVersion 11.6 "${configFile}"
+		updateSWFVersion 19 "${configFile}"
+	fi
 
 	# 3.5 needs FP 11.5 and swf version 18
 	if [ ${AIR_VERSION} = "3.5" ]
@@ -146,8 +152,7 @@ do
 		updatePlayerVersion 11.3 "${configFile}"
 		updateSWFVersion 16 "${configFile}"
 	fi
-	
-	
+		
 	# 3.2 needs FP 11.2 and swf version 15
 	if [ ${AIR_VERSION} = "3.2" ]
 	then

Modified: flex/sdk/branches/develop/ide/checkAllPlayerGlobals.sh
URL: http://svn.apache.org/viewvc/flex/sdk/branches/develop/ide/checkAllPlayerGlobals.sh?rev=1445460&r1=1445459&r2=1445460&view=diff
==============================================================================
--- flex/sdk/branches/develop/ide/checkAllPlayerGlobals.sh (original)
+++ flex/sdk/branches/develop/ide/checkAllPlayerGlobals.sh Wed Feb 13 02:40:54 2013
@@ -104,12 +104,13 @@ downloadPlayerGlobal()
 
 agreeLicense
 
-downloadPlayerGlobal 10.2 aa7d785dd5715626201f5e30fc1deb51 http://fpdownload.macromedia.com/get/flashplayer/installers/archive/playerglobal/playerglobal10_2.swc
-downloadPlayerGlobal 10.3 6092b3d4e2784212d174ca10904412bd http://fpdownload.macromedia.com/get/flashplayer/installers/archive/playerglobal/playerglobal10_3.swc
-downloadPlayerGlobal 11.0 5f5a291f02105cd83fb582b76646e603 http://fpdownload.macromedia.com/get/flashplayer/updaters/11/playerglobal11_0.swc
-downloadPlayerGlobal 11.1 e3a0e0e8c703ae5b1847b8ac25bbdc5f http://fpdownload.macromedia.com/get/flashplayer/updaters/11/playerglobal11_1.swc
-downloadPlayerGlobal 11.2 c544a069518897880e0d732457b6fdeb http://fpdownload.macromedia.com/get/flashplayer/updaters/11/playerglobal11_2.swc
-downloadPlayerGlobal 11.3 e2a9ee439d9660feaf756aa05e7e6412 http://fpdownload.macromedia.com/get/flashplayer/updaters/11/playerglobal11_3.swc
-downloadPlayerGlobal 11.4 e15587856cdb5e21fa1acb6b0610a032 http://fpdownload.macromedia.com/get/flashplayer/updaters/11/playerglobal11_4.swc
-downloadPlayerGlobal 11.5 54bb87668ae9d6b6e61cc61fd487b6a0 http://fpdownload.macromedia.com/get/flashplayer/updaters/11/playerglobal11_5.swc
+downloadPlayerGlobal 10.2 aa7d785dd5715626201f5e30fc1deb51 http://download.macromedia.com/get/flashplayer/installers/archive/playerglobal/playerglobal10_2.swc
+downloadPlayerGlobal 10.3 6092b3d4e2784212d174ca10904412bd http://download.macromedia.com/get/flashplayer/installers/archive/playerglobal/playerglobal10_3.swc
+downloadPlayerGlobal 11.0 5f5a291f02105cd83fb582b76646e603 http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_0.swc
+downloadPlayerGlobal 11.1 e3a0e0e8c703ae5b1847b8ac25bbdc5f http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_1.swc
+downloadPlayerGlobal 11.2 c544a069518897880e0d732457b6fdeb http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_2.swc
+downloadPlayerGlobal 11.3 e2a9ee439d9660feaf756aa05e7e6412 http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_3.swc
+downloadPlayerGlobal 11.4 e15587856cdb5e21fa1acb6b0610a032 http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_4.swc
+downloadPlayerGlobal 11.5 54bb87668ae9d6b6e61cc61fd487b6a0 http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_5.swc
+downloadPlayerGlobal 11.6 5d41f7a3a61da52a66bb46a4844c7914 http://download.macromedia.com/get/flashplayer/updaters/11/playerglobal11_6.swc
 

Modified: flex/sdk/branches/develop/ide/setFlashPlayerVersion.sh
URL: http://svn.apache.org/viewvc/flex/sdk/branches/develop/ide/setFlashPlayerVersion.sh?rev=1445460&r1=1445459&r2=1445460&view=diff
==============================================================================
--- flex/sdk/branches/develop/ide/setFlashPlayerVersion.sh (original)
+++ flex/sdk/branches/develop/ide/setFlashPlayerVersion.sh Wed Feb 13 02:40:54 2013
@@ -95,13 +95,13 @@ determineVersion()
         then 
             FLASH_VERSION="11.1"
         else
-            FLASH_VERSION="11.5"
+            FLASH_VERSION="11.6"
         fi
     fi
     
     if [ ${latest} = "Y" ]
     then
-    	FLASH_VERSION="11.5"
+    	FLASH_VERSION="11.6"
     fi
     
     echo "Setting minimum Flash Player version to ${FLASH_VERSION}"
@@ -114,9 +114,9 @@ then
 	determineVersion
 fi
 
-if [[ "${FLASH_VERSION}" != "10.2" && "${FLASH_VERSION}" != "10.2"  && "${FLASH_VERSION}"
!= "11.0"  && "${FLASH_VERSION}" != "11.1" && "${FLASH_VERSION}" != "11.2"
&& "${FLASH_VERSION}" != "11.3" && "${FLASH_VERSION}" != "11.4" &&
"${FLASH_VERSION}" != "11.5" ]]
+if [[ "${FLASH_VERSION}" != "10.2" && "${FLASH_VERSION}" != "10.2"  && "${FLASH_VERSION}"
!= "11.0"  && "${FLASH_VERSION}" != "11.1" && "${FLASH_VERSION}" != "11.2"
&& "${FLASH_VERSION}" != "11.3" && "${FLASH_VERSION}" != "11.4" &&
"${FLASH_VERSION}" != "11.5" && "${FLASH_VERSION}" != "11.6" ]]
 then
-	echo Unknown version ${FLASH_VERSION} of Flash Player. Versions 10.2, 10.3, 11.0, 11.1,
11.2, 11.3, 11.4 and 11.5 are supported.
+	echo Unknown version ${FLASH_VERSION} of Flash Player. Versions 10.2, 10.3, 11.0, 11.1,
11.2, 11.3, 11.4, 11.5 and 11.6 are supported.
 	exit 1;
 fi
 
@@ -137,9 +137,9 @@ then
 	echo Installing AIR
 	echo
 
-    if [[ $FLASH_VERSION = "11.5" ]]
+    if [[ $FLASH_VERSION = "11.6" ]]
     then
-        ./addAIRtoSDK.sh 3.5 "$IDE_SDK_DIR"
+        ./addAIRtoSDK.sh 3.6 "$IDE_SDK_DIR"
     fi
     
     if [[ $FLASH_VERSION = "11.1" ]]
@@ -174,6 +174,12 @@ for configFile in "${configFiles[@]}"
 do
 	echo Updating ${configFile}
 
+	if [ ${FLASH_VERSION} = "11.6" ]
+	then
+		updatePlayerVersion 11.6 "${configFile}"
+		updateSWFVersion 19 "${configFile}"
+	fi
+	
 	if [ ${FLASH_VERSION} = "11.5" ]
 	then
 		updatePlayerVersion 11.5 "${configFile}"



Mime
View raw message