fleece-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hendrik Dev <hendrikde...@gmail.com>
Subject Re: Do we (have to) support Java 1.6?
Date Sat, 12 Jul 2014 12:57:09 GMT
despite of the discussion i now reworked the code (see FLEECE-8) so
that it runs and compile either with apple java 1.6 and openjdk 1.6.
This is per se not a problem, because as Romain said we don't use (and
yet need no) java 7 features.
Don't know if apple java 1.6 and openjdk 1.6 is still supported?

Thanks
Hendrik

On Sat, Jul 12, 2014 at 1:01 PM, Christian Grobmeier
<grobmeier@gmail.com> wrote:
> Yesterday I read a mail bout Commons Logging dropping support for jdk 1.1
> (or 1.2? not sure)
>
> Fleece is lib too and now the question is how easily we can get rid of
> outdated jdks once
> we support it.
>
> If its like with Commons (support as long as possible) then we will stick
> with jdk1.6 for
> long, long time. In this case I would say just use 7.
>
> If people here are fine with having a sane end of life cycle, then I'd say
> support it,
> but drop support after Oracle dropped suppport (jdk 6 is already dropped):
>
> http://www.oracle.com/technetwork/java/eol-135779.html
>
> Please also have in mind that supporting outdated jdks means man power,
> which is maybe
> necessary else where in a small team.
>
> That being said, I wouldn't bother with jdk6 anymore. But well, i am not
> actively coding,
> its just my thoughts on the topic in general.
>
> regards
>
>
>
> On 12 Jul 2014, at 9:51, Romain Manni-Bucau wrote:
>
>> Hi
>>
>> We can if anyone consider it important since we dont use any jse7 features
>>
>> Wdyt?
>> Le 11 juil. 2014 22:46, "Hendrik Dev" <hendrikdev22@gmail.com> a écrit :
>>
>>> currently not, it looks like: https://travis-ci.org/salyh/fleece_master
>>>
>>> --
>>> Hendrik Saly (salyh, hendrikdev22)
>>> @hendrikdev22
>>> PGP: 0x22D7F6EC
>>>
>



-- 
Hendrik Saly (salyh, hendrikdev22)
@hendrikdev22
PGP: 0x22D7F6EC

Mime
View raw message