David,

Thanks for documenting all this. Would you be able to incorporate this into the wiki documentation. Let me know you're user ID and I will grant you the proper rights to do so.

Ed

On Fri, Oct 27, 2017 at 8:19 PM, David Engel <david@apf.solutions> wrote:
Hey All,

Sorry I didn't get to this until now. Thanks for the prompt information on the ActiveMQ dependency, this seems to have mostly solved my problems with the integration tests.

After installing and starting ActiveMQ I now am seeing only around 8 failures and 9 skips in the integration tests. For reference before the ActiveMQ install I was failing around 80%. The failing tests are:
  • ClientUndoRejectAndWithdrawalIntegrationTest.testClientUndoRejectWithFutureDate
  • ClientUndoRejectAndWithdrawalIntegrationTest.testClientUndoWithDrawnWithFutureDate
  • GroupSavingsIntegrationTest.testSavingsAccountCharges
  • SchedulerJobsTest.testSchedulerJobs
  • SchedulerJobsTestResults.testApplyHolidaysToLoansJobOutcome
  • ShareAccountIntegrationTests.rejectShareAccount
  • ShareAccountIntegrationTests.testShareAccountApproval
  • ShareAccountIntegrationTests.testShareAccountUndoApproval

Most of them are for reasons like

java.lang.AssertionError: 1 expectation failed.
Expected status code <400> doesn't match actual status code <403>.

There are a couple that fail for actual comparison reasons with incorrect dates and such. I'm hoping the above aren't due to using OpenJDK.

As for the API test, everything is a go! Got the MifosX web client up and running as well, going to look into the Android Client next. Thanks for all the help getting up and running folks! Looking forward to working with this project.

Michael, here are the steps I performed to get things working on Ubuntu 16.04 (well, the tests), note that I haven't tested the actual server yet, I'll report back on that as I mentioned above.
  1. Install MySQL (I'm using 5.6)
  2. Install JDK (I'm using OpenJDK 8)
  3. Install ActiveMQ. For this I tried following the new documentation but the command there didn't seem to work for me. I just went directly to the site and downloaded the tarball manually. Then extracted it and started the server as per those instructions.
  4. From here I just followed the instructions on the GitHub page to the tee. Ensure that ActiveMQ is not running, and neither is your TomCat server.
  5. Note, I also goofed and forgot that I don't have my port forwarding.
  6. Note that when you test the API if you followed the instructions here (https://cwiki.apache.org/confluence/display/FINERACT/Fineract+Installation+on+Ubuntu+Server) you have set up your TomCat server to run on port 443. However, in the API example it tells you to use 8443, so use 443, or change your TomCat config to use 8443. If this is the only server you're running you can omit the port altogether.
  7. If you want to use the MifosX web client all you should have to do after your API test is successful is follow step 4 from this link (https://mifosforge.jira.com/wiki/spaces/docs/pages/74711072/Mifos+X+Installation+on+Linux+-+Ubuntu+Server). Note, just use the fineract-provider.war file you already built, so you just need to copy api-docs and community-app.
Let me know if you have any questions.

Cheers,
David


On Tue, Oct 24, 2017 at 2:47 AM, michael chileshe <mchileshe@gmail.com> wrote:
Kindly update when fineract linux install will be update. 




--
Ed Cable
President/CEO, Mifos Initiative
edcable@mifos.org | Skype: edcable | Mobile: +1.484.477.8649

Collectively Creating a World of 3 Billion Maries | http://mifos.org