fineract-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Awasum Yannick <yannickawa...@gmail.com>
Subject Re: Question on building Mifos I/O
Date Sun, 20 Aug 2017 17:44:42 GMT
Ho Ramesh,

Are u sure your backend is running? Show me the log files for the backend.

Also Check your proxy.conf.json in the fims-web-app and make sure it points
to the right ports of the different services as shown by Eureka.

On Sat, Aug 19, 2017 at 9:18 AM, ramesh padmanabhan <
ramesh.padman2@gmail.com> wrote:

> I tried the small 'L' also and still cannot sign in.
> Attaching screen shot with more detail after last attempt:
>
> [image: Inline image 1]
>
> On Fri, Aug 18, 2017 at 10:39 PM, ayuk etta <ettaayuk@gmail.com> wrote:
>
>> That's small L .
>>
>> On 19 Aug 2017 04:25, "ramesh padmanabhan" <ramesh.padman2@gmail.com>
>> wrote:
>>
>>> Hi Markus,
>>>
>>> I tried Chrome also(earlier was on safari). screen shot attached.
>>> I was not sure of the password is init1@I or init1@l .......is it
>>> letter I or letter L ?  I tried both...screen shot of several attempts.
>>>
>>>
>>>
>>>
>>> [image: Inline image 1]
>>>
>>>
>>>
>>>
>>>
>>> On Fri, Aug 18, 2017 at 7:42 AM, Markus Geiss <markus.geiss@kuelap.io>
>>> wrote:
>>>
>>>> Hey Ramesh,
>>>>
>>>> what browser are you using? Currently we only prepare the web app for
>>>> Chrome to keep the build process fast ...
>>>>
>>>> If you use chrome can you please open the developer console (just hit
>>>> F12) and swtich to the network tab before you click the button Sign in ...
>>>>
>>>> If it fails you should see the call in red color ... if this is the
>>>> case please share the complete message that was returned ... so we can dive
>>>> deeper into your issue ...
>>>>
>>>> Cheers
>>>>
>>>> Markus
>>>>
>>>> On Fri, Aug 18, 2017 at 3:13 PM ramesh padmanabhan <
>>>> ramesh.padman2@gmail.com> wrote:
>>>>
>>>>> Sorry, but these credentials do not seem to work....
>>>>>
>>>>> tenant: playground
>>>>> User: operator
>>>>> Pass: init1@l
>>>>>
>>>>>
>>>>> On Fri, Aug 18, 2017 at 2:07 AM, ayuk etta <ettaayuk@gmail.com>
wrote:
>>>>>
>>>>>> Use this
>>>>>>
>>>>>> tenant: playground
>>>>>> User: operator
>>>>>> Pass: init1@l
>>>>>>
>>>>>> These credentials are default and binded somewhere in the code
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Aug 18, 2017 9:43 AM, "ramesh padmanabhan" <
>>>>>> ramesh.padman2@gmail.com> wrote:
>>>>>>
>>>>>> Thanks...
>>>>>>
>>>>>> Made some progress and got the  'Welcome to fims' screen up....
>>>>>>
>>>>>> username/password: mifos/password does not log me in.
>>>>>>
>>>>>> Anything else I should try ?
>>>>>>
>>>>>>
>>>>>> Ramesh
>>>>>>
>>>>>>
>>>>>> On Thu, Aug 17, 2017 at 6:39 AM, Markus Geiss <markus.geiss@kuelap.io
>>>>>> > wrote:
>>>>>>
>>>>>>> Hey Ramesh,
>>>>>>>
>>>>>>> given this a demo-server it will run until you stop it ...
>>>>>>>
>>>>>>> If you have a enough of it simply type exit and hit return.
>>>>>>>
>>>>>>> Cheers
>>>>>>>
>>>>>>> Markus
>>>>>>>
>>>>>>> On Thu, Aug 17, 2017 at 3:10 PM ramesh padmanabhan <
>>>>>>> ramesh.padman2@gmail.com> wrote:
>>>>>>>
>>>>>>>> Thanks Awasum,
>>>>>>>> You are right. I should have looked closer at the script
file also!
>>>>>>>>
>>>>>>>> I started the Java run and its been running for over 10 hours
now.
>>>>>>>> I am running this on my MacBook Air(1.8Ghz Intel).
>>>>>>>>
>>>>>>>> This was the second time I ran the build.
>>>>>>>> The first time it ran and failed saying 'test failed'.
>>>>>>>>
>>>>>>>>
>>>>>>>> Just wondering....how long has anyone seen this executable
take to
>>>>>>>> load all the Services ?
>>>>>>>>
>>>>>>>> Anyone else seen any failures like the one I noticed ?
>>>>>>>>
>>>>>>>>
>>>>>>>> Ramesh
>>>>>>>>
>>>>>>>>
>>>>>>>> On Wed, Aug 16, 2017 at 9:48 AM, Awasum Yannick <
>>>>>>>> yannickawasum@gmail.com> wrote:
>>>>>>>>
>>>>>>>>> Hello Ramesh,
>>>>>>>>>
>>>>>>>>> Looking at the script, there are three other sub folders
which
>>>>>>>>> hold microservices: core, tools, integration-tests.
>>>>>>>>> The rest of the services are on the root folder of your
script.
>>>>>>>>>
>>>>>>>>> So your demo-server is found in the 'integration-tests'
directory.
>>>>>>>>> There you can find the Jar file which you need to run.
>>>>>>>>>
>>>>>>>>> N.B: The script may have to be run several times due
to some
>>>>>>>>> dependency management issues.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> On Wed, Aug 16, 2017 at 3:47 PM, ramesh padmanabhan <
>>>>>>>>> ramesh.padman2@gmail.com> wrote:
>>>>>>>>>
>>>>>>>>>> Hi, I made progress after setting JAVA_HOME
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> FYI for MAC OSX/Unix users, below is how its done
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> export JAVA_HOME=$(/usr/libexec/java_home)
>>>>>>>>>>
>>>>>>>>>> But I see these errors at the end of the build: I
presume these
>>>>>>>>>> can be ignored ?
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> [ERROR] Error fetching link: http://testng.org/apidocs/pack
>>>>>>>>>> age-list. Ignored it.
>>>>>>>>>>
>>>>>>>>>> [ERROR] Error fetching link: http://java.net/projects/javam
>>>>>>>>>> oney/apidocs/package-list. Ignored it
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> I still cannot find a demo-server directory having
been created
>>>>>>>>>> at the end ?
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Any ideas ?
>>>>>>>>>>
>>>>>>>>>> p.s.  I did delete all previous directories/files
(except
>>>>>>>>>> install-script) and re-ran.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> thanks
>>>>>>>>>>
>>>>>>>>>> Ramesh
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> On Wed, Aug 16, 2017 at 3:18 AM, Markus Geiss <
>>>>>>>>>> markus.geiss@kuelap.io> wrote:
>>>>>>>>>>
>>>>>>>>>>> Hey Ramesh,
>>>>>>>>>>>
>>>>>>>>>>> first of all thanks for the effort.
>>>>>>>>>>>
>>>>>>>>>>> I missed the fact that you need to add the JAVA_HOME
variable to
>>>>>>>>>>> your environment variables.
>>>>>>>>>>>
>>>>>>>>>>> This is done differently depending on your operating
system, see
>>>>>>>>>>> here for more details:
>>>>>>>>>>>
>>>>>>>>>>> https://docs.oracle.com/cd/E19182-01/820-7851/inst_cli_jdk_j
>>>>>>>>>>> avahome_t/
>>>>>>>>>>>
>>>>>>>>>>> Cheers
>>>>>>>>>>>
>>>>>>>>>>> Markus
>>>>>>>>>>>
>>>>>>>>>>> PS: I'd suggest to delete everything that was
created by the
>>>>>>>>>>> script so far (the whole content of the folder
you've executed the script
>>>>>>>>>>> in, except the script itself (; ) and rerun it.
>>>>>>>>>>>
>>>>>>>>>>> On Wed, Aug 16, 2017 at 12:01 PM ramesh padmanabhan
<
>>>>>>>>>>> ramesh.padman2@gmail.com> wrote:
>>>>>>>>>>>
>>>>>>>>>>>> Hi Markus,
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> I tried following the instructions you had
laid out for
>>>>>>>>>>>> building Mifos Generation 3.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Had a few questions:
>>>>>>>>>>>>
>>>>>>>>>>>> - I presume for now I only execute the initial-setup.sh
script
>>>>>>>>>>>> and *not* the pull-all.sh script?
>>>>>>>>>>>>
>>>>>>>>>>>> - I get an error saying 'JAVA_HOME' is not
set. However java -v
>>>>>>>>>>>> on my machine shows me the latest downloaded
Java SDK8 that I installed
>>>>>>>>>>>>
>>>>>>>>>>>> - At the end of the script run, I cannot
find a 'demo-server'
>>>>>>>>>>>> directory having been created...
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Any ideas/feedback will help.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> thanks
>>>>>>>>>>>>
>>>>>>>>>>>> Ramesh
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> [ERROR] MavenReportException: Error while
creating archive:
>>>>>>>>>>>> Unable to find javadoc command: The environment
variable JAVA_HOME is not
>>>>>>>>>>>> correctly set.
>>>>>>>>>>>>
>>>>>>>>>>>> On Sun, Aug 13, 2017 at 2:51 AM, Markus Geiss
<mage@apache.org>
>>>>>>>>>>>> wrote:
>>>>>>>>>>>>
>>>>>>>>>>>>> Hey Ramesh,
>>>>>>>>>>>>>
>>>>>>>>>>>>> first of all, welcome to our community.
I need to apologize
>>>>>>>>>>>>> for the belated reply, but my email filters
weren't working properly so I
>>>>>>>>>>>>> just did not see your first request.
>>>>>>>>>>>>>
>>>>>>>>>>>>> As of today, Mifos I/O is a source only
release, so you'd need
>>>>>>>>>>>>> to meet some prerequisites before you
can start testing it.
>>>>>>>>>>>>>
>>>>>>>>>>>>>    1. Install Java SDK 8
>>>>>>>>>>>>>    2. Install Gradle
>>>>>>>>>>>>>    3. Install Maven
>>>>>>>>>>>>>    4. Install git
>>>>>>>>>>>>>    5. Install NodeJS (incl. npm)
>>>>>>>>>>>>>
>>>>>>>>>>>>> Once you have installed the mentioned
tools you need to:
>>>>>>>>>>>>>
>>>>>>>>>>>>>    1. Fork all repositories available
at
>>>>>>>>>>>>>    https://github.com/mifosio
>>>>>>>>>>>>>    2. Fork https://github.com/JavaMoney/javamoney-lib
>>>>>>>>>>>>>    3. You'll find a script to initialize
all resources on
>>>>>>>>>>>>>    your computer
>>>>>>>>>>>>>       1. The scripts are located in the
demo-server project
>>>>>>>>>>>>>       at scripts
>>>>>>>>>>>>>       2. Copy the initial-setup script
for your system into
>>>>>>>>>>>>>       the root directory where you want
all projects to be cloned into
>>>>>>>>>>>>>          1. The easiest way is to browse
to
>>>>>>>>>>>>>          https://github.com/mifosio/
>>>>>>>>>>>>>          demo-server/tree/develop/scripts/Unix
>>>>>>>>>>>>>          <https://github.com/mifosio/demo-server/tree/develop/scripts/Unix>
(windows)
>>>>>>>>>>>>>          and open the script in raw mode,
then selact all and copy and paste to file
>>>>>>>>>>>>>          on your disk
>>>>>>>>>>>>>       3. Run the script
>>>>>>>>>>>>>
>>>>>>>>>>>>> After you done this, there are two ways
to get started:
>>>>>>>>>>>>>
>>>>>>>>>>>>>    1. Run Mifos I/O locally
>>>>>>>>>>>>>       1. Navigate into the folder build/libs
under
>>>>>>>>>>>>>       demo-server on your machine
>>>>>>>>>>>>>          1. execute: java -Ddemoserver.provision=true
>>>>>>>>>>>>>          -jar demo-server-0.1.0-BUILD-SNAPSHOT.jar
>>>>>>>>>>>>>          2. Be aware this is a very heavy
process because all
>>>>>>>>>>>>>          services will get started locally
on your machine (10), and multiple data
>>>>>>>>>>>>>          source will be started in embedded
mode (Apache Cassandra, Apache ActiveMQ,
>>>>>>>>>>>>>          MySQL)
>>>>>>>>>>>>>          3. After the services all have
started simply
>>>>>>>>>>>>>          navigate to the root fims-web-app
folder and follow the steps mentioned in
>>>>>>>>>>>>>          the README
>>>>>>>>>>>>>       2. Run Mifos I/O on the Cloud:
>>>>>>>>>>>>>       1. Before you can start the microservices
you need to
>>>>>>>>>>>>>       provide resources that contains:
>>>>>>>>>>>>>          1. Apache Cassandra
>>>>>>>>>>>>>          2. Apache ActiveMQ
>>>>>>>>>>>>>          3. MySQL
>>>>>>>>>>>>>       2. Before you can push the services
into your cloud you
>>>>>>>>>>>>>       need to adjust the properties in
every application.yml for a service to
>>>>>>>>>>>>>       point to the above installed datasources
>>>>>>>>>>>>>       3. Every Microservice is build
with the capability to
>>>>>>>>>>>>>       run on a VM. For this simply copy
all microservice jar file to one or
>>>>>>>>>>>>>       multiple VMs and start them using
java -jar service-0.1.0-BUILD-SNAPS
>>>>>>>>>>>>>       HOT-boot.jar
>>>>>>>>>>>>>
>>>>>>>>>>>>> Just a kind reminder, Mifos I/O is not
ready to be used in a
>>>>>>>>>>>>> production environment and is still under
heavy development. We expect to
>>>>>>>>>>>>> have the frist functioning version ready
in approx. 8 weeks, until then
>>>>>>>>>>>>> some functionality will not be available
or work properly (e.g. checking
>>>>>>>>>>>>> accounts, individual loans).
>>>>>>>>>>>>>
>>>>>>>>>>>>> But any feedback is appreciated.
>>>>>>>>>>>>>
>>>>>>>>>>>>> Cheers
>>>>>>>>>>>>>
>>>>>>>>>>>>> Markus
>>>>>>>>>>>>>
>>>>>>>>>>>>> On Sun, Aug 13, 2017 at 2:14 AM ramesh
padmanabhan <
>>>>>>>>>>>>> ramesh.padman2@gmail.com> wrote:
>>>>>>>>>>>>>
>>>>>>>>>>>>>> Hi,
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Trying again to see if anyone can
help with tips for setting
>>>>>>>>>>>>>> up a Gen 3 environment ?
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> thanks
>>>>>>>>>>>>>> Ramesh
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> ---------- Forwarded message ----------
>>>>>>>>>>>>>> From: ramesh padmanabhan <ramesh.padman2@gmail.com>
>>>>>>>>>>>>>> Date: Tue, Aug 8, 2017 at 7:58 PM
>>>>>>>>>>>>>> Subject: Question on building Mifos
I/O
>>>>>>>>>>>>>> To: user@fineract.apache.org
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Hi everyone,
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> My name is Ramesh Padmanabhan. I
have recently signed up as a
>>>>>>>>>>>>>> Volunteer with Mifos.
>>>>>>>>>>>>>> My background is as an engineering
and product management
>>>>>>>>>>>>>> leader from Juniper Networks, Fortinet
and most recently at Facebook.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> I am looking forward to helping this
organization in whatever
>>>>>>>>>>>>>> way I can contribute. But I have
a lot to learn here first.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> As a first step, I am familiarizing
myself with the Mifos
>>>>>>>>>>>>>> environments and have played around
with the AWS instance of Mifos that I
>>>>>>>>>>>>>> was able to setup for the Gen 2 version.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> I am trying to figure out how to
get a Gen 3 Mifos I/O
>>>>>>>>>>>>>> environment setup in an AWS environment.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Any clues that you can share will
help me greatly.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> thanks
>>>>>>>>>>>>>> Ramesh
>>>>>>>>>>>>>>
>>>>>>>>>>>>> --
>>>>>>>>>>>>> Markus Geiss
>>>>>>>>>>>>> Chief Technology Officer, Kuelap, Inc.
<http://kuelap.io/>
>>>>>>>>>>>>> +49 1522 9505306 <+49%201522%209505306>
>>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>
>

Mime
View raw message