fineract-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thynn Win <thynn....@thitsaworks.com>
Subject RE: Pentaho Report in Mifos
Date Fri, 30 Sep 2016 03:13:45 GMT
Hi Mexina,

We were experiencing the same error and in our case, it's solved by changing the user to root
and put the report (prpt file) in /root/.mifosx/pentahoReports.

The tutorial or documentation suggested {user directory}/.mifosx/pentahoReports but it didn't
work for us and had to put the report under root path instead.

Best,
Thynn
ThitsaWorks, Inc



-----Original Message-----
From: Mexina M Daniel [mailto:mexina@singo.co.tz]
Sent: 27 September 2016 17:46
To: dev@fineract.incubator.apache.org<mailto:dev@fineract.incubator.apache.org>
Subject: Pentaho Report in Mifos


Hello devs

I created pentaho report in Pentaho Reporting Designer and want to use
it in Mifos X, I followed the steps from
https://mifosforge.jira.com/wiki/display/docs/Creating+Simple+Pentaho+
Report+and+Embedding+it+to+MifosX and was able to create the report to
the end but when i run the report i get a blank page.

Am using release 16.06.01 in Linux

I inspected from Developer tool and find this error


 1. {developerMessage: "The request caused a data integrity issue to be
    fired by the database.",...}
     1. defaultUserMessage:"Unable to create key: No loader was able to
        handle the given key data:
        /root/.mifosx/pentahoReports/Report_For_Mifos.prpt"
     2. developerMessage:"The request caused a data integrity issue to
        be fired by the database."
     3. errors:[{,...}]
         1. 0:{,...}
             1. args:[]
             2. defaultUserMessage:"Unable to create key: No loader was
                able to handle the given key data:
                /root/.mifosx/pentahoReports/Report_For_Mifos.prpt"
             3. developerMessage:"Unable to create key: No loader was
                able to handle the given key data:
                /root/.mifosx/pentahoReports/Report_For_Mifos.prpt"
             4. parameterName:null
             5. userMessageGlobalisationCode:"error.msg.reporting.error"
             6. value:null
     4. httpStatusCode:"403"
     5. userMessageGlobalisationCode:"error.msg.reporting.error"


what could it be the cause?

Thanks in advance.

--
Mexina M Daniel
Lead Software Developer
Research & Development

Tel:+255 222 618 511 | Mob: +255 712 110 791

Singo Africa Limited
Block G,Mbezi Beach B| 7 Nakawale Road| P.O.Box 78908| 14121 Dar es
Salaam

singo.co.tz

Lets grow together



--
Mexina M Daniel
Lead Software Developer
Research & Development

Tel:+255 222 618 511 | Mob: +255 712 110 791

Singo Africa Limited
Block G,Mbezi Beach B| 7 Nakawale Road| P.O.Box 78908| 14121 Dar es Salaam

singo.co.tz

Lets grow together


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message