fineract-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward Cable (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FINERACT-200) Separate Current Accounts from Savings Accounts
Date Tue, 23 Aug 2016 17:52:20 GMT

    [ https://issues.apache.org/jira/browse/FINERACT-200?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15433284#comment-15433284
] 

Edward Cable commented on FINERACT-200:
---------------------------------------

# How do we migrate the existing data? Also this will be a big effort to provide completely
new set of APIs and UI screens for Current account. Refactoring of existing code would be
required as overdraft is no more allowed on savings accounts. I feel it is unnecessary effort
at this moment, could this differentiation can be done with simple naming conventions at product/fee
level?
# Currently Savings/FD/RD are differentiated based on a account type flag. But they all share
the same charge definitions. Is the requirement here only to differentiate between Savings
and Current Accounts or there should be different definitions for Savings/FD/RD as well. On
the face of it, this change looks difficult. Again the same question of how do we mange existing
data.
# There aren't many savings reports. Is there any specific report that we are concerned about?

> Separate Current Accounts from Savings Accounts
> -----------------------------------------------
>
>                 Key: FINERACT-200
>                 URL: https://issues.apache.org/jira/browse/FINERACT-200
>             Project: Apache Fineract
>          Issue Type: Improvement
>            Reporter: Dayna Harp
>            Assignee: Markus Geiss
>            Priority: Minor
>
> https://mifosforge.jira.com/browse/MIFOSX-1361
> Current Accounts and Savings accounts are two different category of deposit products.
At least at the User Interface, these should be treated as two different products. At the
platform level, we should have a field that differentiate these (perhaps m_savings.product.deposit_type_enum
and m_savings_account.account_type_enum)
> Savings accounts should not allow overdraft and hence the parameters associated to overdraft
can be defaulted to null.
> Current accounts allow overdraft and overdraft limits and charges/interest for overdrafts.
Also they usually have zero interest rate, but we should retain the interest rate fields for
current account.
> Fees - should be separated out for current accounts and savings accounts.
> Also, need to be evaluated how this will impact savings reports.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message