fineract-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Carlson <dancarl...@gmail.com>
Subject Re: GSOC 2016 - Authentication on the Mifos REST API
Date Tue, 12 Jul 2016 07:07:13 GMT
Hi Nikhil, Terence,

I wanted to do this from within the code as it is part of the login service
for my app.

Terence that solved it thanks. Many heads are indeed better than one.

Cheers!
Daniel Carlson


On Tue, Jul 12, 2016 at 7:51 AM, Nikhil Pawar <nickrp89@gmail.com> wrote:

> Hey Daniel,
>
> Need not pass username and password as query parameter.(its not GET method)
> Try this:
>
> https://localhost:8443/fineract-provider/api/v1/offices?tenantIdentifier=default
>
> and then you will be asked for username and password.
>
> You can also use clients like Postman for chrome or RESTClient for mozilla
> for testing of REST API.
>
> Regards,
> Nikhil
>
> On Tue, Jul 12, 2016 at 12:06 PM, Daniel Carlson <dancarl758@gmail.com>
> wrote:
>
> > Hi Terence,
> >
> > Thanks but I already tried that.
> >
> > Cheers!
> > Daniel Carlson
> >
> > On Tue, Jul 12, 2016 at 7:34 AM, Terence Monteiro <
> > terence@sanjosesolutions.in> wrote:
> >
> > > Hi Daniel,
> > >
> > > The URL you used needs to have username=mifos&password=password so
> remove
> > > the extra %22 codes and try.
> > >
> > > --
> > > Best Regards,
> > > Terence Monteiro,
> > > Mob: +91 96633 13728
> > > www.sanjosesol.com
> > >
> > > <http://goog_1610728024>
> > > "Providence", No. 36,
> > > Ahmed Sait Road,
> > > Frazer Town, Bangalore - 5.
> > >
> > > On Tue, Jul 12, 2016 at 10:46 AM, Daniel Carlson <dancarl758@gmail.com
> >
> > > wrote:
> > >
> > > > Hi,
> > > >
> > > > I already have those.
> > > > When I use my local server, after installing a plugin to enable
> CORS, I
> > > get
> > > > a 500 error code
> > > > I am using this link locally:
> > > >
> > > >
> > >
> >
> https://localhost:8443/fineract-provider/api/authentication?username=%22mifos%22&password=%22password%22&tenantIdentifier=default
> > > > That is the link from within my code
> > > >
> > > > And when I try to connect to the online server using this:
> > > >
> > > >
> > >
> >
> https://demo.openmf.org/fineract-provider/api/authentication?username=%22mifos%22&password=%22password%22&tenantIdentifier=default
> > > >
> > > > I get a 401 which tells unauthorized but I just used the mifos and
> > > password
> > > > credentials to login.
> > > >
> > > > Cheers!
> > > > Daniel Carlson
> > > >
> > > > On Tue, Jul 12, 2016 at 6:03 AM, Shreyaank Byadagi <
> > > > shreyaank@confluxtechnologies.com> wrote:
> > > >
> > > > > Hi Daniel ,
> > > > >
> > > > > please add following headers in REST client
> > > "Fineract-Platform-TenantId:
> > > > > default" and "Content-Type: application/Json"
> > > > >
> > > > > Regards
> > > > > Shreyaank
> > > > > On 12-Jul-2016 10:29 AM, "Shreyaank Byadagi" <
> > > > > shreyaank@confluxtechnologies.com> wrote:
> > > > >
> > > > > > Hi Daniel,
> > > > > > To which server your communicating ? Demo server or local server
> > > > > >
> > > > > > Regards
> > > > > > Shreyaank
> > > > > > On 12-Jul-2016 10:01 AM, "Daniel Carlson" <dancarl758@gmail.com>
> > > > wrote:
> > > > > >
> > > > > >> Hi all,
> > > > > >>
> > > > > >> For my Google Summer of Code project for this year, I need
to
> get
> > > data
> > > > > >> from
> > > > > >> the Mifos platform. To that, according to the REST API
> > > documentation,
> > > > I
> > > > > >> have to authenticate that request by by using a basic
> > authentication
> > > > key
> > > > > >> which I then used to make my requests.
> > > > > >> I have used this link:
> > > > > >>
> > > > > >>
> > > > >
> > > >
> > >
> >
> https://demo.openmf.org/fineract-provider/api/authentication?username=mifos&password=password&&tenantIdentifier=default
> > > > > >>
> > > > > >> but I get CORS errors despite my header configurations which
I
> > > copied
> > > > > from
> > > > > >> the community app.
> > > > > >> So I setup my local server and used this link:
> > > > > >>
> > > > > >>
> > > > >
> > > >
> > >
> >
> https://localhost:8443/fineract-provider/api/authentication?username=mifos&password=password&&tenantIdentifier=default
> > > > > >>
> > > > > >> Now I get a 500 error code on Firefox and on Chrome I still
get
> a
> > > CORS
> > > > > >> error
> > > > > >>
> > > > > >> Any help with this please?
> > > > > >>
> > > > > >> Cheers!
> > > > > >> Daniel Carlson
> > > > > >>
> > > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message