fineract-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vorbur...@apache.org
Subject [fineract] branch develop updated: upgrade OpenJPA from 3.1.0 to 3.1.1 (FINERACT-908)
Date Sat, 02 May 2020 20:42:19 GMT
This is an automated email from the ASF dual-hosted git repository.

vorburger pushed a commit to branch develop
in repository https://gitbox.apache.org/repos/asf/fineract.git


The following commit(s) were added to refs/heads/develop by this push:
     new 8418dd4  upgrade OpenJPA from 3.1.0 to 3.1.1 (FINERACT-908)
8418dd4 is described below

commit 8418dd424f11c8e6ecd7d323852abab43053a56f
Author: Michael Vorburger <mike@vorburger.ch>
AuthorDate: Sat May 2 15:58:03 2020 +0200

    upgrade OpenJPA from 3.1.0 to 3.1.1 (FINERACT-908)
---
 fineract-provider/build.gradle | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/fineract-provider/build.gradle b/fineract-provider/build.gradle
index 955375f..508a441 100644
--- a/fineract-provider/build.gradle
+++ b/fineract-provider/build.gradle
@@ -25,7 +25,6 @@ project.ext.jerseyVersion = '1.17'
 
 buildscript {
     ext {
-        openJPAVersion = '3.1.0'
         jacocoVersion = '0.8.5'
     }
     repositories {
@@ -41,7 +40,7 @@ buildscript {
             'org.zeroturnaround:gradle-jrebel-plugin:1.1.2',
             'org.springframework.boot:spring-boot-gradle-plugin:2.2.4.RELEASE'
         // below
-        classpath "org.apache.openjpa:openjpa:$openJPAVersion"
+        classpath 'org.apache.openjpa:openjpa:3.1.1' // when upgrading, also change OpenJPA
version repeated below in dependencyManagement!
         classpath 'com.radcortez.gradle:openjpa-gradle-plugin:3.1.0'
         classpath 'gradle.plugin.org.nosphere.apache:creadur-rat-gradle:0.2.2'
         classpath "com.github.spotbugs:spotbugs-gradle-plugin:2.0.1"
@@ -79,7 +78,7 @@ dependencyManagement {
 
     dependencies {
         dependency 'org.springframework.security.oauth:spring-security-oauth2:2.3.6.RELEASE'
-        dependency 'org.apache.openjpa:openjpa:3.1.0'
+        dependency "org.apache.openjpa:openjpa:3.1.1" // when upgrading, also change OpenJPA
version repeated above in buildscript!
         dependency 'com.squareup.retrofit:retrofit:1.6.1'
         dependency 'com.squareup.okhttp:okhttp:2.0.0'
         dependency 'com.squareup.okhttp:okhttp-urlconnection:2.0.0'


Mime
View raw message