felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Subrahmanyam Sistha <subbu.sis...@gmail.com>
Subject Configure resolution:=optional from maven bundle plugin
Date Fri, 31 Aug 2018 15:15:03 GMT
I need help to configure  a dependency as optional, 

Using maven-bundle-plugin:3.4.0,   

In the Import-packages section, they refereed as resolution:optional   


<plugin>
        <groupId>org.apache.felix</groupId>
        <artifactId>maven-bundle-plugin</artifactId>
        <version>3.4.0</version>
        <extensions>true</extensions>
        <executions>
                <execution>
                <id>bundle-manifest</id>
                <phase>process-classes</phase>
                <goals>
                    <goal>manifest</goal>
                </goals>
                <configuration>
                        <instructions>
                                <Export-Package>*</Export-Package>
                                <Import-Package>
                                        org.junit.*;/resolution=optional/, 
                                       
junit.framework.*;/resolution=optional/ 
                                </Import-Package>
                                <_nouses>true</_nouses>
                        </instructions>
                </configuration>
        </execution>
   </executions>
</plugin>


Expectation is generated OSGI manifest file should contains the 
resolution:=optional for that library but the changes not reflecting. 

Expectation : 
junit.framework;resolution:=optional 

but in generated manifest file 
junit.framework 

Did i miss any configuration to reflect it resolution as optional in the 
generated manifest file? 

On investigation Maven-Bundle-Plugin, BundlePlugin.java File, I realized 
that if the artifact contains the optional true then reflected in the 
generated manifest file as resolution:=optional 

<dependency>
   <groupId>junit</groupId>
   <artifactId>junit</artifactId>
    
   <scope>provided</scope>
   <optional>true</optional>
</dependency>


But the previous solution should work according to the BundlePlugin.java 
source code, 

Please guide me to proceed further. 



--
Sent from: http://apache-felix.18485.x6.nabble.com/Apache-Felix-Users-f4833200.html

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message