felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neil Bartlett <njbartl...@gmail.com>
Subject Re: Resolving to micro version
Date Tue, 03 Apr 2018 21:27:56 GMT

> On 3 Apr 2018, at 22:17, Katsuya Tomioka <katsuya.tomioka@gmail.com> wrote:
> 
> Felix users,
> 
> I have same bundles (say "A") installed only different by micro versions,
> 7.24.0 and 7.24.100. I have then another ("B") imports packages from "A"
> such that: "[7.24.0,7.24.1)". This works fine if I installed 7.24.0 only.
> But soon as 7.24.100 installed, the bundle B fails to resolve with
> unresolved requirements.
> 
> Would that be possible to resolve the bundle B even with both versions of A
> installed? Or is even allowed in the spec?

This is definitely possible.

Please post the actual error message so that we can work out what is happening. It would also
be helpful to see:

* the list of bundles;
* the exact exports of the “A” bundles, and;
* the exact imports of the “B” bundle.

Regards,
Neil


> 
> Thanks,
> 
> -Katsuya


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message