felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kerry <karaf-u...@avionicengineers.com>
Subject Override Require-Capability in Maven-Bundle-Plugin
Date Tue, 12 Dec 2017 17:58:46 GMT
Hi,

First of all I have asked this question already on StackOverflow so apologies for 'duplicating'
:

https://stackoverflow.com/questions/47738402/override-require-capability-in-maven-bundle-plugin

I short, the Maven bundle plugin is duplicating my 'Require-Capability' headers I manually
set in the plugin configuration. This is because the plugin is auto-generating the same headers
as well as including my own manually set ones. I need to override the 'resolution' attribute
to become optional (this is probably not ideal but it's the only way I can create a single
Apache Karaf feature to install all my own bundles and other features and not fail on deploy).

Is there a way I can get the plugin to merge or use my manually specified 'Require-Capability'
headers?

Thanks

Kerry


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message