felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From o haya <oh...@yahoo.com.INVALID>
Subject Re: Getting "Unsupported major.minor version 52.0" when build using Eclipse
Date Tue, 31 Oct 2017 06:01:07 GMT
Hi,

As I said below, I know that I compiled with JDK 1.7 (that is the only JDK that is now on
the build machine), so that is why I am puzzled.

Thanks,
Jim

--------------------------------------------
On Tue, 10/31/17, Bernd Eckenfels <ecki@zusammenkunft.net> wrote:

 Subject: Re: Getting "Unsupported major.minor version 52.0" when build using Eclipse
 To: "users@felix.apache.org" <users@felix.apache.org>
 Date: Tuesday, October 31, 2017, 1:22 AM
 
 The error means you compiled
 classes with Java 8, looks like OAM is Java 7 (or older?).
 This is not really related to Felix or OSGi
 
 Gruss
 Bernd
 --
 http://bernd.eckenfels.net
 ________________________________
 From:
 o haya <ohaya@yahoo.com.INVALID>
 Sent: Tuesday, October 31, 2017 6:16:49 AM
 To: users@felix.apache.org
 Cc: ohaya@yahoo.com
 Subject: Getting "Unsupported major.minor
 version 52.0" when build using Eclipse
 
 Hi,
 
 I am working on a plugin for Oracle Access
 Manager (OAM), which I believe uses Felix.
 
 I originally built (compiled
 and JARed) the plugin using Netbeans 8.02 and got it
 working, but I was asked to now build this plugin using
 Eclipse.
 
 I figured that
 shouldn't be a problem, but when I built the plugin, it
 would not "activate" and the logging showed:
 
 java.lang.reflect.InvocationTargetException
         at
 sun.reflect.NativeMethodAccessorImpl.invoke0(Native
 Method)
         at
 sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
         at
 sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
         at
 java.lang.reflect.Method.invoke(Method.java:606)
         at
 oracle.security.am.plugin.internal.OSGIPluginService.installAndStartBundle(OSGIPluginService.java:179)
         at
 oracle.security.am.extensibility.lifecycle.messaging.NodeMessageListener.installAndStartBundle(NodeMessageListener.java:66)
         at
 oracle.security.am.extensibility.lifecycle.messaging.NodeMessageListener.receiveMessage(NodeMessageListener.java:112)
         at
 oracle.security.am.extensibility.lifecycle.messaging.NodeMessageListener.receiveMessageList(NodeMessageListener.java:49)
         at
 oracle.security.am.extensibility.lifecycle.messaging.MessageListenerWrapper.objectCreated(MessageListenerWrapper.java:30)
         at
 oracle.security.am.foundation.mapimpl.coherence.events.MapListenerWrapper.notifyListener(MapListenerWrapper.java:174)
         at
 oracle.security.am.foundation.mapimpl.coherence.events.EventDispatcher.dispatch(EventDispatcher.java:132)
         at
 oracle.security.am.foundation.mapimpl.coherence.events.EventDispatcher.run(EventDispatcher.java:114)
 Caused By: org.osgi.framework.BundleException:
 Activator start error in bundle GxOamResponsePlugin [2].
         at
 org.apache.felix.framework.Felix.activateBundle(Felix.java:2202)
         at
 org.apache.felix.framework.Felix.startBundle(Felix.java:2070)
         at
 org.apache.felix.framework.BundleImpl.start(BundleImpl.java:976)
         at
 org.apache.felix.framework.BundleImpl.start(BundleImpl.java:963)
         at
 sun.reflect.NativeMethodAccessorImpl.invoke0(Native
 Method)
         at
 sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
         at
 sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
         at
 java.lang.reflect.Method.invoke(Method.java:606)
         at
 oracle.security.am.plugin.internal.OSGIPluginService.installAndStartBundle(OSGIPluginService.java:179)
         at
 oracle.security.am.extensibility.lifecycle.messaging.NodeMessageListener.installAndStartBundle(NodeMessageListener.java:66)
         at
 oracle.security.am.extensibility.lifecycle.messaging.NodeMessageListener.receiveMessage(NodeMessageListener.java:112)
         at
 oracle.security.am.extensibility.lifecycle.messaging.NodeMessageListener.receiveMessageList(NodeMessageListener.java:49)
         at
 oracle.security.am.extensibility.lifecycle.messaging.MessageListenerWrapper.objectCreated(MessageListenerWrapper.java:30)
         at
 oracle.security.am.foundation.mapimpl.coherence.events.MapListenerWrapper.notifyListener(MapListenerWrapper.java:174)
         at
 oracle.security.am.foundation.mapimpl.coherence.events.EventDispatcher.dispatch(EventDispatcher.java:132)
         at
 oracle.security.am.foundation.mapimpl.coherence.events.EventDispatcher.run(EventDispatcher.java:114)
 Caused By:
 java.lang.UnsupportedClassVersionError:
 oam/plugin/GxOamResponsePlugin : Unsupported major.minor
 version 52.0
         at
 java.lang.ClassLoader.defineClass1(Native Method)
         at
 java.lang.ClassLoader.defineClass(ClassLoader.java:803)
         at
 org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.findClass(BundleWiringImpl.java:2313)
         at
 org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1519)
         at
 org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:77)
         at
 org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1988)
         at
 java.lang.ClassLoader.loadClass(ClassLoader.java:358)
         at
 org.apache.felix.framework.BundleWiringImpl.getClassByDelegation(BundleWiringImpl.java:1392)
         at
 org.apache.felix.framework.Felix.createBundleActivator(Felix.java:4335)
         at
 org.apache.felix.framework.Felix.activateBundle(Felix.java:2147)
         at
 org.apache.felix.framework.Felix.startBundle(Felix.java:2070)
         at
 org.apache.felix.framework.BundleImpl.start(BundleImpl.java:976)
         at
 org.apache.felix.framework.BundleImpl.start(BundleImpl.java:963)
         at
 sun.reflect.NativeMethodAccessorImpl.invoke0(Native
 Method)
         at
 sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
         at
 sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
         at
 java.lang.reflect.Method.invoke(Method.java:606)
         at
 oracle.security.am.plugin.internal.OSGIPluginService.installAndStartBundle(OSGIPluginService.java:179)
         at
 oracle.security.am.extensibility.lifecycle.messaging.NodeMessageListener.installAndStartBundle(NodeMessageListener.java:66)
         at
 oracle.security.am.extensibility.lifecycle.messaging.NodeMessageListener.receiveMessage(NodeMessageListener.java:112)
         at
 oracle.security.am.extensibility.lifecycle.messaging.NodeMessageListener.receiveMessageList(NodeMessageListener.java:49)
         at
 oracle.security.am.extensibility.lifecycle.messaging.MessageListenerWrapper.objectCreated(MessageListenerWrapper.java:30)
         at
 oracle.security.am.foundation.mapimpl.coherence.events.MapListenerWrapper.notifyListener(MapListenerWrapper.java:174)
         at
 oracle.security.am.foundation.mapimpl.coherence.events.EventDispatcher.dispatch(EventDispatcher.java:132)
         at
 oracle.security.am.foundation.mapimpl.coherence.events.EventDispatcher.run(EventDispatcher.java:114)
 
 I have tried to set the
 compatibility in Eclipse to 1.7 and even uninstalled all
 Java versions and Eclipse and also installed JDK 1.7 and
 re-installing Eclipse and then rebuilt the plugin, but still
 get the same error.
 
 Also, I
 used javap -verbose to check the Java classes that got built
 and they are all "51" or Java 1.7.  From the
 logging above it seems like something to do with the
 classloader.  Is there some parameter I need to use in the
 MANIFEST.MF or something like that?
 
 Thanks,
 Jim
 
 ---------------------------------------------------------------------
 To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
 For additional commands, e-mail: users-help@felix.apache.org
 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message