felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gabriel Ferreira <gabriel.fbsousa...@gmail.com>
Subject Question about the tutorial "Using Distributed Services with iPOJO"
Date Wed, 17 Feb 2016 18:43:54 GMT
Good evening,

I'm Gabriel, a brazilian student. I tried to study iPOJO, in order to
understand how it can help to create and use distributed services. The
first tutorial I found was "Using Distributed Services with iPOJO", from
the Felix iPOJO documentation, in the following link:

http://felix.apache.org/documentation/subprojects/apache-felix-ipojo/apache-felix-ipojo-gettingstarted/apache-felix-ipojo-dosgi.html

However, when I tried to follow the steps, I had two problems.

The first of them happened when I tried to install/activate the
ServiceProvider bundle to the Server side, with the following line:

*start file:../AdderServiceProvider/target/AdderServiceProvider-0.0.1-SNAPSHOT.jar*

The result I got from it was:


[image: Imagem inline 1]

I don't know how to solve this problem. And since it doesn't work, the
service is not available at http://localhost:9090/adder?wsdl.

The second problem I got was when trying to install/activate the
ServiceImporter bundle into the Client side, with the following line:

*start file:../AdderServiceImporter/target/AdderServiceImporter-0.0.1-SNAPSHOT.jar*

I got the following result from it:


[image: Imagem inline 3]

I think it's important to say that I followed exactly what the tutorial
described, using the exact same felix and packages given in the tutorial. I
even tried to follow the steps on a different Operational System. Anyone
could please give me a hint in what to do to solve these problems?

Thank you,

Gabriel

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message